OrangePI Club

Full Version: RetrOrangePi 4.1 - Orange Pi Zero GPIO - Getting GPIO to work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi everyone,
I am trying get the GPIO controls to work. I activated GPIO controls in RetroOrangePi menu and tried both the NES and TZ options. Nothing happens when I gorund the respective control pins. I tried rebooting, reactivating the option etc. Is there anything wrong I am doing?

Edit: When I reinstall TZ_GAMES_SP it says "ADD the line uinput in the /etc/modules". What exactly should I add to /etc/modules?
actually anything, it works, BUT only 40-pin GPIO afaik. It's likely to work on the OPi zero as soon as we tweak the python script (hopefully)
Can you give me some guidance so that I can tweak the code myself?
edit ~/RetrOrangePi/GPIO/drivers/ and change pin bind (PA1, PD14 etc)
(05-15-2018, 10:58 AM)alexkidd Wrote: [ -> ]edit ~/RetrOrangePi/GPIO/drivers/ and change pin bind (PA1, PD14 etc)

The button assignments are already correct in that file. I tried grounding PA6 and PA1 (up and down) and nothing happened.
what does "sudo service tz_gpio status" say?

how exactly are you "grounding" the buttons?
The following is the output of "sudo service tz_gpio status":
Quote:pi@RetrOrangePi:~$ sudo service tz_gpio status
   Loaded: loaded (/lib/systemd/system/tz_gpio.service; enabled)
   Active: active (running) since Tue 2018-05-15 11:51:36 BST; 1h 25min ago
 Main PID: 745 (python)
   CGroup: /system.slice/tz_gpio.service
           └─745 /usr/bin/python /home/pi/RetrOrangePi/GPIO/drivers/ > /home/pi/RetrOrangePi/GPIO/drivers/tz_gpio_controller.log

May 15 11:51:36 RetrOrangePi systemd[1]: Starting RETRORANGEPI CONTROLLER...
May 15 11:51:36 RetrOrangePi systemd[1]: Started RETRORANGEPI CONTROLLER.

I am manually connecting (touching) the respective pin to ground using a wire.
this is how i connect, one wire goes from COM to GPIO assigned pin , ground chain wire goes from NO to GND GPIO pin



NOTE: never tested in OrangePi Zero btw
What difference does it make as long as both pins are connected through a conductor? BTW, connecting using a piece of wire works perfectly on a Raspberry Pi Zero. Is there anything else I need to do? Have I missed a step? Please help.
We still have to test the Orange pi Zero to be able to help.
Pages: 1 2