Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,724
» Latest member: Packing Materials
» Forum threads: 815
» Forum posts: 4,379

Full Statistics

Online Users
There are currently 40 online users.
» 1 Member(s) | 39 Guest(s)
ramonpks

Latest Threads
How to run Scummvm games ...
Forum: Retrostone
Last Post: ramonpks
27 minutes ago
» Replies: 0
» Views: 2
the banana pi m2+ rev 1.1
Forum: HARDWARE DISCUSSION
Last Post: alexkidd
1 hour ago
» Replies: 3
» Views: 34
v4.2 version no lr-fba-pl...
Forum: RetrOrangePi v4.2 version
Last Post: gxb
8 hours ago
» Replies: 5
» Views: 64
New image - Sep 5th
Forum: Retrostone
Last Post: bedfellow
10-14-2018, 03:20 PM
» Replies: 66
» Views: 4,161
retrorange pi shaders
Forum: RetrOrangePi v4.2 version
Last Post: kalicci
10-14-2018, 12:46 AM
» Replies: 2
» Views: 34
Possible to add new port?
Forum: Retrostone
Last Post: doogin
10-13-2018, 12:57 AM
» Replies: 4
» Views: 113
USB roms feature
Forum: RetrOrangePi v4.2 version
Last Post: alexkidd
10-12-2018, 10:47 PM
» Replies: 14
» Views: 2,828
A single .PBP file is ign...
Forum: RetrOrangePi v4.2 version
Last Post: alexkidd
10-12-2018, 11:18 AM
» Replies: 1
» Views: 44
WiFi Dongle
Forum: Retrostone
Last Post: bouboulover
10-12-2018, 09:56 AM
» Replies: 22
» Views: 998
v4.2 SLIM RELEASE
Forum: RetrOrangePi v4.2 version
Last Post: genzi0401
10-12-2018, 03:37 AM
» Replies: 28
» Views: 3,600

 
  RetrOrange Pi 4.0 (update from 3.0.1)
Posted by: alexkidd - 11-01-2017, 02:20 PM - Forum: README FIRST! - Replies (9)

Hello guys,
 
As expected by the vast majority of users, ROPi 3.0.1 to 4.0 update will work by script, without the need of reflashing your sdcard all over again. We hope this version to be more user-friendly and easily upgradable.
 
Full images will take a little more time to be available, as Harryzimm has been VERY busy with real life lately. We hope to read your feedback on our forums soon, so we can fix any bug before flashing the final images.
 
The automated script will backup your configs, keeping your roms and metadata intact, so you should not be worried (too much). If your data is very unique, it’s wiser to backup Big Grin
 
Update instructions :
 

  1. Quit to terminal (from EmulationStation start menu or simply by pressing F4).
  2. Download the updater: wget http://www.retrorangepi.org/ropi4.sh
  3. Give it execute permission: sudo chmod +x ropi4.sh
  4. Run it: sudo -u pi ./ropi4.sh
 
NOTES:
  1. Make sure you have 1GB of free space, before running the update. Script will remove update files after completion , so don’t worry.
  2. It’s possible to update from SSH. Please log with user pi , not root (ever)
If all goes well, you should get a confirmation at the end asking you to reboot your board.

Print this item

  OPi Plus WiFi & X360 JoyPad
Posted by: niarbagem - 10-31-2017, 10:12 AM - Forum: Hardware compatibility - No Replies

Good day!

WiFi (RTL8189ETV) on my Orange Pi Plus don't work. When i've tried add Wifi connection through gui connection manager adapter havn't seen.
Haven't seen it on dmesg yet. Does it supported "from box" or manual installation only?

I have Logitech cordless RumlbePad 2 and XBOX 360 pad with chinese receiver, both works well and configured without problem, but when i'd tried to play with 2 players SNES DKC 1 i've seen title "XBOX pad configured to port #3" and don't work in game. But it works in DKC2. 

How i can configure it to port #2?

Print this item

Question dual purpose gpio
Posted by: dragoon - 10-31-2017, 09:16 AM - Forum: General Discussion - Replies (1)

is it possible to have two function for gpio... for example... in emulation station, certain gpio works as d-pad, and when in desktop it functions as mouse cursor control...

sorry for noobie uestion, i very little knowledge in programming... it will be bbeeficial for handheld projects

Print this item

  OrangePi 2G IoT Raspian booting problems
Posted by: atmax - 10-28-2017, 04:54 PM - Forum: DIY Practical Questions - No Replies

Hey OrangePi Club

I have downloaded Raspbian Server (http://www.orangepi.org/download ... 367e8175b1c992.html) and flashed it on a Class 10 Micro SD-HC with 8GB. I connects itself to a hotspot where the SSID and the PSK are both 'orangepi'. A few seconds after the connection to the hotspot is established I am able to ping my OrangePi (I assume SSH could also work but within that timewindow i wasn't yet able to connect). But then someting crashes and the OrangePi doesn't respond at all. 

And now I don't really know what to do Sad  I would love to give you guys the serial debug output, but that doesnt't work. I am using a CH340G USB to TTL adapter with a BAUD Rate of both 511200 and 921600. Tried it with Putty and kermit, but there is just no output. But as an alternative I can offer you a dump from all the files from /var/log/messages, you can get them from here: https://mega.nz/#!2c8nzaoB!8X8sO6GTuoH-i...1sVhToiALY . Does anyone have an idea how I could solve this problem?? Please let me know

Print this item

Rainbow Retro-bit ATARI usb adapter support
Posted by: canadien - 10-19-2017, 04:46 PM - Forum: Support area - No Replies

Hi,

Is it possible to support this adapter :
[Image: atari_to_usb01.jpg?t=1433489911]

Right now only right and down work. It doesn't register left or up.

I've read that the problem are the drivers that have not been updated, hence on the original RetroPie it need a kernel mod to be fully functional: https://www.raspberrypi.org/forums/viewt...t&start=25



I also found those links that can be useful:
https://github.com/robmcmullen/hid-atari-retrobit
https://github.com/msteinbeck/hid-retrobit

Thanks for the heads-up!

Print this item

  hcitool process consumes 100% CPU
Posted by: greenais - 10-18-2017, 07:27 PM - Forum: Support area - Replies (2)

Hey guys, 
strange thing I noticed in htop:
once I start from ES menu dosbox emulation or ES package install there starts root process which loads one CPU core for ~100%.

Code:
/bin/sh -c while true; do hcitool con | grep -q "$mac" || echo "connect $mac" | blutooth


Terminating it makes no difference on system functionality - both my PS3 BT-connect controllers stay full operational

What is purpose of this process and how could I disable it from unnecessary spawning (as it makes no sense)?


BTW, even if menu background music is switched off in settings the process

Code:
 python bgmusic.py
 
 is still there (I assume it authostarts somewhere) and - which is quite noticeable - it consumes 7-10% of CPU for nothing
Renaming music dir solves the issue)

Print this item

  dosbox segfaults in 3.0.1
Posted by: greenais - 10-16-2017, 08:35 AM - Forum: Support area - Replies (2)

Hi, 

It seems that dosbox is broken in 3.0.1 - while started from desktop environment it segfaults:

Code:
pi@RetrOrangePi:~$ dosbox
dosbox: /usr/local/lib/libpng17.so.17: no version information available (required by dosbox)
DOSBox version 0.74-ES
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file /home/pi/.dosbox/dosbox-0.74-ES.conf
OpenGL-ES
Vendor: (null)
Renderer: (null)
Version: (null)
Shader Version: (null)
Segmentation fault

Forcing dosbox to create a fresh .conf file  doesn't help - segfault again
Fresh ROPI 3.0.1 installation, OP+2E board.

Meanwhile in plain console (no X started, ctrl-F4 at ROPI start) - it works but without any -es graphic acceleration, off cause  Sad
Any ideas, guys?

Print this item

  123 HP Setup
Posted by: anoopkumar77 - 10-05-2017, 04:09 AM - Forum: Hardware - No Replies

The template for all modern computers is the Von Neumann architecture, detailed in a 1945 paper by Hungarian mathematician John von Neumann. This describes a design architecture for an electronic digital computer with subdivisions of a processing unit consisting of an arithmetic logic unit and processor registers, a control unit containing an instruction register and program counter, a memory to store both data and instructions, external mass storage, and input and output mechanisms.[2] The meaning of the term has evolved to mean a stored-program computer in which an instruction fetch and a data operation cannot occur at the same time because they share a common bus. This is referred to as the Von Neumann bottleneck and often limits the performance of the system

Print this item

  PC+ Booting problem
Posted by: OldBikerPete - 09-25-2017, 10:51 AM - Forum: Hardware - Replies (1)

Hello, I'm a noob. Have only had my Pi's for a couple of days. Have downloaded OS's and utilities from OrangePi main site and am trying to load up an operating system. I've been using Raspberry Pi for a while now, so I know how that gets done but I've struck a problem.
I've burnt three different OS's onto my SD card but they all seemed to produce the same chinese-language Android OS.

My sluggish brain finally decided that I should try to boot the Pi without the SD card in.  Unsurprisingly the card booted to exactly the same OS.

Clearly there is already an Android OS on the Pi's EMMC onboard memory and the boot procedure is ignoring the SD card.
Has anyone seen this problem?  An obvious cause could be that the SD card reader is faulty (the SD card reads/writes just fine in other machines).
Doe anyone have a workaround?

Peter.

Print this item

  RT8192EU usb-wifi module problem
Posted by: mrxiong - 09-11-2017, 06:23 PM - Forum: Hardware compatibility - Replies (4)

Hello guys! Sorry for disturbing, i have not so much experience with compiling something, but maybe you can show me the right way.

What I have:

I have an OPI PC, an usb-wifi dongle TP-LINK TL-WN823N V2 which have 8192eu chipset (at least google says me that) and ROPi 3.0.1 image running. There is no 8192eu support out of the box, so I tried to compile it by myself.

I performed commands like this:

Code:
git clone https://github.com/Mange/rtl8192eu-linux-driver
cd rtl8192eu-linux-driver
make clean
make ARCH=arm
make install

After that, it's appears 8192eu.ko file within directory :/lib/modules/3.4.113-RetrOrangePi--sun8i/kernel/drivers/net/wireless/. then running
Code:
depmod -ae

Then I type 
Code:
sudo modprobe 8192eu

and got this error:

modprobe: ERROR: could not insert '8192eu': Exec format error

Code:
dmesg | tail

telling me "8192eu: disagrees about version of symbol module_layout".

Some google research make me think that I'm using wrong version of linux headers, but linux headers as I understand are similar to the kernel of ROPi:
Code:
uname -r
3.4.113-RetrOrangePi--sun8i

Code:
ls /usr/src/
linux-headers-3.4.113-sun8i
mt7601-3.0.0.4

What am I doing wrong? Maybe there is any other way to start this dongle? Thanks in advance!

Print this item