OrangePI Club
Kodi videos wont play - Printable Version

+- OrangePI Club (http://orangepi.club)
+-- Forum: International (English) Forums (http://orangepi.club/forumdisplay.php?fid=3)
+--- Forum: *nix Distro (http://orangepi.club/forumdisplay.php?fid=4)
+---- Forum: RetrOrangePi v4 (http://orangepi.club/forumdisplay.php?fid=31)
+----- Forum: SUPPORT (http://orangepi.club/forumdisplay.php?fid=34)
+----- Thread: Kodi videos wont play (/showthread.php?tid=2508)

Pages: 1 2 3


RE: Kodi videos wont play - alexkidd - 05-06-2018

btw, just checked OPi Lite image, and OpenELEC is there:

[attachment=170]


RE: Kodi videos wont play - DeJaVu - 05-06-2018

I cant even beleive i can be so blind, Openelec was in the start menu after all, i cant figure how could i imissed it, its been hiding in plain sight.
Ok, lack of sleep showed its teeth, i was planning to deal with this tomorrow morning, you shouldnt reply so fast, you got me hooked TongueSmile.
It does work and much smoother than the modern kodi interface, but it would be nice to have kodi working too as it is bit more convenient than openelec at least in my eyes.

sudo find /usr -name libGL.so.1 found the file at 2 spots
adding just /usr/lib/GLSHIM/libGL.so.1 didnt help ,
but when i added both locations and the line looked like this - "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib/arm-linux-gnueabihf/libGL.so.1:/usr/lib kodi"

i managed to play the video from usb and some of the links but still it isnt working correctly. Many of the links show the video just about to start and it stops right away.
The 1080p video file from the usb is h264 and i figure it should be HW accelerated, but it is not the case and it is incredibly choppy.In Openelec it plays smoothly.
Could the lack of HW acceleration also be the culprit for the addon dropping out of the video?And is the kodi in Ropi even configured to do HW acceleration?As i couldnt see any setting for that in kodi system settings.


RE: Kodi videos wont play - alexkidd - 05-06-2018

get rid of one of the libGL instances, as it's probably conflicting with the other:
sudo mv /usr/lib/arm-linux-gnueabihf/libGL.so* ~/temp/

then
edit the kodi script again, adding only the folder to the LD line, not the full filename, so the line is exactly:
LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib kodi

the video fails because it's not finding libGL.so.1, that's why we have to add the folder to the execute line


RE: Kodi videos wont play - DeJaVu - 05-06-2018

(05-06-2018, 02:16 AM)alexkidd Wrote: get rid of one of the libGL instances, as it's probably conflicting with the other:
sudo mv /usr/lib/arm-linux-gnueabihf/libGL.so* ~/temp/

then
edit the kodi script again, adding only the folder to the LD line, not the full filename, so the line is exactly:
LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib kodi

the video fails because it's not finding libGL.so.1, that's why we have to add the folder to the execute line

With the line like you suggest the 1080p video wont even start, i got black screen with a freeze and after kodi crashed got some screen artefacts which didnt go away with soft restart via the button, had to power cycle the Pi Lite.
Noticed that the libGL.so.1 file is a shortcut to libgl.so.1.2.0 and is 2.2mb . The one with the same name we moved to temp is 457kb, so obviously different.
Ill try tomorrow how it goes with the other one, unless you suggest something more ingenious till then.
Gotta go to sleep now, almost 5am here, too tired to think straight.


RE: Kodi videos wont play - alexkidd - 05-06-2018

Open a terminal window in Desktop and run Kodi from there: ./RetrOrangePi/kodi/start-kodi.SH
then you'll be able to Alt-Tab to that window and check Kodi output, probably confirming the libGL error

double check the LD_LIBRARY thing syntax


RE: Kodi videos wont play - DeJaVu - 05-06-2018

This is the output i get when running kodi through terminal and trying to stream through the addon:

\LIBGL: Initialising gl4es
LIBGL: v0.9.2 built on Nov 21 2017 14:20:22
LIBGL:loaded: libGLESv1_CM.so
LIBGL:loaded: libEGL.so
LIBGL: Error while gathering supported extension (Init issue), default to none
LIBGL: Current folder is:/home/pi
[input] No bind found for key '\'.
Playing: http://someaddress/video.mp4Agent=Mozilla%2F5.0+%28Windows+NT+5.0%3B+WOW64%3B+Trident%2F7.0%3B+rv%3A11.0%29+like+Gecko
Failed to recognize file format.

Exiting... (No files played)

Looks like its not registering the extensions and seems like it Libgl still giving trouble, maybe another version is available?


This is the output i get when trying to stream from youtube addon:

LIBGL: Initialising gl4es
LIBGL: v0.9.2 built on Nov 21 2017 14:20:22
LIBGL:loaded: libGLESv1_CM.so
LIBGL:loaded: libEGL.so
LIBGL: Error while gathering supported extension (Init issue), default to none
LIBGL: Current folder is:/home/pi
Playing: https://r2---sn-vox8p2-n32l.googlevideo.com/videoplayback?mv=m&source=youtube&ms=au%2Crdu&fvip=1&lmt=1508379169096138&key=yt6&ip=92.53.28.118&fexp=23724337&expire=1525644628&initcwndbps=720000&c=WEB&mt=1525622957&mn=sn-vox8p2-n32l%2Csn-c0q7ln7k&mm=31%2C29&signature=CBDB864047E025A1A87F95EFA07A0FC0B9CB0F63.C587A3C30D204DC32E832F9ADF85183ECB533B98&dur=129.590&id=o-AGZ9G94PaZClhqxMd9YzmgqF_nZ2rCD4Wk58u2q275XV&requiressl=yes&itag=22&sparams=dur%2Cei%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpire&mime=video%2Fmp4&ei=9CjvWsGWJ4_M1gLW86GgDg&ipbits=0&pl=22&ratebypass=yes|Cookie=PREF%3Df1%3D50000000%3B%20VISITOR_INFO1_LIVE%3D_0_VjQYkGxc%3B%20YSC%3DJLtVRwyfHxU%3B%20s_gl%3D688af368a73160e3babbbbf6f6dfe8a8cwIAAABNSw%3D%3D%3B
[libav] https: HTTP error 403 Forbidden
Failed to open https://r2---sn-vox8p2-n32l.googlevideo.com/videoplayback?mv=m&source=youtube&ms=au%2Crdu&fvip=1&lmt=1508379169096138&key=yt6&ip=92.53.28.118&fexp=23724337&expire=1525644628&initcwndbps=720000&c=WEB&mt=1525622957&mn=sn-vox8p2-n32l%2Csn-c0q7ln7k&mm=31%2C29&signature=CBDB864047E025A1A87F95EFA07A0FC0B9CB0F63.C587A3C30D204DC32E832F9ADF85183ECB533B98&dur=129.590&id=o-AGZ9G94PaZClhqxMd9YzmgqF_nZ2rCD4Wk58u2q275XV&requiressl=yes&itag=22&sparams=dur%2Cei%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Clmt%2Cmime%2Cmm%2Cmn%2Cms%2Cmv%2Cpl%2Cratebypass%2Crequiressl%2Csource%2Cexpire&mime=video%2Fmp4&ei=9CjvWsGWJ4_M1gLW86GgDg&ipbits=0&pl=22&ratebypass=yes|Cookie=PREF%3Df1%3D50000000%3B%20VISITOR_INFO1_LIVE%3D_0_VjQYkGxc%3B%20YSC%3DJLtVRwyfHxU%3B%20s_gl%3D688af368a73160e3babbbbf6f6dfe8a8cwIAAABNSw%3D%3D%3B.


Exiting... (No files played)

While looking near the end of the log it would seem that youtube blocks the playback "HTTP error 403 Forbidden" , thats not the issue, as the same video plays fine on youtube Kodi addon on my computer.

Oh and regarding the syntax, as far as i can tell everything is correct.
Here is the kodi script just in case there is some error and i dont see it.
http://www.mediafire.com/file/8ucbglj7h6sgp6j/start-kodi.SH


RE: Kodi videos wont play - alexkidd - 05-06-2018

MPV does not handle some file extensions and protocols, I could watch YouTube videos yesterday . Can you share the video name so I try to reproduce it


RE: Kodi videos wont play - DeJaVu - 05-06-2018

First one that came up and i tried was "Rasta Majka Official Music Video" 2:09 long , it doesnt play on the opi but plays on my computer.

(05-06-2018, 05:13 PM)alexkidd Wrote: MPV does not handle some file extensions and protocols, I could watch YouTube videos yesterday . Can you share the video name so I try to reproduce it
Understandable that no player could support all extensions and protocols.
But dont forget what i said few posts ago, everything was working fine yesterday(not sure about youtube as i didnt use it, but the addon was working) before i did fresh install.Only difference was that on the previous install i had everything installed/updated from source.

Oh and probably another difference was that i didnt have the latest RetrOrangePi update on it too, as i figure you released that about 5 days ago, and last RetrOrangePi update on the old install i think i did before that.


RE: Kodi videos wont play - alexkidd - 05-06-2018

playing fine...  :/

LIBGL: Initialising gl4es
LIBGL: v0.9.2 built on Jan 24 2018 19:59:35
LIBGL:loaded: libGLESv1_CM.so
LIBGL:loaded: libEGL.so
LIBGL: Error while gathering supported extension (Init issue), default to none
LIBGL: Current folder is:/home/pi
Playing: https://r7---sn-oxunxg8pjvn-cncl.googlevideo.com/videoplayback?mime=video/mp4&pl=48&itag=22&ip=2804:14c:658c:5a75:3406:13ff:fe24:6256&ms=au,rdu&fexp=23724337&source=youtube&dur=129.590&mv=m&id=o-AH-xdTxtKU1kg_iZKBoO2Eq2g9bXUDA1tiHyTnn3VHC1&key=yt6&mm=31,29&ipbits=0&c=WEB&mn=sn-oxunxg8pjvn-cncl,sn-bg07dnlz&initcwndbps=608750&sparams=dur,ei,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,pl,ratebypass,requiressl,source,expire&expire=1525649594&lmt=1508379169096138&requiressl=yes&mt=1525627909&ei=WjzvWvegEpKcxwTm7KDwBg&signature=5B252535D381C80EDD14DE863E2DF1B36431EA23.DD0968DDF5782A4F04B6DF6CE360222F7A32E73D&ratebypass=yes&fvip=1
[stream] Video (+) --vid=1 (*) (h264)
[stream] Audio (+) --aid=1 --alang=und (*) (aac)
File tags:
major_brand: mp42
minor_version: 0
compatible_brands: isommp42
creation_time: 2017-10-19 02:12:47
[VDPAU SUNXI] VE version 0x1680 opened
[VDPAU SUNXI] OSD enabled, using pixman
Trying to use hardware decoding.
AO: [alsa] 44100Hz stereo 2ch float
VO: [vdpau] 1280x540 => 1280x540 vdpau
[VDPAU SUNXI] Generate CSC matrix from following color standard: 0
[VDPAU SUNXI] >procamp->bright: 0.000, procamp->contrast: 1.000, procamp->saturation: 1.000, procamp->hue: 0.000
[VDPAU SUNXI] Setting mixer value from following color standard: 0
[VDPAU SUNXI] >mix->bright: 0.000, mix->contrast: 1.000, mix->saturation: 1.000, mix->hue: -0.000
[VDPAU SUNXI] Setting mixer value from following color standard: 0
[VDPAU SUNXI] >mix->bright: 0.068, mix->contrast: 1.000, mix->saturation: 0.479, mix->hue: -0.068
[VDPAU SUNXI] Presentation time not supported
[VDPAU SUNXI] rgba_render_surface: colors and flags not implemented!
AV: 00:00:37 / 00:02:09 (29%) A-V: -0.001 Cache:  1s+1978KB
Exiting... (Quit)


RE: Kodi videos wont play - DeJaVu - 05-06-2018

(05-06-2018, 05:36 PM)alexkidd Wrote: playing fine...  :/

LIBGL: Initialising gl4es
LIBGL: v0.9.2 built on Jan 24 2018 19:59:35
LIBGL:loaded: libGLESv1_CM.so
LIBGL:loaded: libEGL.so
LIBGL: Error while gathering supported extension (Init issue), default to none
LIBGL: Current folder is:/home/pi
Playing: https://r7---sn-oxunxg8pjvn-cncl.googlevideo.com/videoplayback?mime=video/mp4&pl=48&itag=22&ip=2804:14c:658c:5a75:3406:13ff:fe24:6256&ms=au,rdu&fexp=23724337&source=youtube&dur=129.590&mv=m&id=o-AH-xdTxtKU1kg_iZKBoO2Eq2g9bXUDA1tiHyTnn3VHC1&key=yt6&mm=31,29&ipbits=0&c=WEB&mn=sn-oxunxg8pjvn-cncl,sn-bg07dnlz&initcwndbps=608750&sparams=dur,ei,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,pl,ratebypass,requiressl,source,expire&expire=1525649594&lmt=1508379169096138&requiressl=yes&mt=1525627909&ei=WjzvWvegEpKcxwTm7KDwBg&signature=5B252535D381C80EDD14DE863E2DF1B36431EA23.DD0968DDF5782A4F04B6DF6CE360222F7A32E73D&ratebypass=yes&fvip=1
[stream] Video (+) --vid=1 (*) (h264)
[stream] Audio (+) --aid=1 --alang=und (*) (aac)
File tags:
major_brand: mp42
minor_version: 0
compatible_brands: isommp42
creation_time: 2017-10-19 02:12:47
[VDPAU SUNXI] VE version 0x1680 opened
[VDPAU SUNXI] OSD enabled, using pixman
Trying to use hardware decoding.
AO: [alsa] 44100Hz stereo 2ch float
VO: [vdpau] 1280x540 => 1280x540 vdpau
[VDPAU SUNXI] Generate CSC matrix from following color standard: 0
[VDPAU SUNXI] >procamp->bright: 0.000, procamp->contrast: 1.000, procamp->saturation: 1.000, procamp->hue: 0.000
[VDPAU SUNXI] Setting mixer value from following color standard: 0
[VDPAU SUNXI] >mix->bright: 0.000, mix->contrast: 1.000, mix->saturation: 1.000, mix->hue: -0.000
[VDPAU SUNXI] Setting mixer value from following color standard: 0
[VDPAU SUNXI] >mix->bright: 0.068, mix->contrast: 1.000, mix->saturation: 0.479, mix->hue: -0.068
[VDPAU SUNXI] Presentation time not supported
[VDPAU SUNXI] rgba_render_surface: colors and flags not implemented!
AV: 00:00:37 / 00:02:09 (29%) A-V: -0.001 Cache:  1s+1978KB
Exiting... (Quit)

I noticed that we have different build dates on LIBGL , mine is older, maybe it is with some issues?