OrangePI Club
Emulationstation does not start - Printable Version

+- OrangePI Club (http://orangepi.club)
+-- Forum: International (English) Forums (http://orangepi.club/forumdisplay.php?fid=3)
+--- Forum: *nix Distro (http://orangepi.club/forumdisplay.php?fid=4)
+---- Forum: RetrOrangePi v4 (http://orangepi.club/forumdisplay.php?fid=31)
+----- Forum: SUPPORT (http://orangepi.club/forumdisplay.php?fid=34)
+----- Thread: Emulationstation does not start (/showthread.php?tid=2538)



Emulationstation does not start - svj3ist - 06-23-2018

hung on the screen retrorangepi loading, if run from armbian or boot Emulationstation. It seems like this after the update armbian. How can I restore everything back?

when started Emulationstation in ssh write:
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Aborted


RE: Emulationstation does not start - alexkidd - 06-23-2018

try to run emulationstation from its folder

cd /opt/retropie/supplementary/emulationstation
./emulationstation

if from ssh , run "emulationstation --debug" to have more detailed error messages

edit: there is no "restore everything back" , you'll have to reflash if no fix works


RE: Emulationstation does not start - svj3ist - 06-23-2018

log:
lvl2: EmulationStation - v2.7.3rp - ROPi 4.0, built Nov 25 2017 - 02:13:35
lvl2: Creating surface...
lvl2: Created window successfully.
lvl2: CECInput::mAdapter->DetectAdapters failed
lvl2: Checking available OpenGL extensions...
lvl2: ARB_texture_non_power_of_two: MISSING
lvl2: Loading system config file /home/pi/.emulationstation/es_systems.cfg...
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Aborted


RE: Emulationstation does not start - alexkidd - 06-23-2018

Never ran through such error. Try the following:

sudo apt-get install locale-gen
sudo locale-gen en_US en_US.UTF-8
sudo dpkg-reconfigure locales


RE: Emulationstation does not start - svj3ist - 06-23-2018

Thank you! I forgot that I tried to change the language in my native language. all worked