OrangePI Club
Scrape broken... - Printable Version

+- OrangePI Club (http://orangepi.club)
+-- Forum: International (English) Forums (http://orangepi.club/forumdisplay.php?fid=3)
+--- Forum: *nix Distro (http://orangepi.club/forumdisplay.php?fid=4)
+---- Forum: RetrOrangePi v4.2 version (http://orangepi.club/forumdisplay.php?fid=38)
+---- Thread: Scrape broken... (/showthread.php?tid=3043)



Scrape broken... - Lamerjack - 01-12-2019

Scrape doesn't work anymore on my system.
Also games that i scrape in the past give no result.
System has internet connection.
The only thing that i changed is that i updated the Retropie Setup Script to try to compile Amyberry.
Any suggestion?


RE: Scrape broken... - Lamerjack - 01-16-2019

(01-12-2019, 09:36 PM)Liontek1985 Wrote: forgot the scraper this have no good results and need many time

use Universal_XML_Scraper search in google best results

https://github.com/Universal-Rom-Tools/Universal-XML-Scraper/releases

this scraper is for windows

This sound amazing.
I exactly what i was dreaming manage scraping from a pc with full keyboard.

I got some errors i will read faq and maybe i will test latest version from github!


RE: Scrape broken... - Lamerjack - 01-16-2019

(01-16-2019, 11:13 AM)Liontek1985 Wrote: the first configuration its not easy, you must set all folder right, is this done you can scrape nice images and clips

the program use the database from https://www.screenscraper.fr/ , you can scrape only 1  image in the same time, that is the disadvantage
if you want scrape faster need you a premium account

i downloaded
i run it.
The first time start 
i select retropie
i select the mix that i like
then if i select "roms are on raspberry pi" it fail
so i select locally and i point to share \\RETRORANGEPI\roms
i write my credentials for ScreenScraper
when ask me if i want to scrape i chose no
and in menu SSH command -> SSH parameter i set host RETRORANGEPI login pi password pi
then from menu scrape i chose amiga and i press Scrape
it hangs on
Testing server connection

i found this.
https://github.com/verybadsoldier/Universal-XML-Scraper/tree/fix/scanning_freeze
and this seems that works.
But this seems that doesn't save settings at every launch ask me again language os etc


RE: Scrape broken... - Lamerjack - 01-17-2019

(01-16-2019, 02:29 PM)Liontek1985 Wrote: better you scrape on your pc hdd not on pi self, its faster and easyer 

make a folder on your hdd "roms"
in this folder copy all your roms with right retropie folder name "nes" like "nes"

select as main folder "roms" now you can scrape on your hdd

i can make you a screenshot of my setting if you want
Ok i will dump rom on my pc hd in order to have also a backup.
Anyway if you have time screenshot are welcome and  can be userful also for other people!
p.s.
Screenscraper is very updated there also clones like AlexKidd2 for SMS!


RE: Scrape broken... - Lamerjack - 01-18-2019

(01-18-2019, 08:16 AM)Liontek1985 Wrote: i know i have spend many time to find a good scraper, this is the best Smile
by time i make screenshots

I found why it hangs on Testing server connection
i was scraping amiga files and the cause was +UAE4ARM_Launcher.sh
probably the + sign. removed the file works fine!