OrangePI Club
UAE4ARM (RetrOrangePi 4.2 SLIM) on Orange PI One - Printable Version

+- OrangePI Club (http://orangepi.club)
+-- Forum: International (English) Forums (http://orangepi.club/forumdisplay.php?fid=3)
+--- Forum: *nix Distro (http://orangepi.club/forumdisplay.php?fid=4)
+---- Forum: RetrOrangePi v4.2 version (http://orangepi.club/forumdisplay.php?fid=38)
+---- Thread: UAE4ARM (RetrOrangePi 4.2 SLIM) on Orange PI One (/showthread.php?tid=3261)



UAE4ARM (RetrOrangePi 4.2 SLIM) on Orange PI One - klaute - 10-18-2019

Hello,

I‘m running ReteOrange PI 4.2 slim on my Opi One.

In the last days I tried to get Uae4arm working.

I installed it successfully using the retropi_setup.sh

From the EmulationStation I can start uae (in Xorg) after I modified the +Start... script. I have added a sudo call to the startx command.

I tried to get the emulator work but I have no success.
I tried many many different kick rom files, which work well on my Windows system and also on my Android phone.
And I also added a 512MB swap file.

I only get a blank black screen after I click on start in the UAE configuration window.

UAE version info:

pi@RetrOrangePi:~$ /opt/retropie/emulators/uae4arm/uae4arm --version
Uae4arm v0.5 for Raspberry Pi by Chips
Based on uae version: 3.5.0
Git revision: 38591d3

At this point I don‘t know what to try out next.

I also tried to build amiberry, but without success.
The file bcm_host.h is missing, compilation is aborted...

Maybe someone could give me some hint?!

Thank you!


RE: UAE4ARM (RetrOrangePi 4.2 SLIM) on Orange PI One - alexkidd - 10-18-2019

upgrade to v4.3 and use amiberry
please help testing beta OPi One version
http://orangepi.club/showthread.php?tid=3230

Uae4arm wont be supported any longer