Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Emulationstation does not start
hung on the screen retrorangepi loading, if run from armbian or boot Emulationstation. It seems like this after the update armbian. How can I restore everything back?

when started Emulationstation in ssh write:
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
try to run emulationstation from its folder

cd /opt/retropie/supplementary/emulationstation

if from ssh , run "emulationstation --debug" to have more detailed error messages

edit: there is no "restore everything back" , you'll have to reflash if no fix works
lvl2: EmulationStation - v2.7.3rp - ROPi 4.0, built Nov 25 2017 - 02:13:35
lvl2: Creating surface...
lvl2: Created window successfully.
lvl2: CECInput::mAdapter->DetectAdapters failed
lvl2: Checking available OpenGL extensions...
lvl2: ARB_texture_non_power_of_two: MISSING
lvl2: Loading system config file /home/pi/.emulationstation/es_systems.cfg...
terminate called after throwing an instance of 'std::runtime_error'
what(): locale::facet::_S_create_c_locale name not valid
Never ran through such error. Try the following:

sudo apt-get install locale-gen
sudo locale-gen en_US en_US.UTF-8
sudo dpkg-reconfigure locales
Thank you! I forgot that I tried to change the language in my native language. all worked

Possibly Related Threads...
Thread Author Replies Views Last Post
  CPS2 games unable to start Loo 2 627 06-06-2019, 07:27 PM
Last Post: djcasl
  + Start UAe4ARM doesn´t start rtokuda 5 2,743 07-12-2018, 01:49 AM
Last Post: alexkidd
  Emulationstation don't recognize wireless "3 in 1" controller mrxiong 2 2,012 06-02-2018, 07:11 AM
Last Post: mrxiong
Question How do I change the text color of the emulationstation menu? AeitZean 3 2,145 05-01-2018, 08:59 PM
Last Post: AeitZean
  Help! DosBox: the system hang up when I start keymapper starxxx 6 3,618 01-10-2018, 05:59 PM
Last Post: starxxx
  Orange Pi One fails to start. ps1x 0 1,091 12-24-2017, 10:48 PM
Last Post: ps1x
  Error when i start ropi on tv Raziello 4 3,210 12-09-2017, 09:35 PM
Last Post: Raziello
  emulationstation crash YiorgosH 4 2,843 12-07-2017, 07:07 PM
Last Post: alexkidd

Forum Jump:

Users browsing this thread: 1 Guest(s)