Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi videos wont play
#1
Kodi used to work fine on my OPi Lite with the addon i prefer on my previous Retrorangepi 4.1 installation on which i had done every posible update(maaaany hours).
But now after doing fresh install it shows all the sources for the videos, but videos for some reason wont play(even youtube).
As i dont want to go through that veery long update process again, and dont want to fill the install with lots of unneeded components, it would be great if someone could point me in the right direction and advise what packages i need updated to get it working again.
At the moment only thing i have updated is RetrOrangePi from the Retroarch menu.
Reply
#2
Most streaming addons are hit and miss, and due to their "unofficial" nature, there will be no support. Specially because issues are not related with our build. Maybe you have better luck with OpenELEC btw.
Reply
#3
(05-05-2018, 10:17 PM)alexkidd Wrote: Most streaming addons are hit and miss, and due to their "unofficial" nature, there will be no support. Specially because issues are not related with our build. Maybe you have better luck with OpenELEC btw.

Youtube isnt playing videos too, which is as official as can be, so it might be an issue worth looking into.
Also i couldnt start a movie from a usb stick, got a freeze and crash.It was an mp4 1080p file.

As far as i understood from reading these few days, openelec no longer can be run directly from retrorangepi and i would need another sd card for that purpose, or am i wrong?
Reply
#4
if you installed v4.1 from our repo, you can try the OpenELEC option from Start Menu.
About the addon, we'll take a look... but issues like that are common, looks like those addons have a usage quota or something. Search for quota API addon youtube
Reply
#5
default resolution is 720p , so you should probably change resolution to 1080p (sudo h3disp -m10) before to avoid lockups. Also, hardware acceleration only works for certain codecs
Reply
#6
OK, got it working, seems to be related with MPV not finding libGL.so.1 , so try this:
sudo find /usr -name libGL.so.1

then add the folder to the LD_LIBRARY_PATH in /home/pi/RetrOrangePi/kodi/start-kodi.SH,
so it's like this:
LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib kodi
Reply
#7
I downloaded the 4.1 image from retrorangepi.org.
If by start menu you mean exiting es to desktop and looking in applications menu, then i dont see openelec there.

About the addon, definately not a quota issue, as it is working ok on my pc and also on my RPi3 B.
It was also working ok on ropi 4.1 minutes ago, only difference is that i had installed/updated all packages which took more than 10 hours i think.
After starting fresh it isnt working anymore, so it is 99% an issue with a componnent needing update or some dependency.
But i cant figure which component that would be, and im not willing to go over that long update process again atm. Will probably try it out again in few days to make sure that it starts working after all the updates.
It could also have some connection to the very low ammount of ram and acting out in certain scenarios, who knows.Ill have a OPi PC in few weeks, so it would be easier to do direct comparison.

BTW how do you do memory split on the OPi ? Cant seem to do it the same way as on retropie 4.4
Reply
#8
read post above
openelec should appear when you press Start on ES (dont remember if OPi Lite is supported)
AFAIK, there is no memory split feature as raspberries

also, dont update anything, there might be upstream changes we still couldnt have fixed yet. It's very likely libGL is being duplicated with the updates, so it breaks MPV compatibility.
Reply
#9
(05-05-2018, 11:56 PM)alexkidd Wrote: read post above
openelec should appear when you press Start on ES (dont remember if OPi Lite is supported)
AFAIK, there is no memory split feature as raspberries

also, dont update anything, there might be upstream changes we still couldnt have fixed yet. It's very likely libGL is being duplicated with the updates, so it breaks MPV compatibility.

Probably not supported, as i dont have that on the start menu, have only Desktop option.

By dont update anything i suppose you mean through RetroPie-Setup?
Orangepi Update is always safe? Or shouldnt update even that
Reply
#10
From RetroPie-Setup, it's usually safe to update the libretro cores and some of the emulators, but we've been experimenting some regression lately, we're working on the next version ,fixing a few scripts.
Update RetrOrangePi is usually safe as it contains tested fixes. Do it twice as the second on will add a hotfix script to the updater.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  how to remove kodi from ropi 4.1? Garrafinha 2 443 04-20-2018, 07:26 PM
Last Post: Garrafinha
  Wifi connect and default Kodi martin5504 5 918 03-22-2018, 06:03 PM
Last Post: alexkidd
  HDMI CEC not working in kodi haze333 1 666 02-20-2018, 10:52 AM
Last Post: alexkidd
  KODI NO AUDIO saroninux 2 661 01-21-2018, 04:00 PM
Last Post: saroninux
  How to uninstall Kodi? aserdaqw 4 1,254 01-10-2018, 08:53 PM
Last Post: alexkidd
  kodi keyboard non us keiser1080 0 429 01-01-2018, 10:44 PM
Last Post: keiser1080
  Kodi : videos not playing tyrell 12 4,243 01-01-2018, 09:26 PM
Last Post: keiser1080
  how to install inputstream.adaptive kodi 17.4 sacy 0 810 12-27-2017, 12:03 PM
Last Post: sacy
  Orange Pi Zero Kodi Not Working after 4.0 Update infex 7 2,688 12-14-2017, 11:22 AM
Last Post: alexkidd
  Remove RetroPie menu but keep Kodi KeyDet 1 818 12-14-2017, 02:50 AM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 2 Guest(s)