Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Orange Pi Lite Micro USB port
#1
Howdy. Firstly, thanks for your continued work on the project!

  I am running an OPi Lite with ROPI version 4.1. (I have not updated to 4.2, but I imagine my question would apply if I did.)  My current issue is that the Micro USB port in the back of board seems to be disabled.  My last installation on this OPi had it working, but that SD card died a long time ago.  Are there steps I can take to get this port active again in v4.1? (If rebuilding the system with 4.2 will activate the port by default, then I will gladly do that.)

System:
Orange Pi Lite
ROPI 4.1
PSU 5V 2.5A
1 SNES-style Vilros gamepad
1 USB Hub attached to Micro USB port (nothing connected to it because it doesn't work)
Reply
#2
go in the "/boot/bin" folder and copy the orangepilite.bin file in the /boot/ folder
delete the script.bin and rename the orangepilite.bin to script.bin

it still does not work,
1.) i think a hardware damage
2.) the cable what you use is broken
Reply
#3
I just swapped those files as you stated. The port is getting power. When I plug in a mouse, the mouse laser is on. However, no devices are being picked up when I use that port.
Reply
#4
test the mouse on one of the two USB-A Ports on you Orange-Pi Lite
work it -> i think the micro USB-Port have not enough Power for the Mouse or your Power Supply is to low
It does not work -> test the Mouse on a PC or Laptop

test you the mouse on armbian desktop?
Reply
#5
Everything works when connected to the other standard USB ports (controllers, keyboards, mice). I disconnected everything else when testing, so the micro USB should have all the power it needs (2.5A power supply, the official standard). If I boot up with nothing but a controller attached to the micro port, no response. (I only mentioned the mouse as proof that the micro port has power.)
I'll see if the desktop can find anything on the port.
Reply
#6
please run:
cat /sys/bus/platform/devices/sunxi_usb_udc/otg_role
Reply
#7
(01-15-2019, 04:25 PM)alexkidd Wrote: please run:
cat /sys/bus/platform/devices/sunxi_usb_udc/otg_role

It appears to be empty. The file is there but has no content.
Reply
#8
Should I try adding a mode to this file? I've seen stuff around that indicate putting a 1 or 2 (or both) in this file may have something to do with it becoming active.
Reply
#9
it should be default, but you can try:
sudo mkdir /etc/systemd/system/serial-getty@ttyGS0.service.d
sudo nano /etc/systemd/system/serial-getty@ttyGS0.service.d/10-switch-role.conf

insert the text below

[Service]
ExecStartPre=-/bin/sh -c "echo 0 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role"

Ctrl X to exit, Y to save

post 'sudo lsusb' output and last lines of 'dmesg' right after plugging and unplugging an usb cable
Reply
#10
Ok, here's what happened.

I went to do:"sudo mkdir /etc/systemd/system/serial-getty@ttyGS0.service.d" and found that the directory already existed. The file 10-switch-role.conf also exists.
The contents of the file 10-switch-role.conf are:
[Service]
ExecStartPre=-/bin/sh -c "echo 2 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role"

I added the lines you suggested:
[Service]
ExecStartPre=-/bin/sh -c "echo 0 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role"

and now the contents of the file are:
[Service]
ExecStartPre=-/bin/sh -c "echo 2 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role"
[Service]
ExecStartPre=-/bin/sh -c "echo 0 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role"

doing an lsusb shows 8 ports listed, two with devices (1 for the controller and 1 for the keyboard)
dmesg has a last line showing that the vmouse service stopped.

Plugged in a mouse to the micro usb.
lsusb - unchanged
dmesg - unchanged

Unplugged mouse, still no changes

plugged in USB hub: no changes
unplugged USB hub, no changes

Disconnected the controller from standard usb port.
lsusb now only show the keyboard connected.
dmesg added 2 line showing disconnect of controller

connected a standard usb hub to standard port
lsusb shows USB hub in the list and now also has 4 more ports ont he list
dmesg show a few lines about adding the hub


In all cases - the file otg_role is empty. It never gets a value put into it.



So..... the Micro usb is getting power, but not recognizing any device connected to it still. At this point, I am inclined to think that the port is damaged after all. It's entirely possible that the cramped space between the HDMI port and micro usb port is to blame. No matter how narrow of an hdmi cable I use, it still interferes with the micro usb adapter I have. the pressure between them could easily have caused a breakage int he usb port. I now that sometimes the HDMI port gets screwy if they are both plugged in. (This is why I wanted to use my USB hub on this port because it's natively Micro USB and doesn't require an adapter.)

If you have any further suggestions, I welcome them, but am willing to drop it if you are too busy to go further. I am very grateful for the suggestions thus far, but don't want to waste your time.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Orange pi lite retrorangepi 4.1 won't boot Merlin3D 6 4,145 11-11-2018, 08:23 PM
Last Post: Doogie10
Big Grin Picked Up my Orange pi plus 2 after a while Brottus 1 829 07-02-2018, 08:22 PM
Last Post: alexkidd
  how to fix screen black bar at bottom AV orange pi zero jamespoo 4 1,818 05-28-2018, 12:15 PM
Last Post: jamespoo
  OrangePi Pc connect via micro usb saroninux 3 1,770 05-18-2018, 04:17 PM
Last Post: alexkidd
  RetrOrangePi 4.1 - Orange Pi Zero GPIO - Getting GPIO to work bharathram21391 15 5,321 05-15-2018, 04:58 PM
Last Post: alexkidd
  Included Firefox Browser Freezes the OPi lite DeJaVu 2 1,172 05-06-2018, 05:12 PM
Last Post: DeJaVu
  Trouble connecting bluetooth ps4 controllers to orangepi lite board Sternosaur 1 1,188 04-04-2018, 09:38 PM
Last Post: alexkidd
  Orange Pi Zero with - 4.1 Rpi - expand filesystem? popeye 6 2,780 03-23-2018, 09:44 AM
Last Post: popeye
Question Cannonball port not loading (Ropi 4.1) canadien 6 3,414 03-13-2018, 08:03 PM
Last Post: canadien
  Orange pi zero h3 512mb help Merlin3D 1 1,499 03-07-2018, 07:11 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)