Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Amiga - WHDLoad
#1
reserved
Reply
#2
I'd love to find out how it's done. It's been melting my brain, trying to figure it out when emulating on a PC.
Reply
#3
But do you want to set it up on a PC or the OrangePi?
Reply
#4
How to setting x retrorange witch uae4arm ?
I tried:
https://retropie.org.uk/forum/topic/8431...ages-amiga
http://arcademania.eu/viewtopic.php?f=18&t=715
http://www.ultimateamiga.co.uk/HostedPro...guide.html
but all whitout result
Reply
#5
I can confirm this worked for me  => https://www.giantpockets.com/setting-up-...h-whdload/
If you can, try the preinstalled packs from Classic Amiga Workbench, some already contains the bundled whdload. So you would just need select the correct kickstart (kick31.rom), load the A1200 configuration, increase fast memory to 8MB, add the workbench file as DH0 and the folder containing your games in whdload format as DH1.

[Image: 28685440_1814423371941113_28686751629355...e=5B37AE86]
Reply
#6
ok thank's i have installed workbench and whdload is installed fine.
But the problem exists when you create the configuration for the game to get them started directly from the emulationstation.
From there comes out the black screen and you hear only the audio.
Pressing F12 will display the split menu, as if the resolution was too high.
Reply
#7
In my tests, i can launch WHDLoad workbench from EmulationStation fine, but not whdload games directly. If you give me details, i can try to reproduce here. The black screen is an old bug related to lack of memory or unsupported resolution. Which board you have? And what resolution? About the menu, default resolution is 720p not scalable. We probably have a fix for this, using the binary compiled for the Orange PI Zero (480p).
Reply
#8
So, if from emulationstation, I start + Start UAE4Arm.sh and from the gui, load the configuration file .aue everything works correctly.
If, instead, from emulationstation, I start the configuration file directly, it gives me a black screen, within the gui, the configuration is loaded correctly but I display in double screen, as if the resolution was too high.

The board is beelink x2

At this point, I think it's the way aue4arm is started in emulator.cfg.
I have tried all the options available but none is working I have tried too
uae4arm = "pushd / opt / retropie / emulators / uae4arm /; ./uae4arm -f% ROM%"
but no result

I keep trying and updating you.
I launched the putty command
and the problem seems to be its resolution
Uae4arm v0.5 for Raspberry Pi by Chips
Will use keycode from fbcon mapping.
Joystick 0: Saitek PLC Saitek P3200 Rumble Pad
Buttons: 12 Axis: 5 Hats: 1
starting sound thread ..
Current resolution: 1280 x 720 32 bpp
Emulation resolution: Width 640 Height: 256
Unable to create EGL surface (300b)
eglSwapBuffers 300d

ok resolved
this is the line for launch
"LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/emulators/uae4arm/uae4arm.sh %ROM% %ROM%"
file names must be without space
Reply
#9
please post the output of the following command: "cat /opt/retropie/configs/amiga/emulators.cfg"
Reply
#10
launcher = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx %ROM%"
amiga-500 = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/configs/amiga/+Amiga500.sh %ROM%"
amiga-1200 = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/configs/amiga/+Amiga1200.sh %ROM%"
default = "new"
uae4arm-a500 = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/emulators/uae4arm/uae4arm.sh rp-a500.uae %ROM%"
uae4arm-a1200 = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/emulators/uae4arm/uae4arm.sh rp-a1200.uae %ROM%"
uae4arm = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/emulators/uae4arm/uae4arm -config=%ROM%"
new = "LD_LIBRARY_PATH=/usr/lib/GLSHIM:/usr/lib startx /opt/retropie/emulators/uae4arm/uae4arm.sh %ROM% %ROM%"

with "new" start from emulationstation

The only thing is that the name must be without spaces and you must have the configuration file also in
/ Opt / retropie / configs / amiga / uae4arm / conf /
For now this is the working configuration I found
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)