Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
eMMC + SD behaviour
#11
1. retropie-mount is indeed a folder , check retropie howto - https://github.com/RetroPie/RetroPie-Set...-USB-drive
also this video:

2. emmc in 4.0 is also working fine now, but SD usage afterwards is what is being discussed here.
Reply
#12
Hello
i have a problem with the eMMC install. (orange pi pc +)
It is going to (Creating rootfs on eMMC. Please wait! . . This may take a while.) Then it does not do anything arround 2 min the loading bar is on 0%. After that it tells me ( Cleaning up . . . few seconds) After that it tells me to shutdown and remove the sd card and reboot. But this is not working. It does not boot.
I tryed it now 3 times. Is there anything i can do??
Reply
#13
Did you install the 4.0 update?
Reply
#14
(11-07-2017, 08:00 PM)alexkidd Wrote: Did you install the 4.0 update?

Yes. I did a complete new install. First flash Retrorangepi 3.0.1 to Sd than update to 4.0 and then i tryed to write to emmc.
Reply
#15
We tested the eMMC installer and it worked OK on the banana pi m2+ and other people got to install it too.

two things to try:

1. install gparted on armbian desktop (sudo apt-get install gparted), run it and delete emmc partition (should be /dev/mmcblk1), then try to run emmc installer again
2. if 1 fails, repeat gparted process, but instead of running installer, copy the image to an usb drive , plug it in, mount the drive, then run the command: "sudo dd bs=1024 if=/yourdrive/yourfolder/retrorangepi.img of=/dev/mmcblk1"
Reply
#16
(11-07-2017, 08:29 PM)alexkidd Wrote: We tested the eMMC installer and it worked OK on the banana pi m2+ and other people got to install  it too.

two things to try:

1. install gparted on armbian desktop (sudo apt-get install gparted), run it and delete emmc partition (should be /dev/mmcblk1), then try to run emmc installer again
2. if 1 fails, repeat gparted process, but instead of running installer, copy the image to an usb drive , plug it in, mount the drive, then run the command: "sudo dd bs=1024 if=/yourdrive/yourfolder/retrorangepi.img of=/dev/mmcblk1"
Ok thank you i will test the second one because i already testet the first one.
Reply
#17
(11-06-2017, 08:36 PM)alexkidd Wrote: 1. retropie-mount is indeed a folder , check retropie howto - https://github.com/RetroPie/RetroPie-Set...-USB-drive
also this video: [video]

2. emmc in 4.0 is also working fine now, but SD usage afterwards is what is being discussed here.

I made my tests and conclusion:

1. RetrOrangePi 4.0 on SD then install usbromservice - WORK
2. RetrOrangePi 4.0 on eMMC then install usbromservice - NOT WORK
3. RetrOrangePi 4.0 on SD then install usbromservice and then pass to eMMC - eMMC install script NOT WORK (Same error Terri123)

Note: only FAT32 formatted drive works to roms drive, exFAT not work.


All this tests are made with a clean install of RetrOrangePi 3.0.1 updated to 4.0 on SD card then passed to eMMC.

(11-07-2017, 08:10 PM)Terri123 Wrote: Yes. I did a complete new install. First flash Retrorangepi 3.0.1 to Sd than update to 4.0 and then i tryed to write to emmc.

Just a question. Did you install usbromservice on SD before to write to eMMC? If yes try to make a new flash to SD, update to 4.0, but don't install usbromservice then write to eMMC.
Reply
#18
1. OK, confirmed working
2. surprising, once installed to eMMC, it should detect the usb the same way the sdcard does, i will check that
3. not surprising, as the usbromservice routine involves mounting the block device (/dev/mmcblk0) directly on /home/pi/RetroPie. This probably breaks rsyncing the files (absolute paths)

Note: yes, usbromservice is limited to FAT32, but using NTFS or exFAT is possible as long as you mount them manually and use symbolic links (i do it for some of the largest roms folders stored in my 1TB HDD :p)

I'll try to reproduce the bugs and fix the installer (actually we're working on it, already enabled bootloader and roms on SD, system on eMMC and more roms on USB)
Reply
#19
(11-08-2017, 08:02 PM)alexkidd Wrote: 1. OK, confirmed working
2. surprising, once installed to eMMC, it should detect the usb the same way the sdcard does, i will check that
3. not surprising, as the usbromservice routine involves mounting the block device (/dev/mmcblk0) directly on  /home/pi/RetroPie. This probably breaks rsyncing the files (absolute paths)

Note: yes, usbromservice is limited to FAT32, but using NTFS or exFAT is possible as long as you mount them manually and use symbolic links (i do it for some of the largest roms folders stored in my 1TB HDD :p)

I'll try to reproduce the bugs and fix the installer (actually we're working on it, already enabled bootloader and roms on SD, system on eMMC and more roms on USB)

One little tip but i think you work on it.... can you make a script to copy or create the retropiemenu, the base roms folders on the automount drive at the boot if you don't find it?
Reply
#20
(11-08-2017, 06:55 PM)edu82 Wrote:
(11-06-2017, 08:36 PM)alexkidd Wrote: 1. retropie-mount is indeed a folder , check retropie howto - https://github.com/RetroPie/RetroPie-Set...-USB-drive
also this video: [video]

2. emmc in 4.0 is also working fine now, but SD usage afterwards is what is being discussed here.

I made my tests and conclusion:

1. RetrOrangePi 4.0 on SD then install usbromservice - WORK
2. RetrOrangePi 4.0 on eMMC then install usbromservice - NOT WORK
3. RetrOrangePi 4.0 on SD then install usbromservice and then pass to eMMC - eMMC install script NOT WORK (Same error Terri123)

Note: only FAT32 formatted drive works to roms drive, exFAT not work.


All this tests are made with a clean install of RetrOrangePi 3.0.1 updated to 4.0 on SD card then passed to eMMC.

(11-07-2017, 08:10 PM)Terri123 Wrote: Yes. I did a complete new install. First flash Retrorangepi 3.0.1 to Sd than update to 4.0 and then i tryed to write to emmc.

Just a question. Did you install usbromservice on SD before to write to eMMC? If yes try to make a new flash to SD, update to 4.0, but don't install usbromservice then write to eMMC.

I did not install usbromservice any time because my games are on the 64gb sd card. The sd card forward boot to emmc like it was in 3.0.1 

Tutorial to allow system to recognize SD card presence after installing to EMMC:

  1. Turn off your board
  2. Reinsert your SD card with RetrOrange Pi
  3. Turn on your board
  4. Go to Desktop and open a terminal window
  5. Backup your boot files: run ‘cp /boot/boot* ~/’
  6. Run ‘sudo pluma /boot/*.cmd’
  7. In file boot-retro.cmd , change /dev/mmcblk0p3 to /dev/mmcblk1p3
  8. In file boot.kodi.cmd, change to boot=/dev/mmcblk1p1 and disk= /dev/mmcblk1p2
  9. Save all files and close Pluma
  10. Run ‘sudo mkimage –C none –A arm –T script –d /boot/boot-retro.cmd /boot/boot.scr
  11. Leave SD card inside slot and reboot board: sudo reboot
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)