Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Amiga games
#11
(11-09-2017, 10:26 PM)alexkidd Wrote: oops, looks like an upstream pull broke our script.
edit ~/RetroPie-Setup/scriptmodules/emulators/uae4arm.sh and remove !mali right at the beginning

Thanks. But still not start:
Modprobe: fatal Module g2d_23 not found
Modprobe: fatal Module sunxi_cedar_mod not found
Reply
#12
errors not related, try from command line:

pushd /opt/retropie/emulators/uae4arm
LD_LIBRARY_PATH=/usr/lib startx ./uae4arm
Reply
#13
(11-13-2017, 04:38 PM)alexkidd Wrote: errors not related, try from command line:

pushd /opt/retropie/emulators/uae4arm
LD_LIBRARY_PATH=/usr/lib startx ./uae4arm

Sorry for the delay.
command line works.
Maybe is something in old configs that is not correct for this uae...
Reply
#14
It's already fixed, will be included in final image, now runs zipped games from ES
Reply
#15
Hey guys, firstly thanks for all the the work on the OrangePI images. I bought a couple of orange Pi's with the sole intention of building C64 and Amiga emulation machines from them, I have a Zero and a Orange PI PC, on the latest images on the Retropi download site both versions are giving me this error and I've been unable to to the Amiga emulators working at all in Emulationstation. C64 emulation is working beautifully though. Do I need a newer beta image or something?. Another problem I encountered is the overscan fix completely breaks the orange PI pc image.
Reply
#16
Amiga emulation is not present in latest image (v4.2 SLIM)
Overscan fix is exclusive for Analog output

if it's really v4.1 you downloaded, please be more specific of your steps
Reply
#17
I just checked it's actually the 4.2 images I'm using This one on the zero RetrOrangePi_4.2_SLIM_Armbian_5.54_Orangepizeroplus2-h3_Debian_jessie_default_3.4.113.7z and this one RetrOrangePi_4.2_SLIM_Armbian_5.54_Orangepipc_Debian_jessie_default_3.4.113.7z on the orange PI PC. The Amiga emulator is pre-installed on the Zero image but doesn't work (same error as reported in this thread). VICE for C64 is pre installed also but has an error loading also. The amiga emulator can be compiled on PC version but doesn't work, however if you compile VICE emulator for C64 on the PC version it will work perfectly. There's also something wrong with the DNS setup on the Zero image, I ended up deleting all the resolv.conf stuff and starting again manually and got it to work. That's where I'm at.
Reply
#18
No, you're probably seeing the Amiga entry in EmulationStation, but there is no Amiga emulator or binary AFAIK
Dependencies are not installed in SLIM image (X11 environment and other stuff) so you still probably wont get it to build it correctly.
Maybe you'll have more luck with the Full v4.1 , there are some limitations as it relies on X to work ( filenames cant have spaces) , but if/when you get them to work, it should be OK)

about DNS, looks like NetworkManager is still messed up, ethernet is working fine though

edit: AMIGA support will be added to full flavor of ROPi v4.2 , WIP)
Reply
#19
Thanks, yep ethernet works good on the PC but the Zero I have has no ethernet port. I have got wireless working now so that's fine but by default it wouldn't resolve. Ok I'll try and find the 4.1 image and see if that works out for me. What I'm trying to build is a mechanical keyboard that has a small board inside which emulates C64 and Amiga, It needs to be very small and the orange pi zero is small enough to fit inside and powerful enough to emulate the Amiga, I can easily get everything working perfectly on the raspberry pi zero but one big problem.. It isn't powerful enough so.. completely pointless. This can be a long term project so I'm not too worried about it. I'll see how some consoles run in the meantime.
Reply
#20
Yes, maybe it should work, but keep in mind, the zero plus2 heats up very easily, make sure to give it some airflow. I have an unit here, gonna test and fix the image building script.

I think your project is viable, performance is very good , but as there isn't really many people developing OrangePi boards out there, it wont be easy as in raspberries.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  CPS2 games unable to start Loo 2 240 06-06-2019, 07:27 PM
Last Post: djcasl
Question 2 or more disc games on PSX longin 6 2,742 08-24-2018, 06:14 AM
Last Post: svj3ist
  Fba dont work CPS2 Games. Help batistars30 3 1,998 04-03-2018, 08:46 PM
Last Post: alexkidd
  AMIGA roms launcher not found LoW 9 4,108 03-19-2018, 04:53 PM
Last Post: alexkidd
  image quality with psx games popeye 0 1,025 02-08-2018, 10:05 PM
Last Post: popeye
  OPI ZERO - HOW TO FIX overscan, slow fps on games mourgolukos 0 1,192 12-25-2017, 09:47 PM
Last Post: mourgolukos

Forum Jump:


Users browsing this thread: 1 Guest(s)