Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Background music & runcommand
#1
Hi, just installed ropi4 few days ago, its great! however, got some small issues, if i enable background music whenever i reboot the configuration reset itself, i mean, its disabled on reboot.

And about runcommand, i can enter it pressing "up" repeadly in the right stick, the select button doesnt seems to work (its an original ps3 controller, tested on jstest and select=0.
Reply
#2
try to Disable it, reboot, then Enable it again
check /etc/init.d/asplashscreen if python line is there
about runcommand, try to get rid of the launching images (they're in /opt/retropie/configs/PLATFORM), seem to be the culprit
Reply
#3
(11-22-2017, 10:30 PM)alexkidd Wrote: try to Disable it, reboot, then Enable it again
check /etc/init.d/asplashscreen if python line is there
about runcommand, try to get rid of the launching images (they're in /opt/retropie/configs/PLATFORM), seem to be the culprit

Ur right about the runcommand thing, once launching images gets disabled it works normally again.

About the BG music no luck, tried several reboots enabling disabling,also tried disabling splash screens but nothing, it refuses to work. If i enable it on ES it works untill next reboot, also if i quit ES with F4 then run emulationstation it works. About the line i suppose u are refering to this "python /home/pi/RetrOrangePi/Background_Music/bgmusic.py &

    exit 0", yes its there, bgmusic.py enable and disable files are also in their respective folders.
Reply
#4
Still cannot reproduce the bug.
One more thing to try: enter RetroPie-Setup - Manage packages - main (or optional), install splashscreen support , it also contains the python bgmusic.py, worth a try
Reply
#5
(11-23-2017, 10:54 AM)alexkidd Wrote: Still cannot reproduce the bug.
One more thing to try: enter RetroPie-Setup - Manage packages - main (or optional), install splashscreen support , it also contains the python bgmusic.py, worth a try

Fixed. I had the same problem and it works perfectly. Thanks again.
Reply
#6
(11-23-2017, 10:54 AM)alexkidd Wrote: Still cannot reproduce the bug.
One more thing to try: enter RetroPie-Setup - Manage packages - main (or optional), install splashscreen support , it also contains the python bgmusic.py, worth a try

Fixed for me too, i also think that i have found the culprit, whenver i enable the splashscreen randomizer the bugs occurs, if i disable it the music plays fine again, pity, cause the splashrandomizer was a very cool feature, anyway, thx for ur support alex
Reply
#7
i wil check our script, maybe it's a bug on our side. If you have some screenshots and logs, open an issue here: https://github.com/retr0rangepi/RetrOrangePi
Reply
#8
Oh well i would but i have no idea where to get the appropiate logs or which screenshots would be of any use, my knowledge of linux is very limited, anyway, the bug is easily reproducible,for me it happend everytime i enable the randomizer

EDIT: configuring splash screen with own video seems to produce the same bug
Reply
#9
OK, we'll take a look.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Sad Background music gone when system restart. Help! Revnus 0 70 06-28-2019, 05:44 AM
Last Post: Revnus
  NO BACKGROUND MUSIC AT BOOT saroninux 3 1,064 09-23-2018, 10:28 AM
Last Post: saroninux
  No background music at boot (when randomizer is enabled) saroninux 1 1,341 01-22-2018, 08:32 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)