Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clone N64 controllers don't work.
I bought these clone N64 controllers.  They configure in ES and work with ES to navigate but when I launch a game in N64 they don't work.  Pressing any button or moving the joystick does nothing.  I also tried the NES emulator with the same results.  My other PlayStation style controller works but the button mappings are all different from what I configure in ES.  Are these controllers incompatible junk or am I doing something wrong?  If these controllers are junk how to I correct the button mapping with the N64 emulator?
Actually i think its a regression caused by Retroarch 1.6.9, still need more tests to confirm it or not.
You can test the old binary
Copy to /opt/retropie/emulators/retroarch/bin/ with sudo
(12-06-2017, 09:38 AM)alexkidd Wrote: Actually i think its a regression caused by Retroarch 1.6.9, still need more tests to confirm it or not.
You can test the old binary
Copy to /opt/retropie/emulators/retroarch/bin/ with sudo

That didn't fixit.  It did however break my NES emulator.  The controllers did "work" in N64 though.  Since it broke the NES I went back to the original binary.  Oddly I can get the controller to work now for some reason.  The button mapping is wonky which I'll have to figure out but I probably won't bother since these controllers are cheap garbage.  I hope noone buys them and gets ripped off like I did.  the analog joystick is just a replication of the D-pad and there is nothing analog about it.  This alone makes it useless and most games unplayable. 

If anyone knows where I can get some decent N64 style controllers or even if any decent N64 style controllers are even made I'd appreciate any info anyone has to share.
I think I am also having similiar issue.
I am using DIY USB adapter based on ATMega microcontroller and it worked like charm in previous version. As I posted before, I bumped this with zx-spectrum emulator. But it shows, that found joystick.
Anyway, I will test more and update.
Our guess is some regression with Armbian, removing some drivers from default build, we will confirm this soon
The analog stick of these controllers is not truely analog. It's just 8-way digital unfortunately, this is a hardware limitation of the controllers.

Also still looking for an N64 controller which replicates the analog stick like the original.
i dont know if this would help in anyway... it's a howto to add analog bindings when your controllers dont have analog or when it's not recognized as such.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [split] Multiple PS3 controllers compatibility trowakage 4 2,195 02-26-2018, 03:06 PM
Last Post: trowakage
  Wii pro controllers Rundll32 2 1,630 02-25-2018, 12:20 AM
Last Post: canadien
Thumbs Down the Select button on the GPIO does not work as Hotkey Nipoman 4 3,123 12-28-2017, 07:26 PM
Last Post: alexkidd
  NES with 4 controllers? Emulator only recognizes first 2 Triangles 2 2,029 12-06-2017, 01:02 AM
Last Post: Triangles

Forum Jump:

Users browsing this thread: 1 Guest(s)