Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Display rom file name in unicode character.
#1
I copy roms to a fat 32 external usb drive. Some roms are in unicode file name(chinese char). 

Some rom folders contain  xml gamelist(chinese char. )  in which the name list in ES could not display properly until i google and run the following command at terminal:
sudo apt-get install fonts-droid

However,  some rom folders does not have xml gamelist and the file name of the roms were in chinese character.zip which could not be displayed either on ES or file manager of desktop. 

I googled 'fstab' at fedora forum but i cant use it at retrorangepi. 

What else could be done to display the file name properly at least on ES, and if possible, also on desktop.

Thanks.
Reply
#2
fstab is not used for mounting external USB drives, it's driven by usbmount instead:
run 'sudo nano /etc/usbmount/usbmount.conf' maybe you just need to add some extra regional parameters to MOUNTOPTIONS...
Reply
#3
It works!  The unicode file name can now be displayed in both ES and desktop!
The script i edit in usbmount.conf are:

FS_MOUNTOPTIONS="-fstype=vfat,umask=0,fmask=111,iocharset=utf8 -fstype=ntfs,umask=0,fmask=111,iocharset=utf8"

Thanks!
Reply
#4
double check if you need to add / keep our settings for FAT32 permissions

https://github.com/retr0rangepi/RetroPie...service.sh

FS_MOUNTOPTIONS" "$ini_value -fstype=vfat,umask=022,uid=$uid,gid=$gid"
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  PCSX core and Emulation fight for display ChronoStriker1 4 91 01-13-2018, 08:44 PM
Last Post: ChronoStriker1
  Create Update File Wooper 2 139 12-22-2017, 11:33 AM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)