Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pink screen on boot issue - any progress?
#1
I wonder if there any ideas how to solve this pink screen issue on ROPI 4.1 boot?
Cold start always lead to this, then on "hot" rebooting - only 1 of 4-5 times..
Is it Armbian issue then?
Reply
#2
Same problem, any solutions? thanks!
Reply
#3
Please try this
http://orangepi.club/showthread.php?tid=...15#pid4215
Reply
#4
Didn't help, unfortunately Undecided 
I doublechecked to download and install proper u-boot version for my OPI+2E.

The only solution I found is to turn on my TV before I turn on OPIE - then pink screen never appears.
Reply
#5
Adding this bug to v4.2 todo list.
We still cannot reproduce this. So, if we find a fix somehow, we'll post here in the forums
Reply
#6
Got the same problem, but I'm using the same solution as greenais -I just turn TV on before plugging in OPi. Also, TV should be set to input signal from OPi - other way I still get pink screen.
Another moment - this should be done only when turning on OPi. As long as it's up and running, TV can be turned off or switched to another source, pink screen won't appear if you switch back to OPi.
Reply
#7
Has anyone have a solution to pink screen on HDMI TVs?

Everytime I boot Orangepi into a HDMI TV I have the Pink Screen.
When booting in a VGA monitor (with adapter to VGA) it boots up normal.

Alreayd tried everything when it comes to after-boot resolution. I think maybe something with booting...

Is there a way to boot orangepi without all that splash? Just pure linux? I think it wont work either, but we can try, right?

Changing fast from the VGA monitor to HDMI TV I can see the boot logs, so I think its something before the boot logs, something before. i'm new to this U-boot stuff (last *nix work was with LILO)
Reply
#8
(02-16-2018, 07:07 PM)bagualas Wrote: Has anyone have a solution to pink screen on HDMI TVs?

Everytime I boot Orangepi into a HDMI TV I have the Pink Screen.
When booting in a VGA monitor (with adapter to VGA) it boots up normal.

Alreayd tried everything when it comes to after-boot resolution. I think maybe something with booting...

Is there a way to boot orangepi without all that splash? Just pure linux? I think it wont work either, but we can try, right?

Changing fast from the VGA monitor to HDMI TV I can see the boot logs, so I think its something before the boot logs, something before. i'm new to this U-boot stuff (last *nix work was with LILO)

Some debug that we can work?
I found the only message in messages when I deattach and attach HDMI cable (with or without adaptar), when the screen is pink:
"ddc rst timeout"

only reference: https://github.com/allwinner-zh/linux-3...._sun8iw7.c


And my boot log (got with serial cable)
[   76.510671] Restarting system.
[   76.514152] Restarting Linux version 3.4.113-sun8i (root@pi-HP-Compaq-Elite-8300-SFF) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #112 SMP PREEMPT Sun Nov 26 02:28:40 GMT 2017
[   76.514163]

U-Boot SPL 2017.11-armbian (Nov 26 2017 - 02:21:43)
DRAM: 512 MiB
Trying to boot from MMC1


U-Boot 2017.11-armbian (Nov 26 2017 - 02:21:43 +0000) Allwinner Technology

CPU:   Allwinner H3 (SUN8I 1680)
Model: Xunlong Orange Pi Lite
DRAM:  512 MiB
MMC:   SUNXI SD/MMC: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
starting USB...
USB0:   USB EHCI 1.00
USB1:   USB OHCI 1.0
USB2:   USB EHCI 1.00
USB3:   USB OHCI 1.0
scanning bus 0 for devices... 1 USB Device(s) found
scanning bus 2 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
reading /boot.scr
2710 bytes read in 19 ms (138.7 KiB/s)
## Executing script at 43100000
gpio: pin PL10 (gpio 298) value is 1
   Warning: value of pin is still 0
gpio: pin PG11 (gpio 203) value is 1
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
** Unable to read file .next **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
reading script.bin
34880 bytes read in 25 ms (1.3 MiB/s)
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
reading uInitrd-3.4.113-sun8i
3837099 bytes read in 203 ms (18 MiB/s)
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
reading vmlinuz-3.4.113-sun8i
4773416 bytes read in 247 ms (18.4 MiB/s)
## Loading init Ramdisk from Legacy Image at 43300000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    3837035 Bytes = 3.7 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
Using machid 0x1029 from environment

Starting kernel ...

[sun8i_fixup]: From boot, get meminfo:
        Start:  0x40000000
        Size:   512MB
ion_carveout reserve: 160m@0 256m@0 130m@1 200m@1
ion_reserve_select: ion chipid  [0x2c00081!
ion_reserve_common: ion reserve: [0x56000000, 0x60000000]!

Debian GNU/Linux 8 RetrOrangePi ttyS0
Reply
#9
The pink screen is in the version RetrOrangePi 4.2 SLIM, any solution?

Thanks for this new version!
Reply
#10
no solution, find a combination turning on the board with the TV set on, or the opposite. The fix is in there.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Screen rotation printnplay 6 704 11-14-2018, 01:19 AM
Last Post: Tchernobil
  Orange pi lite retrorangepi 4.1 won't boot Merlin3D 6 2,531 11-11-2018, 08:23 PM
Last Post: Doogie10
  NO BACKGROUND MUSIC AT BOOT saroninux 3 264 09-23-2018, 10:28 AM
Last Post: saroninux
  4.2 full issue No Sound through desktop Merlin3D 2 295 09-11-2018, 02:59 AM
Last Post: Merlin3D
  Any method to hide boot text? genzi0401 5 762 09-04-2018, 03:15 PM
Last Post: neworange
  Openelec locked on Home screen Nill2016 4 935 09-03-2018, 02:43 AM
Last Post: Padova
Star Get boot but can't go into the emulator Himyorange 1 371 07-22-2018, 02:18 AM
Last Post: alexkidd
  how to fix screen black bar at bottom AV orange pi zero jamespoo 4 859 05-28-2018, 12:15 PM
Last Post: jamespoo
  Orangepi pc image comes out of the screen Ropi 4.1 juliodias0297 8 2,061 05-21-2018, 12:19 PM
Last Post: juliodias0297
  Shanwan Android Gamepad issue YiorgosH 2 1,040 03-02-2018, 09:28 PM
Last Post: YiorgosH

Forum Jump:


Users browsing this thread: 2 Guest(s)