Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Retrorangepi + tft 2.4" screen spi ili9341
#1
Are any way to use this 
2.4" lcd screen in Retrorangepi?

It uses ili9341.

Thanks.
Reply
#2
we don't have the screen to test, a user reported:

"It works but you can only use opengles in x11 and not in framebuffer (...) If you want use for other thing probably best start from an update armbiam distro"
check this howto: https://www.facebook.com/groups/11317596...cation=ufi
Reply
#3
(01-23-2018, 06:12 PM)alexkidd Wrote: we don't have the screen to test, a user reported:

"It works but you can only use opengles in x11 and not in framebuffer (...) If you want use for other thing probably best start from an update armbiam distro"
check this howto: https://www.facebook.com/groups/11317596...cation=ufi

https://github.com/bitbank2/BB-CP

i can operate retrorange pi with ili9341 lcd, using this git.

i confirm that orange pi zero can operate retrorange pi with framebuffer.
and it was useful.

but i can't revise code, so i don't know how i can use this git.

i want to operate this program at boot.
Reply
#4
you can add the execute command to /etc/rc.local . Maybe it works, i dont have that screen to test
Reply
#5
Question 
Hi, everyone!
I tried to use BB-CP on my Orange pi zero with ILI_9341 running Retrorangepi. It work but only with 40 fps at steady image and drops to 20 (sometimes even less). Also I get this message when I run the bbcp :

"Warning: the framebuffer bit depth is 32-bpp, ideally it should be 16-bpp for fastest results"

So I set the fb bit depth to 16, run the bbcp again and the screen went wild:
[Image: VZKRJPd.jpg]

This happens only to the tft, composite works fine. I also tried 24bpp bit depth but then both displays started showing things like that.

If you have any ideas how to run the display at 16 bit depth please tell me Smile
Reply
#6
Hi all
I tried this LCD today and I have the same issues than bumtras, but didn't try 16b depth.
I have about 14 - 40 fps

@bumtras: how did you changed framebuffer bit depth please ?
and what did you changed in script.bin ?

Thank you.
Reply
#7
I tried all fb0_format possibilities in script.bin
- RGB655, RGB565, RGB556, ARGB1555 are working, but it's quite slow and indicates an invalid framebuffer 32b depth
- ARGB4444 doesn't generate errors and seems to have a good framerate (23-60), but:

   

I'm giving up
If you know a solution, please post Smile
Reply
#8
(03-04-2018, 04:45 PM)popeye Wrote: I tried all fb0_format possibilities in script.bin
- RGB655, RGB565, RGB556, ARGB1555 are working, but it's quite slow and indicates an invalid framebuffer 32b depth
- ARGB4444 doesn't generate errors and seems to have a good framerate (23-60), but:



I'm giving up
If you know a solution, please post Smile

Sorry for the late answer! Smile
For changing the bitdepth I used "fbset -depth 16" for 16bpp and respectively "fbset -depth 32" for 32bpp.
In script.bin I have changed the fb0_format to ntsc for 60fps and fb1 resolution to 320x240.

NOTE:
The screenshot above is from retrorangepi 3.1(or 3.0 not shure) later I upgrated to 4.0 and the same thing happend, only it was looking a bit diferent.
Reply
#9
Thank you bumtras Smile

I tried several configuration but there is always issues.
Best results are with that config:
fb0_width = 320
fb0_height = 240
fb0_format = 10    (I don't know what this means exactly)
and fbset -depth 16
I have 22-30 fps with micro machine v3 (ps1)
however the screen becomes white when I leave a game.
I'll tell you if I have better results...
Reply
#10
(03-04-2018, 07:55 PM)popeye Wrote: Thank you bumtras Smile

I tried several configuration but there is always issues.
Best results are with that config:
fb0_width = 320
fb0_height = 240
fb0_format = 10    (I don't know what this means exactly)
and fbset -depth 16
I have 22-30 fps with micro machine v3 (ps1)
however the screen becomes white when I leave a game.
I'll tell you if I have better results...

I have made a mistake in my last post.
This are the changes in the script.bin that I have been made:
Code:
screen1_output_mode = 14
fb0_width = 320
fb0_height = 240


I no longer have the file so I can't be sure. But every combination that I have tried was unsuccesfull.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Bug [DRIVER BUG] [RetrOrangepi v4.1] Wifi Very Inconsistent evert7877 1 731 01-29-2018, 10:37 AM
Last Post: alexkidd
  BananaPi m2 Berry + RetrOrangePi + Nespi case phobosjv 3 1,252 01-11-2018, 08:49 AM
Last Post: Liontek1985
  RetrOrangePi 4.1 + PS3 shanvan lego666 1 854 12-21-2017, 11:01 AM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)