Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DRIVER BUG] [RetrOrangepi v4.1] Wifi connected but no internet

I use the Orange Pi PC with a Wifi Dongle: TP-LINK TL-WN725N
With a freshly installed image of RetrOrangePi-4.1.Orangepipc.img on a 8gb miniSD card I let Retrorange pi boot and go to Desktop to configure Wifi because the RETROPIE-SETUP wifi program don't let me connect.

Anyway, when I am at the RetrOrange Pi desktop I click on the right top button and click on my home WiFi... 
Huh? two Wifi interfaces on one dongle? hm... strange ohh well beter pick one. *enters wifi password "Connection Established"

Let's go to Root Terminal and check: ping
bingo, internet so everything should be fine. I back out of Desktop en inside the Emulator Station to "Update RetroPie-Setup script"... unable to fetch script?! Wierd because in desktop I can ping google.

Well let's try the "Configururation / tools to connect to the Wifi... Connect to Wifi network <ok> Select WiFi <ok> Enter Password <ok> ... it takes over a minute to start connecting ... *Connecting... And it take a axtra minute to tell me "Unable to connect to network Chateau van Ingen"

So let's go back to Desktop and check Ifconfig and /etc/network/interfaces:
When I arrive to Desktop it quickly connects to the WiFi... as if it's sneaky about connecting Tongue

Ok Check sudo ping
From icmp_seq=1 Destination Host Unreachable 
this happens 40 times and then is reachable  Confused

Right... Ifconfig

pi@RetrOrangePi:~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 72:39:20:6a:d4:62  
          inet6 addr: fe80::7039:20ff:fe6a:d462/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:580 (580.0 B)

eth0:avahi Link encap:Ethernet  HWaddr 72:39:20:6a:d4:62  
          inet addr:  Bcast:  Mask:
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:540 errors:0 dropped:0 overruns:0 frame:0
          TX packets:540 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:46696 (45.6 KiB)  TX bytes:46696 (45.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 7c:8b:ca:1c:ff:58  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::7e8b:caff:fe1c:ff58/64 Scope:Link
          RX packets:320 errors:0 dropped:1 overruns:0 frame:0
          TX packets:244 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:47482 (46.3 KiB)  TX bytes:32162 (31.4 KiB)

wlan1     Link encap:Ethernet  HWaddr 7a:8b:ca:1c:ff:58  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:133 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)[/code]

sudo nano /etc/network/interfaces

# Wired adapter #1
allow-hotplug eth0
#no-auto-down eth0
iface eth0 inet dhcp
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838

# Wireless adapter #1
# Armbian ships with network-manager installed by default. To save you time
# and hassles consider using 'sudo nmtui' instead of configuring Wi-Fi settings
# manually. The below lines are only meant as an example how configuration could
# be done in an anachronistic way:
allow-hotplug wlan0
iface wlan0 inet dhcp
#   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
# Disable power saving on compatible chipsets (prevents SSH/connection dropouts over WiFi)
#wireless-mode Managed
#wireless-power off

# Local loopback
auto lo
iface lo inet loopback

Hm, let's do a reboot and check if I can see my IP in "Show IP" in the RetrOrange Pi menu. No IP address...
[Image: 1z39v6s.jpg]
When I got back to desktop it's connected with Wifi but no internet. And it didn't come back either.

I had my internet back when I disconnect eth0. I always have to disconnect eth0. (no cable attached)
So now if I go back to Emulator Station and check "Show IP" in the RetroPie settings menu I have a IP adres.

Now on reboot I checked my ip again with "Show IP"... no ip, arrived at desktop... not connected... This is getting old!
Why is my Wifi not automatically connecting? for weeks I have these inconsistent things that annoy the hell out of me.

Right, so top right corner click on connection icon and reconnects to wifi "Chateau van Ingen" I don't know why but somehow it forgot the password to the WiFi.
*Sight Sudo ping destination Host Unreachable... *Disconnects eth0... is reachable again.

Why is this a thing... It's driving me mad.

Let's add # to the eth0 part in /etc/network/interfaces
# Wired adapter #1
#allow-hotplug eth0
#no-auto-down eth0
#iface eth0 inet dhcp
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838

sudo reboot

Let's see if I have a Ip on boot to RetroOrange Pie...
*Tries to navigate to RetroOrange Pi menu *Get's Segmentation fault error due to (usb attached) PS3 driver bug *Facepalm
*Sigh, reboot and try again. (usb attached) PS3 controller is causing system freezes when in retrorange pi menu. *Sigh, reboot and try again.
The controller disconnects automatically with random delay.

Still no IP in "Show IP" on boot.

This is what it states:
[Image: j0cnx3.jpg]

*Sight, I am going to reinstall and try again with a fresh image. Use a Ethernet cable for the internet en update the setup scrip, install ps3 controller driver from source and try to get the WiFi to work as it should. CONNECT ON BOOT ! Angry

I'll keep editing this Topic for updates as I go along and try things and to keep track what I have tried and for the people who also may have these issues.  So this states my problem, how can I make it so that I don't need to go to desktop every time to disconnect eth0 and enjoy wireless internet?

Thank you  Blush
sudo mv interfaces /etc/network/
sudo reboot
Dear alexkidd,

I have tried this fix but still no internet...
Sudo ping
Destination Host Unreachable

Hm, after menually selecting one the two Wifi interfaces (wlan0) to connect to the proper Wifi I got Internet again.
Let's reboot and try again. Ok in desktop mode it auto connects to the internet now to lets reboot and check in RetrOrange Pi...

Nope for some reason it is for RetrOrangePi impossible to auto connect to the WiFi without me going to the desktop first! When I go back to the Desktop enviourment I check sudo ping and guess what? DESTINATION HOST UNREACHABLE!!!
Wifi is connected... eth0 *clicks on disconnect What do you know is reachable...

# Wired adapter #1
#allow-hotplug eth0
#no-auto-down eth0
#iface eth0 inet dhcp
# hwaddress ether # if you want to set MAC manually
# pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838

and after sudo ifconfig eth0 down

Still no ip adres from WiFi without going to desktop.
Try to manual typing youre Time, they must be correct to internet works good.

Possibly Related Threads...
Thread Author Replies Views Last Post
  wifi sky123 1 3,256 01-28-2018, 06:33 PM
Last Post: evert7877

Forum Jump:

Users browsing this thread: 1 Guest(s)