Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Orange Pi Zero image - beta testing
#1
Hello guys,

Orange Pi Zero image is here. Still beta, still has a couple of bugs. Unfortunately we couldnt find spare time to implement all fixes into the image, so a hotfix script was included instead. After flashing the image, boot the sdcard and wait a couple of minutes for it to expand filesystem. Dont mind the user prompt in the first boot, it will reboot automatically shortly afterwards. 

Before downloading/installing files or running options from RetroPie/RetrOrangePi menus, press Start, select the Desktop option, run the Wifi Config if needed, then run the hotfix from terminal:

Code:
pi@RetrOrangePi:~$ /boot/FixOpiZero.sh
The script will try to fix the DNS bug we're still having and install system dependencies.

As featured in v4, overscan can be fixed from our menu Retropie - RetrOrangePi - Audio/Video Selector). You can choose NTSC or PAL systems. If you have any trouble running from EmulationStation, run the script from terminal as well:

Code:
pi@RetrOrangePi:~$ /home/pi/RetrOrangePi/BashTool_ROPI_RCA/Tool/run.sh
This should be enough to get you a good system to play with. Apparently it’s more stable than v3. At least, the kernel panic seems to be gone. Big Grin

Please report any bugs, we’ll fix them before releasing the final v4.2 version.
#2
Good job guys
Ill try it soon
Thnx
#3
The first few mistakes I encountered were that no retropie menu is being accessible, both just upload but return to the home page.
#4
did you follow the instructions? "Before downloading/installing anything, press Start, select the Desktop option, run the Wifi Config if needed, then run the hotfix from terminal" I will add more instructions to the thread
#5
(01-30-2018, 07:01 PM)alexkidd Wrote: did you follow the instructions? "Before downloading/installing anything, press Start, select the Desktop option, run the Wifi Config if needed, then run the hotfix from terminal"  I will add more instructions to the thread

Yes, step by step calmly. After that I tried to execute the av tool, but it did not open and I executed the same one by the code quoted in the post. I made the screen selection and tried to open the other menus and they did not open.
#6
you wont be able to open mostly anything from the menus without running the hotfix. You must have a working connection. If you encountered any issue, post a screenshot or error message if you can
#7
(01-30-2018, 07:15 PM)alexkidd Wrote: you wont be able to open mostly anything from the menus without running the hotfix. You must have a working connection. If you encountered any issue, post a screenshot or error message if you can

I only got these pictures unfortunately. I do not know if it will help much.


[Image: 24d4sch.jpg]
[Image: 2hci3p0.jpg]
#8
try running these lines:

sudo cp /boot/temp/interfaces /etc/network
sudo /etc/init.d/networking restart

then run the script again.

Do you use a wifi or ethernet connection?
#9
(01-30-2018, 07:33 PM)alexkidd Wrote: try running these lines:

sudo cp /boot/temp/interfaces /etc/network
sudo /etc/init.d/networking restart

then run the script again.

Do you use a wifi or ethernet connection?
Okay, I use wifi. so I run these lines do I run the hotfix script?
#10
add one more line:

sudo ifconfig eth0 down
sudo cp /boot/temp/interfaces /etc/network
sudo /etc/init.d/networking restart

then run the hotfix again


Possibly Related Threads...
Thread Author Replies Views Last Post
  Compiling retroarch on Orange Pi juan 6 947 06-06-2018, 08:58 PM
Last Post: linuxarcade
  ROPi TRANSLATIONS - beta release alexkidd 13 2,557 04-02-2018, 03:01 PM
Last Post: alexkidd
  Streets of Rage Remake port - beta release alexkidd 0 1,310 12-08-2017, 12:14 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)