Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Uae.
#1
after updatind from version 3 to version 4 uae stopped working.
I made several tests...
Also reinstalling everything.
And doing the update.... and here the situation starts to be strange...
at the beginning lauch the update twice was needed...
...with the image that i flashed yesterday seems that everything is done in only one update. Ist it correct.
Then i have to put bios roms:
kick13.rom, kick20.rom, kick31.rom
in BIOS folder...
exactly wich rom i have to rename to kick13 20 and 31?
then in roms folder...
what i have to put?
ADF and ADZ or config files .UAE?
Reply
#2
(02-26-2018, 10:49 AM)UnoCheConosco Wrote: after updatind from version 3 to version 4 uae stopped working.
I made several tests...
Also reinstalling everything.
And doing the update.... and here the situation starts to be strange...
at the beginning lauch the update twice was needed...
...with the image that i flashed yesterday seems that everything is done in only one update. Ist it correct.
Then i have to put bios roms:
kick13.rom, kick20.rom, kick31.rom
in BIOS folder...
exactly wich rom i have to rename to kick13 20 and 31?
then in roms folder...
what i have to put?
ADF and ADZ or config files .UAE?
I think that is normal that the update will be in just one shot. (will be interesting a popup that say what is updated for nerds like me that we want to update everything)
Kick 13 is not used...
according to info found on internet about Retropie should be:
Kickstart v2.05 r37.299 (1991)(Commodore)(A600)[!].rom (rename it to kick20.rom)
Kickstart v3.1 r40.63 (1993)(Commodore)(A500-A600-A2000)[!].rom (rename it to kick31.rom)

but amiga 12000 kickstar should be this....
Kickstart v3.1 rev 40.68 (1993)(Commodore)(A1200)[!]
Anyway i had several problem running games from the menu....
p.s. you should use as launch program amiga500 or amiga1200 (but somewhere i read that amiga1200 is broken)
and filenames shoud not have space inside!
pp.s in this way i have no idea how to use multidisk games...
I hope that somebody that has already well configured will post about.
Reply
#3
it might be the same problem ?
Reply
#4
FS-UAE is being removed as it wont perform as good as UAE4ARM. To fix Amiga configuration, run the following:
=> sudo ~/RetroPie-Setup/retropie_packages.sh uae4arm configure

if you update from v3 from v4, it's worth compiling uae4arm again with:
=> sudo ~/RetroPie-Setup/retropie_packages.sh uae4arm (or using retropie-setup and selecting uae4arm from there)

running those commands should reset your amiga configurations and create Start UAE4ARM script. You can drop .zip and .adf into roms/amiga folder, they should run from EmulationStation (even a single ZIP with several floppies work). kick13.rom, kick20.rom and kick31.rom are accepted, but you can customize hem in UAE4ARM configuration.

for 512MB boards, adding swap is sometimes needed.
Please report , we are improving Amiga configs as we speak.
Reply
#5
here is a log of a reinstallation on opi0 if it helps, it seems there is something wrong.
Reply
#6
for the opi zero, uae4arm had to be customized so it works better on analog output.
Are you using v3 update OR v4.1 beta? If it's the latter, you shouldnt need to recompile it.
edit: actually the error is caused by the lack of libmpeg2-4-dev package
Reply
#7
(02-26-2018, 03:00 PM)alexkidd Wrote: FS-UAE is being removed as it wont perform as good as UAE4ARM. To fix Amiga configuration, run the following:
=> sudo ~/RetroPie-Setup/retropie_packages.sh uae4arm configure

if you update from v3 from v4, it's worth compiling uae4arm again with:
=> sudo ~/RetroPie-Setup/retropie_packages.sh uae4arm  (or using retropie-setup and selecting uae4arm from there)

running those commands should reset your amiga configurations and create Start UAE4ARM script. You can drop .zip and .adf into roms/amiga folder, they should run from EmulationStation (even a single ZIP with several floppies work). kick13.rom, kick20.rom and kick31.rom are accepted, but you can customize hem in UAE4ARM configuration.

for 512MB boards, adding swap is sometimes needed.
Please report , we are improving Amiga configs as we speak.
thank you! I will try in the weekend.
Reply
#8
When I try to recompile uae4arm, I get some error:

<builtin>recipe for target 'src/cd32_fmv.o' failed

Any idea ?
Reply
#9
Update RetrOrangePi from our menu option and activate swap. It's probably low RAM
Reply
#10
(03-10-2018, 01:25 PM)alexkidd Wrote: Update RetrOrangePi from our menu option and activate swap. It's probably low RAM

Thanks !

Seems like activating swap did the trick.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)