Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problem to install on orangepiplus2e emmc
#1
Hello

Any help will be welcome...
I think i tried everything to install retrorange pi on orangepi plus 2e emmc with no succes.
The provided install_emmcv4.sh script don t work because the emmc device is not detected with standard 4.1 installation (mmcblk1 doesn t t appear in /dev). I can assume that is not a board failure because i ve no problem to install last armbian version with nand_to_sata...
So i tried a lot of things, from u-boot update to sunxi kernel recompilation or flashing directly from armbian, but nothing seems to work.
Has somebody succesfully done the trick ?

thanks for your help
Reply
#2
can you try "sudo fdisk -l" from command line and post the output?
Reply
#3
Code:
Disk /dev/mmcblk0: 14.9 GiB, 15931539456 bytes, 31116288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x78bef114

Device         Boot   Start      End  Sectors  Size Id Type
/dev/mmcblk0p1         8192  1056767  1048576  512M  e W95 FAT16 (LBA)
/dev/mmcblk0p2      1056768 30805119 29748352 14.2G 83 Linux

As you see i only have partitions from extrernal mmc Sad
Reply
#4
can you "transplant" a valid script.bin from a pure Armbian distro and replace ours on the boot partition? Maybe it will magically detect. IF you have a failed boot afterwards, copy/paste from boot/bin/orangepiplus2e.bin to script.bin to revert back
Reply
#5
on armbian distro

Code:
script.bin -> bin/orangepiplus2e.bin

and

Code:
cksum bin/orangepiplus2e.bin

341417207 36808 bin/orangepiplus2e.bin


on retrorangepi
Code:
root@RetrOrangePi:/boot# cksum script.bin 

341417207 36808 script.bin


the files are already strictly identical, and of course copying the armbian one to retrorangepi didn t change anything
Reply
#6
we have a plus2e user report that it works, so i'm failing to find whats wrong with your setup
Reply
#7
what @saitoh00 is talking about whith  Retrorange pi 4.1 + 1.0  Hotfix . I searched everywhere about this fix but didn t found it. 
Could you explain me what it is ?
Reply
#8
It's just the Update RetrOrangePi option from ES. From a fresh system, you just need to run it twice, we added extra commands to the update script
Reply
#9
So , it has already been done, and is not my mistake Sad
Could you tell me what kernel source use and what config u used on it ?
Reply
#10
latest armbian - legacy 3.4.113 kernel with FAT boot partition
alternatively, maybe you get luck flashing v3.0.1 then updating to v4.0
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Question How to install RetrOrangePi onto pre-installed Armbian fureweb 18 7,785 08-06-2019, 06:00 PM
Last Post: alexkidd
  PPSSPP key mapping problem xonn 0 266 04-21-2019, 10:32 AM
Last Post: xonn
Exclamation No internet, No eMMC... Fael 4 1,727 09-21-2018, 12:02 AM
Last Post: alexkidd
  Clone ROPI 4.1 from EMMC to MicroSD garcia 2 1,067 08-02-2018, 10:53 PM
Last Post: alexkidd
  OPANGEPI PC ROPI 4.1 gamepad problem unrw@mail.ru 8 5,107 05-05-2018, 08:48 AM
Last Post: djcasl
Shocked How do I format EMMC on PI PC +? seantattoo666 2 2,136 05-03-2018, 09:29 PM
Last Post: seantattoo666
  PROBLEM - ROMS self deleted on ROPI 4 unrw@mail.ru 5 2,822 03-15-2018, 12:57 PM
Last Post: alexkidd
  Please Help with Install. mightythias 1 1,278 03-15-2018, 12:26 AM
Last Post: alexkidd
  emmc install and sd rom boot brains74 1 1,812 02-12-2018, 07:13 PM
Last Post: alexkidd
  Dosen't boot after EMMC Install ronson 24 17,273 02-01-2018, 12:04 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)