Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenGL
#1
I found an instruction to add OpenGL, https://forum.armbian.com/topic/1420-ope...pi-pc-etc/
I wanted to try it, will the current driver will not break ?
I understand that OpenGL in this system is not configured?
I'm trying to  - glxgears.  I get 45 fps and the error is libGL error: unable to load driver: mali_drm_dri.so
Reply
#2
OpenGL is included, just add 'LD_LIBRARY_PATH=/usr/lib/GLSHIM' before the command .
edit: most content already make use of OpenGL ES => Mali, what exactly are you trying to achieve?
Reply
#3
for example, I watched the installation instructions for Minecraft, https://www.raspberrypi.org/forums/viewt...7#p1177639
Reply
#4
you can try your luck, but most of absent content from RetrOrangePi have Raspberry-only dependencies
Reply
#5
there's nothing much as far as I understand, GL driver, Java
yes, but you need to make the GL driver work on the armbian desktop, at the current setting glxgears reports that it does not see them
Reply
#6
As said, OpenGL is included, but you have to add 'LD_LIBRARY_PATH=/usr/lib/GLSHIM' (environmental flag) before the command . That's what we do, for example, with the Amiga emulator.
Reply
#7
I connected to my orange pi via the rdp protocol as root, after logging out of my account. now I get such results
Code:
root@RetrOrangePi:~# glxgears
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
740 frames in 5.0 seconds = 147.720 FPS
980 frames in 5.0 seconds = 195.131 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":11.0"
     after 4116 requests (37 known processed) with 0 events remaining.

Does this mean that the driver is loaded and running?
Reply
#8
you NEED to add LD_LIBRARY_PATH=/usr/lib/GLSHIM before the command, like this:

Code:
LD_LIBRARY_PATH=/usr/lib/GLSHIM /usr/bin/glxgears


btw, it will only work on X desktop
Reply
#9
(03-05-2018, 01:02 PM)alexkidd Wrote: you NEED to add LD_LIBRARY_PATH=/usr/lib/GLSHIM before the command, like this:

Code:
LD_LIBRARY_PATH=/usr/lib/GLSHIM /usr/bin/glxgears


I'm trying to launch GL-based Quake 3 Arena and OpenArena using this approach, but getting exactly the same error (example):


Code:
Initializing OpenGL display
...setting mode -1: 1280 720
LIBGL: Unable to create EGL display.
LIBGL: Unable to create EGL display.

...several times...

LIBGL: Unable to create EGL display.
Available modes: '1280x720'
Couldn't get a visual

I can understand why it fails trying to init modes like 640 480, but why it does for "native" one - 1280 720?
Any suggestions, perhaps?
The same "Unable to create EGL display" error happens for glxgears as well.


Without LD_LIBRARY_PATH=/usr/lib/GLSHIM OpenArena starts, but performance is just terrible - even in start menu.
glxgears without glshim works but with the same errors (no driver) in console as in post above.
Reply
#10
AFAIK, GLSHIM will only work in X11 (Desktop) environment, not in the framebuffer
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)