Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Suvell R69 ROPI4.1 quick tips
#1
Wink 
Here's a quicky a dirty procedure for using ROPI4.1 on the Sunvell R69 tv box with the H2.   Other images and procedures will obviously work, but this is mine.

Start with OrangePi Plus2e Image -- burn to sd card and boot

Once its done installing, exit Emulation station and make sure you're logged in as root on the console

Disable LSB networking, so that network manager won't fight against it.

Code:
systemctl disable networking


Install the sunvell Fex file for correct blinky lights, usb, and frequency settings

Code:
cp /boot/bin/sunvell-r69.bin /boot/script.bin


Disable incorrect wireless module from /etc/modules

Code:
sed -i 's/^8189fs$/#8189fs/' /etc/modules

Reboot.


PS 
* You can try the xradio_wlan module, but I would just stick to wired Ethernet
* I've given up on trying to debug the install to on-board flash, just use the SDcard   Wink
* I've found that sometimes after reboot SD boot doesn't work.. I sometimes have to pull the power out a time or to for it to behave,
* Because of it's CPU and thermal limitations, manage your expectations and stick to the lightweight emulators.
Reply
#2
THanks Lane, a Sunvell image is in the works. And you're right, it gets warm! Been running it upside down with a cooler above (below?? hahaha) it
Reply
#3
the same about the SD reboot, it happens with a real Sunvell image as well
Reply
#4
I bought a new Sunvell R69 because what I had previously broke.
On the old everything worked well.
Now I tried to install everything on the new, but every time I try to turn it off, it gives me error:
kernel panic not syncing
it reboots after 10 seconds and does not make any changes.
So it does not install on the internal memory.
I then noticed that the motherboard is of a different color on the green while the old one was on the red.
and reports Allwinnerh202 - V2.2
Maybe different hardware?
Do you know something?

This is the two board

NEW:
[Image: r69n.jpg]

OLD:
[Image: r69o.jpg]


Attached Files Thumbnail(s)
   
Reply
#5
Maybe because another board image is used , installing to emmc might not work. Did you test the feature on V3? What were your steps on the new one?
Reply
#6
but the main problem is that even without installing on the emmc, when I turn off the system appears the error I attached above. So it's not a script problem. I tried with version 3 but on turning off the error. I also tried to install ropi3, always the same error. The procedure is the one I used on the old card, the image beelink, update and install v4.i have tested img of oragepipc but aleays same error.

Tomorrow test other img, but now remember, at end of internal install where print press ok for boot internal i view error bus
Reply
#7
Try another screen, that doesn't seem to be 720p compliant and it causes kernel panic
Reply
#8
I have try all resolution, I tried all the resolutions, but that's not the problem, because I always get the same error when I go to switch off.
Reply
#9
Wait official sunvell image
Reply
#10
tk's alex , but you on that board are you working? on the new or the old?
Because the old (the red one) does not have any kind of problem works great with the beelink image.
So if you are working on this the problem is not solved because it is the new board (green) that has something different not compatible.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)