Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RetroOrangePi 4.1 handle the contollers with huge delay
#1
Hey,
I downloaded from the official website the newest version of RetrOrangePi, namely RetrOrangePi 4.1. and installed it successfully.
When the emulator loaded the rom(s) I have to be waiting for 30 or 60 seconds to start the game because the controllers cannot be handled these time periods.
I haven't got an idea what causes this issue, but it is really annoying.

Are there some tricks or solution which can fix this issue?

As I experienced that the previous version of the RetroOrangePi (3.0) didn't include this bug, but I haven't downloaded again because it isn't available.

Thank you for your help!
Reply
#2
We're still investigating this as we couldnt find any pattern or even reproduce it with the controllers we have (generic dragonrise, xbox360, ps3). It won't happen with every controller. It's probably a device that draws too much from the usb port. It can also be high cpu usage, low RAM, overheat.

Workaround: as soon as it enters the game, unplug / plug the controller, you should see a message immediately saying it was configured.
Reply
#3
Hey,
Thank you for your answer it helped me to find the solution!

What was that:
I updated the controllers' related drivers via RetroPie option. When drivers were updated successfully and restarted the emulator system everything has started to work fine...

It takes 30 or 45 minutes depends on the downloading speed.
Reply
#4
OK, which option did you choose? We could include the update in the upcoming images.
Reply
#5
It was that:

"Retropie --> RetroPie Setup -> Manage Packages --> Manage Driver Packages ->Install / Update all optional packages from source"

"We could include the update in the upcoming images." It would be so cool! Wink
Reply
#6
(05-04-2018, 04:16 PM)Imre_Papai Wrote: It was that:

"Retropie --> RetroPie Setup -> Manage Packages --> Manage Driver Packages ->Install / Update all optional packages from source"

"We could include the update in the upcoming images." It would be so cool! Wink

UPDATE:
It is a possible solution which I found.
Delay in USB Controller being recognised after launching a game.
Reply
#7
Hi, 

I had the same problem and solved it disabling eth0 in networkmanager.

Edit /etc/NetworkManager/NetworkManager.conf and add eth0 mac address (see it with ifconfig) to unmanaged-devices with mac option. For example:

unmanaged-devices=mac:00:11:22:33:44:55;mac:66:77:88:99
Reply
#8
If you have WiFi or network connection this doesn't occur, however if you have your system without network this happens. I had my PC Plus with me at my brother in law. Got delays on controllers and on exiting a game. Have tested the solution from netamego. At home my WiFi fixes this issue.
Reply
#9
(06-08-2018, 10:20 PM)netamego Wrote: Hi, 

I had the same problem and solved it disabling eth0 in networkmanager.

Edit /etc/NetworkManager/NetworkManager.conf and add eth0 mac address (see it with ifconfig) to unmanaged-devices with mac option. For example:

unmanaged-devices=mac:00:11:22:33:44:55;mac:66:77:88:99

Hey,
Thank you for your great info / suggestion. I will try it at the weekend. I hope it will solve this issue Wink

(06-09-2018, 11:04 AM)djcasl Wrote: If you have WiFi or network connection this doesn't occur, however if you have your system without network this happens. I had my PC Plus with me at my brother in law. Got delays on controllers and on exiting a game. Have tested the solution from netamego. At home my WiFi fixes this issue.

Hey,
Thank you for your answer. Good to know that netamego's solution solved the issue.  Wink
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Question Delay in USB Controller being recognised after launching a game. seantattoo666 11 1,300 05-06-2018, 12:16 PM
Last Post: alexkidd
  delay for load overlays webfly 4 660 01-22-2018, 02:00 AM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)