Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ZX-Spectrum (lr-fuse) keyboard access
To get ZX-Spectrum emulation working, there are some weird steps.

Keyboard is not accessible, and it is not possible to configure input in e.g. game menu

To make it accessible, you need to get to emulator configuration via select+x, then

Select "none" as input device for player 1
Select "none" as input device for player 2
Select "sinclair keyboard" as input device for player 3

Actually step are described there:

My question -- how I can set this as default settings ? Even I restart the game, it still uses those "factory presets"... It will be very handy have only keyboard configured, since a LOT of games have menu selection. Also saving this "per game" is not a good option, since there are thousands of titles....

I'll take a look i'm not too familiar with Spectrum configuration ,but did you try the option Save Core Overrides? It should work for all games, at least it does work for other platforms i've tested.
About the keyboard, did you try to map it from ES menu? Usually when you do, it works automatically in Retroarch/Libretro cores
Will try to override core.
Thanks for the hint.
Just remapped as described in manual and did "Save Core override". Works like charm!

Also, may be useful. Working scanlines (for Orange) are here:

I'm running "Renegade" like on good old glass TV Smile

Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't access machine menu LR-Vice djcasl 9 352 05-05-2018, 08:41 AM
Last Post: djcasl
  OpeneLec sh: can't access tty; job control turned off alveniz 17 2,752 02-06-2018, 10:50 PM
Last Post: alexkidd
  kodi keyboard non us keiser1080 0 202 01-01-2018, 10:44 PM
Last Post: keiser1080
  lr-fuse (zx-spectrum) not responds to hotkey znoxx 2 435 12-14-2017, 11:06 AM
Last Post: alexkidd

Forum Jump:

Users browsing this thread: 1 Guest(s)