Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RetrOrangePi 4.1 - Orange Pi Zero GPIO - Getting GPIO to work
#1
Hi everyone,
I am trying get the GPIO controls to work. I activated GPIO controls in RetroOrangePi menu and tried both the NES and TZ options. Nothing happens when I gorund the respective control pins. I tried rebooting, reactivating the option etc. Is there anything wrong I am doing?

Edit: When I reinstall TZ_GAMES_SP it says "ADD the line uinput in the /etc/modules". What exactly should I add to /etc/modules?
Reply
#2
actually anything, it works, BUT only 40-pin GPIO afaik. It's likely to work on the OPi zero as soon as we tweak the python script (hopefully)
Reply
#3
Can you give me some guidance so that I can tweak the code myself?
Reply
#4
edit ~/RetrOrangePi/GPIO/drivers/tz_gpio_controller.py and change pin bind (PA1, PD14 etc)
Reply
#5
(05-15-2018, 10:58 AM)alexkidd Wrote: edit ~/RetrOrangePi/GPIO/drivers/tz_gpio_controller.py and change pin bind (PA1, PD14 etc)

The button assignments are already correct in that file. I tried grounding PA6 and PA1 (up and down) and nothing happened.
Reply
#6
what does "sudo service tz_gpio status" say?

how exactly are you "grounding" the buttons?
Reply
#7
The following is the output of "sudo service tz_gpio status":
Quote:pi@RetrOrangePi:~$ sudo service tz_gpio status
● tz_gpio.service - RETRORANGEPI CONTROLLER
   Loaded: loaded (/lib/systemd/system/tz_gpio.service; enabled)
   Active: active (running) since Tue 2018-05-15 11:51:36 BST; 1h 25min ago
 Main PID: 745 (python)
   CGroup: /system.slice/tz_gpio.service
           └─745 /usr/bin/python /home/pi/RetrOrangePi/GPIO/drivers/tz_gpio_controller.py > /home/pi/RetrOrangePi/GPIO/drivers/tz_gpio_controller.log

May 15 11:51:36 RetrOrangePi systemd[1]: Starting RETRORANGEPI CONTROLLER...
May 15 11:51:36 RetrOrangePi systemd[1]: Started RETRORANGEPI CONTROLLER.

I am manually connecting (touching) the respective pin to ground using a wire.
Reply
#8
this is how i connect, one wire goes from COM to GPIO assigned pin , ground chain wire goes from NO to GND GPIO pin

   

   

NOTE: never tested in OrangePi Zero btw
Reply
#9
What difference does it make as long as both pins are connected through a conductor? BTW, connecting using a piece of wire works perfectly on a Raspberry Pi Zero. Is there anything else I need to do? Have I missed a step? Please help.
Reply
#10
We still have to test the Orange pi Zero to be able to help.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  PVR IPTV simple for RetrOrangePi v4 ? prixes 2 115 09-16-2018, 06:26 AM
Last Post: prixes
Bug Retrorangepi BPI m2 plus Wifi connect and don't show ip jimlee32 3 213 08-03-2018, 11:12 PM
Last Post: alexkidd
Question How to install RetrOrangePi onto pre-installed Armbian fureweb 11 1,380 07-21-2018, 02:43 PM
Last Post: alexkidd
Big Grin Picked Up my Orange pi plus 2 after a while Brottus 1 204 07-02-2018, 08:22 PM
Last Post: alexkidd
  how to fix screen black bar at bottom AV orange pi zero jamespoo 4 669 05-28-2018, 12:15 PM
Last Post: jamespoo
  GPIO (one more time) znoxx 1 409 05-13-2018, 11:39 AM
Last Post: alexkidd
  USB Sound Card support in RetrOrangePi v4? djcasl 5 798 05-11-2018, 03:55 PM
Last Post: DeJaVu
  Orange pi lite retrorangepi 4.1 won't boot Merlin3D 5 2,139 05-06-2018, 10:55 PM
Last Post: Padova
  RetrOrangepi Zero 4.1 fredjedimaster 2 695 04-15-2018, 04:38 PM
Last Post: fredjedimaster
  Fba dont work CPS2 Games. Help batistars30 3 726 04-03-2018, 08:46 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)