Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to install RetrOrangePi onto pre-installed Armbian
#11
(07-09-2018, 09:20 PM)alexkidd Wrote: yes, libsdl2-dev requires libgl1-mesa-dev that depends on libgl1-mesa-glx (which contains libGL.so) . VMware = Mesa, ARM = Mali

It seems mesa-egl got "reinstalled" right nearby the still present "mali-egl".

I could instruct gl4es to use the latter - See here:
https://github.com/ptitSeb/gl4es/issues/65

I guess it is also safe (or maybe advised?) to remove mesa-egl by mv-ing it out somewhere else, but I did not do it yet. I guess it can only add performance because then things are not finding the bad one accidentally.

Aside this, the install script mostly seem to have did its job, but I will do further testing...
Reply
#12
Glad it works. IIRC we moved Mesa libGL to ~/temp to avoid conflicts, also pointing emulator binaries to /usr/lib/GLSHIM so it can be used
Reply
#13
Yesterday I had a better luck with GL4ES: i was able to run both Emulationstation and Retroarch (copied manually from an old ROPi installation to /opt).

To make it work i reconfigured manually $HOME/.config/retroarch/retroarch.cfg and $HOME/.emulationstation/es_systems.cfg to launch RA directly.

side question: can you upload an updated build of Retroarch i can try?
Reply
#14
you're probably not really using GL4ES, because retroarch uses framebuffer libs from /usr/local/lib (fbdev libMali and SDL2)
Reply
#15
i didn't copy anything in /usr/local/lib, i am using the stock armbian libraries (except GL4ES that i compiled myself).

The only setup that worked for me fullspeed is:
RetroArch video_driver = "sdl2"
+
export LD_LIBRARY_PATH=/usr/local/lib/arm-linux-gnueabihf/gl4es

EmulationStation is working perfectly, while retroarch is not showing OSDs and is not rendering the overlays.
Reply
#16
ah ok ,i'll check this
Reply
#17
(11-21-2018, 11:41 AM)alexkidd Wrote: ah ok ,i'll check this

I suspect the rendering issues in RA are due to GL4ES.

Now i am trying to recompile the latest RA to be sure.

EDIT: just finished recompiling the latest RA v1.3.6 and the issues persist, so i've opened an issue here.
Reply
#18
Still no script to manually install retrorangepi on the orange cards?
I just installed a brand new distribution on my card in memory emm.
Everything is working very well. I installed an Armbian_5.90_Orangepipcplus_Ubuntu_bionic_next_4.19.57.

Otherwise how to do it.
The Retropie installation does not work and retrorange does not have an install script.
Any ideas ?

Thank you

-----------------

Toujours pas de script pour installer manuellement retrorangepi sur les cartes oranges ?
Je vient d'installer une distribution toutes neuves sur ma carte en mémoire emm.
Tout marche très bien. J'ai installé une Armbian_5.90_Orangepipcplus_Ubuntu_bionic_next_4.19.57.

Sinon comment faire.
L'installation de Retropie ne marche pas et retrorangepie n'a pas de script d'install.
Quelqu'un à une idée ?

Merci
Reply
#19
We're working on the upcoming release based on mainline kernel and Armbian
documentation will come at a later moment, but sources and branches are being updated on https://github.com/retr0rangepi/
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  OPI PC install ps3 pad via bluetooth davide84e31 2 17 Yesterday, 02:49 PM
Last Post: davide84e31
  USB Sound Card support in RetrOrangePi v4? djcasl 7 3,619 06-17-2019, 04:55 PM
Last Post: alexkidd
  Orange pi lite retrorangepi 4.1 won't boot Merlin3D 6 5,294 11-11-2018, 08:23 PM
Last Post: Doogie10
  PVR IPTV simple for RetrOrangePi v4 ? prixes 2 1,409 09-16-2018, 06:26 AM
Last Post: prixes
Bug Retrorangepi BPI m2 plus Wifi connect and don't show ip jimlee32 3 1,836 08-03-2018, 11:12 PM
Last Post: alexkidd
  How do you setup etcher on armbian? Merlin3D 7 3,079 06-27-2018, 09:12 AM
Last Post: alexkidd
  is it OK to update Armbian? sprectre 4 2,764 06-15-2018, 06:54 PM
Last Post: alexkidd
  RetrOrangePi 4.1 - Orange Pi Zero GPIO - Getting GPIO to work bharathram21391 15 7,630 05-15-2018, 04:58 PM
Last Post: alexkidd
  RetrOrangepi Zero 4.1 fredjedimaster 2 2,469 04-15-2018, 04:38 PM
Last Post: fredjedimaster
  problem to install on orangepiplus2e emmc co4x 12 6,548 03-16-2018, 02:00 AM
Last Post: FilipeCastro

Forum Jump:


Users browsing this thread: 1 Guest(s)