Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Desktop won't open after running Universal XML Scraper
#1
With Selph's Scraper and Skyscraper not yielding anything for PSX, I was pleasantly surprised with the Universal XML scraper. It's also nice commanding it from my PC as a linux newb.

In the config I directed it towards \ipaddress\roms\psx as a rom source, and /home/pi/RetroPie/roms/psx/ for the gamelist.xml and "media" folder dumps. It ran fully and got the job done for psx - gorgeous.

When I did a similar setup dreamcast, something broke. Dreamcast now has metadata, but when I press start to go to the desktop, it gets hung up, goes to a black screen for a while, then returns me to Emulationstation. It'd be nice to have a terminal error or something to help me track down the issue. (Is there a master log I can share and reference for issues? Sorry, please dumb it down and let me know where it is.)

I re-flashed the SD last night with Retrorangepi 4.1, thinking I might have corrupted something from my earlier endeavors. Got everything up and running today with the desktop operating as it should. I tried UXS again (ignoring the voice in the back of my head, 'back up your image before you do this!'). Same result - I'm fairly certain UXS is touching stuff other than the paths I used in 'config.'

I can still get the desktop when I VNC to the pi, but UXS must have altered something when I try to get to it from emulationstation.
Any ideas? Is there a terminal command I can enter to see if the desktop will boot with a little nudge?
If you need more information I'll do my best to provide it.

Best regards
Reply
#2
Desktop is a single command line "startx" you can try from regular terminal, post the output so we can try to troubleshoot, or file an issue at GitHub with the steps to reproduce it
Reply
#3
After quitting Emulationstation with f4 to get to the terminal and entering the command "startx," terminal returns:
"Xauth: timeout in locking authority file /home/pi/.Xauthority"

If I wait a little while, I'm presented with a black screen and nothing happens. I think it's the same screen I get when I try to get to it from the start button, but emulationstation's killed so it can't go back to it.

HOWEVER, if I ctrl+c to cancel before it goes to the black screen, I arrive at the desktop I've missed so dearly. Can't reboot emulationstation with the shortcut though. Hmmm.

When I click the emulationstation shortcut on the desktop after the ctrl+c thing, I'm sent back to the terminal where it says the following:

"xinit: unexpected signal 15"
""Xauth: timeout in locking authority file /home/pi/.Xauthority"
@RetrorangePi~$
Reply
#4
Here's a full screen of everything from start to finish: https://imgur.com/nKAPZVW
Reply
#5
Looks like the X server is crashing when you use VNC (from a quick googling), try to regain xauthority ownership: 'sudo chown -R pi:pi .Xauthority' then reconfiguring Xserver: 'sudo dpkg-reconfigure xserver-xorg'
Reboot
Reply
#6
That resolved it, thank you so much! Seriously man, you're the lifeblood of this forum; I really appreciate you taking the time to investigate almost everything posted here.
Is ownership like permissions? I'm assuming UXS changed credentials in order to scrape remotely - or something like that.
Anything I should know going forward?
Reply
#7
Yes, it's something with permissions. Xauthority is owned by default user "pi" (with limited privileges). I cannot remember how UXS work, it's been a while since i tested it, if the VNC process is started from UXS, you'll probably need to recheck your VNC configs as it's connecting as root or with root privileges.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  4.2 full issue No Sound through desktop Merlin3D 2 104 09-11-2018, 02:59 AM
Last Post: Merlin3D
  SNES Lag / Stutter until I open RetroArch? infex 1 333 05-10-2018, 04:41 PM
Last Post: alexkidd
  OPI PC problem sound desktop MegaLoLdean 0 343 01-09-2018, 05:09 PM
Last Post: MegaLoLdean
Photo After try scraper it crash ropi4. 1 caioandrade 0 442 12-14-2017, 05:33 PM
Last Post: caioandrade
  Desktop browser ropi 4 kill_us_Now 1 787 11-27-2017, 03:26 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)