Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HDMI Display detecetion Full HD TV vs. old Samsung HDMI to DVI 1680*1050
#1
Hi guys,

i'm running RetrOrangePi on an Orange Pi 2 (with HDMI), which works out of the box with my TV. But if I try to run the Oange Pi 2 with 4.2 Slim on my old Samsung display (HDMI to DVI) I wont get a picture after the loading screen that says: starting the kernel, the TV usally would switch to HD ready after this screen booting RetrOrangePi. With my Samsung display I am left with a blackscreen, he wont detect any digtal input.

Do you have any idea were I could change some settings to get any picture? I'm also runniny RetroPi with my raspberry pi B (1), there the Samsung screen will be detected after the booting screen.

Thanks for your effort  Smile  and

best regards

Carry
Reply
#2
Image is set to pure HDMI by default and it will not change on the fly.
Try this: boot the image in HDMI, run "sudo h3disp" from command line and identify the correct parameter, then re-run h3disp with the added flags plus "-d" , for DVI
something like: "sudo h3disp -m 10 -d" , for 1920x1080 DVI, for example. Then it should boot in your old TV. Keep in mind, 1680x1050 might not be compliant, need confirmation
Reply
#3
(08-10-2018, 12:04 AM)alexkidd Wrote: Image is set to pure HDMI by default and it will not change on the fly.
Try this: boot the image in HDMI, run "sudo h3disp" from command line and identify the correct parameter, then re-run h3disp with the added flags plus "-d" , for DVI
something like: "sudo h3disp -m 10 -d" , for 1920x1080 DVI, for example. Then it should boot in your old TV. Keep in mind, 1680x1050 might not be compliant, need confirmation

Can I use this to make this work on a 4:3 screen with 1024 X 768 resolution?

I tried help from:
ropi videooption and ropi config but I can't get video on 15 inch dell screen.
Reply
#4
those instructions are for the raspberry pi , not OrangePi

to enable 1024x768 , try "sudo h3disp -m 32" or "sudo h3disp -m 32 -d"
Reply
#5
/usr/bin/h3disp: missing video mode. Try one of the following:

   480i        use "-m 480i" or "-m 0"
   576i        use "-m 576i" or "-m 1"
   480p        use "-m 480p" or "-m 2"
   576p        use "-m 576p" or "-m 3"
   720p50      use "-m 720p50" or "-m 4"
   720p60      use "-m 720p60" or "-m 5"
   1080i50     use "-m 1080i50" or "-m 6"
   1080i60     use "-m 1080i60" or "-m 7"
   1080p24     use "-m 1080p24" or "-m 8"
   1080p50     use "-m 1080p50" or "-m 9"
   1080p60     use "-m 1080p60" or "-m 10"
   1080p25     use "-m 1080p25" or "-m 11"
   1080p30     use "-m 1080p30" or "-m 12"
   1080p24_3d  use "-m 1080p24_3d" or "-m 13"
   720p50_3d   use "-m 720p50_3d" or "-m 14"
   720p60_3d   use "-m 720p60_3d" or "-m 15"
   1080p24_3d  use "-m 1080p24_3d" or "-m 23"
   720p50_3d   use "-m 720p50_3d" or "-m 24"
   720p60_3d   use "-m 720p60_3d" or "-m 25"
   1080p25     use "-m 1080p25" or "-m 26"
   1080p30     use "-m 1080p30" or "-m 27"
   4kp30       use "-m 4kp30" or "-m 28"
   4kp25       use "-m 4kp25" or "-m 29"
   800x480     use "-m 800x480" or "-m 31"
   1024x768    use "-m 1024x768" or "-m 32"
   1280x1024   use "-m 1280x1024" or "-m 33"
   1360x768    use "-m 1360x768" or "-m 34"
   1440x900    use "-m 1440x900" or "-m 35"
   1680x1050   use "-m 1680x1050" or "-m 36"
   2048x1536   use "-m 2048x1536" or "-m 37"

I did sudo h3disp -m 32 -d, got picture on my Dell. Yay

I you messup your resolution and got no more picture, just use putty or other ssh client to connect and run program again. Worked for me.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Opi-zero h2 Ropi 4.2 full kodi don't start jimlee32 13 260 10-06-2018, 09:34 PM
Last Post: alexkidd
  Huge text font or wrong resolution on RetrOrangePi v4.2 FULL dee098 7 277 10-06-2018, 06:06 PM
Last Post: jimlee32
Bug Opi-zero h2 Ropi 4.2 full joystick don't work jimlee32 1 89 10-04-2018, 05:30 AM
Last Post: dee098
Bug Wifi dongle don't work Ropi4.2 full jimlee32 4 271 09-19-2018, 01:08 AM
Last Post: batistars30
  boost hdmi sound , distortion bodtx 4 156 09-12-2018, 07:06 PM
Last Post: bodtx
Bug Ropi 4.2 full - OrangePi PC Reicast joypad config don't Start. jimlee32 3 198 09-12-2018, 10:35 AM
Last Post: alexkidd
  Ropi 4.2 full - Nintendo64 - Parallel N64 – Don't Save Quick menu jimlee32 0 99 09-11-2018, 02:44 AM
Last Post: jimlee32
  ROPI 4.2 FULL Desktop start failed dee098 5 245 09-10-2018, 04:46 PM
Last Post: alexkidd
  Dead USB Ports. Retrorangepi 4.2 Full Version Robocop 5 306 09-05-2018, 02:07 PM
Last Post: alexkidd
Bug OrangePi PC - No sound in Emulator - Ropi 4.2 Full caioandrade 2 225 09-03-2018, 11:06 PM
Last Post: caioandrade

Forum Jump:


Users browsing this thread: 1 Guest(s)