Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Retrostone boots randomly and works unstable
#1
Hi Everyone!

I'm not sure whether this is a software problem, since some other people using the same software don't report it, maybe it's not.

For me the device completes booting only about 1 time out of 5-8, and other than that every time it stops at different random point: sometimes it freezes on the Slim logo, sometimes just black screen, once it was endlessly outputting some console text (longer than 30 minutes), but the screen resolution is too low to recognize what exactly was written, I just noticed that it repeats the same blocks of text all the time.

Those few times when it managed to complete booting, I was able only to browse the menus, but when I only started to play some game, it randomly crashed out of it after few, maximum 30 seconds.

I tried all the suggestions from this forum and Retrostone tutorials including proper formatting and re-flashing SD card (even though I'm quite confident in what I'm doing even without those), and even tried a different SD card which worked perfectly in my Raspberry Pi.

Any ideas are appreciated.
#2
As suggested here Allwinner boards (most Orange PIs, Retrostone included) are very sensitive to SD card quality. Believe me, the SD is the culprit most of the times. I've been lucky with Sandisk. 

Here my steps:
1. Use AOMEI to delete partition and recreate a new FAT32 one
2. Flash the latest image (replaced 16/08) if it's not the one you have
3. Use Win32DiskImager to flash the image 
4. Make sure the device is fully charged (leave it a few more hours just to make sure)
5. Turn on the board and wait a couple of minutes so it completes installation and reboot. 
6. NEVER turn off the device before shutting down properly from Quit menu. Otherwise it will cause filesystem corruption and no boot afterwards.

I believe those steps improve stability. Anyway, we're catching user experience and feedback to fix whatever bugs exist.
#3
alexkidd, thanks for you advice, I have tried to do everything exactly like you suggest, even used Sandisk SD card.

And at some point it has managed to perform the first boot successfully.
But I believe this was more a lucky coincidence rather than a result of my actions - it just happened that this first boot turned out to be that 1 of 5-8 successful boots.
Of course it's the most important one, because the OS is installed, and after that happened everything was working quite stable, I was able to setup the WiFi, copy ROMs, play them, etc.

But unfortunately after rebooting the device it failed to boot again, and currently it keeps booting only 1 time out of 5-8, same as before, the difference is only that now if it manages to boot, then the session is more or less stable (but again not 100%, few times it has frozen in the Emulation Station menu).

And I assume every time it fails to boot, it increases the risk of data corruptions since the system will not be shut down properly.
#4
The boot problem is definitely there, maybe due to the custom board. Pierre told me the Retrostone has the same schematic as Orange PIs, so i'm guessing it's something else. I recall that some H3 or H2+ devices, like the Sunvell R69, need a power cycle (like re-plugging power supply) to reboot fine. Also being investigated, if there are usb devices connected, as they draw power from battery...

Anyway, i dont have a boot failure so frequent like yours, and when it happens, i get to boot it fine after the second or third attempt of turning off/on. SDcard corruption or overheating would explain EmulationStation freezes. I really dont think it's the temperature, unless there is something too intensive being run. I would need more info on your common usage and pattern when this happens to research a solution.
#5
(08-22-2018, 12:15 PM)alexkidd Wrote: I would need more info on your common usage and pattern when this happens to research a solution.
It's happened right now - the device was just laying on my table with SNES games list open, no game was launched, and at some point I took it and it was already not responding to any button.
BTW this didn't prevent screensaver to turn off display few minutes after that (I have "Black" screensaver mode in settings). Which means, I guess, that it's not completely frozen, but just stops reacting on input events, or so.
Nothing was connected to the device.
#6
Retrostone input is driven by a python script. If it stops working out of the blue, it's probably the SD card. If you can test another brand / model, it may help to reduce the odds. There are many fake sdcards out there!
#7
Update:

As suggested by Pierre, I tried to use OrangepiPC+ version.

After turning the device on with HDMI connected it first showed some console output with the Armbian boot sequence, and after the line "Starting kernel..." the screen went black and my monitor showed "No signal".
I tried that 7 or 8 times - every time the same.

Does this mean anything?
#8
That sometimes happens when the device has no native support to 1280x720 or when a adapter to DVI is used. Try a regular TV If you're using a PC monitor with direct hdmi connection. Freezing on kernel start may indicate some pattern , what is good for troubleshooting.
Try the regular retrostone image and switch to HDMI to check if boot failure rate is the same.
#9
(08-22-2018, 03:48 PM)alexkidd Wrote: That sometimes happens when the device has no native support to 1280x720 or when a adapter to DVI is used. Try a regular TV If you're using a PC monitor with direct hdmi connection. 

Yes, you were right about that, on a TV I've seen a bit more info, see the screenshot: http://take.ms/ZTB8y

In general, I would say that the boot success rate is about 1 out of 3. 
Before I thought that it's even worse because for me it has failed to boot the first time during the system installation and probably corrupted the data, which made all the next attempts to also fail unless I've re-flashed the SD card.

And there's another problem: all the games eventually crash back to the menu or even reset the whole RetrorangePi (it looks pretty much like a kernel panic). Sometimes it happens after a while, sometimes - in the first few seconds. And it doesn't depend on particular games, happens in any.

Is there any way to debug RetrorangePi remotely from another computer?
I've managed to connect to it via ssh, but there I can only execute commands, and don't see any other  output.
#10
I'm testing the previous v4.1 now. If you could do the same, it would be good. Download the image for the orange pi pc plus and use HDMI with usb gamepad (i'll post detailed instructions to enable retrostone controller later, don't worry).


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to run Scummvm games on retrorangepi for retrostone??? ramonpks 10 97 Yesterday, 11:48 AM
Last Post: ramonpks
  Retrostone N64 secondd 0 23 10-18-2018, 05:39 AM
Last Post: secondd
  RetroStone controller takes a long time to be seen TROFF 3 45 10-18-2018, 02:39 AM
Last Post: alexkidd
  How hot is too hot for the RetroStone? TROFF 1 90 10-11-2018, 10:14 AM
Last Post: alexkidd
  Selling limited edition blue retrostone aj_efff 0 100 09-30-2018, 12:58 PM
Last Post: aj_efff
  retrorangepi for retrostone repo? retrojack 3 141 09-28-2018, 05:11 PM
Last Post: alexkidd
  Make a image retrostone with my roms bouboulover 1 142 09-26-2018, 02:23 PM
Last Post: alexkidd
  Amiga emulation on Retrostone Marco Verhoeven 4 180 09-20-2018, 09:07 PM
Last Post: Marco Verhoeven
  Retrostone Charger Recomendations? Skully63 6 328 09-18-2018, 09:22 PM
Last Post: steebo777
  installing roms on retrostone (controls / dark theme) alexkidd 2 270 09-07-2018, 10:08 PM
Last Post: bedfellow

Forum Jump:


Users browsing this thread: 1 Guest(s)