Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
boost hdmi sound , distortion
#1
Hi I use a hdmi2vga converter (With opi PC plus), output sound is very low, when i change the volume in the options with the slider sound volume does not change .
Try to run opi command to change to switch to analog sound and then use the jack. The sound was strong and volume control ils working. But i hear some glitch.

I've run alsamixer but when i select the HDMI sound card, no control is available.


How can I boost the HDMI sound?

EDIT: ok for the glitches in analog audio, I've figured out that I was using a 3 pole cable instead of a 4 pole cable, so the glitches were coming from the video channel ^^
I'm still interested to control the volume of the HDMI audio output?
Reply
#2
Alsa cannot control HDMI sound. Pulseaudio would do the job, but it adds weight to gaming content, unusable.

you should probably use the analog port for audio - change it through our AV tool (RetroPie-RetrOrangePi-BashTool ROPI RCA and select the second option - HDMI video 720p & Analog Audio)
Reply
#3
Well back with a 4 pole jack, I still have the glitches in audio.

see this video it is linked to video move

strange thing when I test the ground there is a connection between video and ground when nothing is linked, is this normal?:


only way to minimize this is to put audio at 100% in retropi setup, but I can hear it.
any idea?
Reply
#4
Working on integrating pulseaudio without sacrificing performance, should have something in a couple of days
Reply
#5
OK i've figured out. It was a problem of background loop https://en.m.wikipedia.org/wiki/Ground_l...ectricity)
Amp and opi were on the same power source.
There are many solution but the cheaper and easiest to me was to power the amp (pam8403) with it's own 5v power supply.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  no sound in the roms kelzadtu 1 361 09-21-2018, 02:39 PM
Last Post: alexkidd
  Sound trouble Secretcookies 3 250 09-18-2018, 07:31 PM
Last Post: alexkidd
Bug PulseAudio How to repair no sound? caioandrade 1 201 09-12-2018, 01:02 AM
Last Post: alexkidd
Bug OrangePi PC - No sound in Emulator - Ropi 4.2 Full caioandrade 2 361 09-03-2018, 11:06 PM
Last Post: caioandrade
  HDMI Display detecetion Full HD TV vs. old Samsung HDMI to DVI 1680*1050 carrygoldextra 4 410 08-15-2018, 01:59 PM
Last Post: djcasl

Forum Jump:


Users browsing this thread: 1 Guest(s)