Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Retroachievments not working with WiFi but Eth
#1
Seems that inside of RetroArch the WiFi is not working correctly.

RetroAchievments are working only if I connect the network cable.

In general the wifi is working, I used the scrapper in EmulationStation with WiFi without issues.

Inside of RetroArch (Information->Network) I see lo, eth0 and wlan3. wlan3 shows the correct IP address, eth0 shows the IP address from last cable connection, also after reboot without cable.


It looks also that there is a timeout connecting to the RetroAchievments server. After starting of a rom it took some time until the notification “controller connected” appeared. With connected cable it appeared instantly.

Rebooted and testet also WiFi in EmulationStation several times, always the same. I tried the Image from 5. September and also the new “supreme image”. Any ideas?
Reply
#2
Wifi is borked in recent Armbian updated.
check output of "sudo ifconfig" for the wlan interface then "sudo nano /etc/network/interfaces" , change wlan0 for the one you found. It will probably work after a reboot.
Reply
#3
(09-28-2018, 12:51 AM)alexkidd Wrote: Wifi is borked in recent Armbian updated.
check output of "sudo ifconfig"  for the wlan interface then "sudo nano /etc/network/interfaces" , change wlan0 for the one you found. It will probably work after a reboot.

Works find now!


My /etc/network/interfaces looks now like this. I only changed the 2 places where i could find wlan0 to wlan3.


Code:
source /etc/network/interfaces.d/*

# Wired adapter #1
allow-hotplug eth0
#no-auto-down eth0
iface eth0 inet dhcp
#address 192.168.0.100
#netmask 255.255.255.0
#gateway 192.168.0.1
#dns-nameservers 8.8.8.8 8.8.4.4
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838


# Wireless adapter #1
# Armbian ships with network-manager installed by default. To save you time
# and hassles consider using 'sudo nmtui' instead of configuring Wi-Fi settings
# manually. The below lines are only meant as an example how configuration could
# be done in an anachronistic way:
#
allow-hotplug wlan3
iface wlan3 inet dhcp
#address 192.168.0.100
#netmask 255.255.255.0
#gateway 192.168.0.1
dns-nameservers 8.8.8.8 8.8.4.4
#   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
# Disable power saving on compatible chipsets (prevents SSH/connection dropouts over WiFi)
#wireless-mode Managed
#wireless-power off

# Local loopback
auto lo
iface lo inet loopback
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  WiFi Dongle KimDEa 28 8,730 11-08-2019, 12:03 PM
Last Post: Catbiscuits
  Dreamcast Not Working TurtleFlyte 4 807 05-16-2019, 12:14 AM
Last Post: alexkidd
  USB Wifi + Screen protector question ahnfire 3 1,872 11-15-2018, 06:48 PM
Last Post: qu1que
  Cheats Retroarch not working secondd 2 1,593 10-29-2018, 06:24 AM
Last Post: secondd
  wifi bouboulover 0 652 10-09-2018, 11:04 AM
Last Post: bouboulover
  Wifi Error: either "dev" is a duplicate or "wlan3" is a garbage Bart0 2 1,409 09-09-2018, 11:53 AM
Last Post: Bart0

Forum Jump:


Users browsing this thread: 1 Guest(s)