Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] USB causes issue at boot
Hi all,

I've revived my OPI One with the V4.2 Full on a 8GB microSD class10, and I'm quite happy with it. 
However, I found an issue with my USB drives: I can connect and mount them but if I reboot the OPI with an USB drive inserted it will remap the drive as home folder (not /media/USB) then many thing are obviously missing. To solve I need to pull out my drive and reboot again.
Tested 3 USB units, one 2GB and two 4GB from different brands all formatted as FAT32 and completely empty.
Is there something to configure to solve this issue?  


edit /etc/rc.local and remove the mount sda1 command
(12-13-2018, 06:57 PM)alexkidd Wrote: edit /etc/rc.local and remove the mount sda1 command

Thanks, will test today night.
(12-13-2018, 06:57 PM)alexkidd Wrote: edit /etc/rc.local and remove the mount sda1 command

Solved changing mount point, since I need he USB always available:

if [ -b "/dev/sda1" ]; then
sudo mount /dev/sda1 /media/data -o rw,user,exec,umask=0000,uid=pi,gid=pi

Possibly Related Threads...
Thread Author Replies Views Last Post
  Issue with the NEOGEO X joystick saitoh00 4 977 09-23-2019, 12:52 AM
Last Post: saitoh00
  Fix loading in boot rtokuda 7 3,849 03-29-2019, 12:03 PM
Last Post: alexkidd
  [Solved] Broken system start (boot) laguna 12 6,300 01-28-2019, 10:45 AM
Last Post: alexkidd
  No background music on boot. patchmagic 0 882 12-07-2018, 11:46 AM
Last Post: patchmagic
  [solved] Opi PC load ES but freezze RinDim 2 1,328 11-11-2018, 06:19 AM
Last Post: RinDim
  [solved] Doubt with PSP emulator of libretro laguna 3 2,203 11-10-2018, 06:18 PM
Last Post: retux
Exclamation [solved]Problem with the video in gamelist view style retux 4 2,499 10-28-2018, 02:00 PM
Last Post: retux
  [solved] FFMPEG drivers for recording gameplays on retroarch laguna 6 3,329 10-11-2018, 04:01 PM
Last Post: laguna
  [solved] Compile a core of libretro to a specific commit version laguna 6 3,383 10-03-2018, 08:23 PM
Last Post: laguna
Sad [solved] ES Scraper function does not work laguna 3 2,045 09-28-2018, 07:16 AM
Last Post: laguna

Forum Jump:

Users browsing this thread: 1 Guest(s)