Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mupen64plus-libretro-nx
#1
Hello Guys,

There is a new emulator for n64 in retroarch

I write here i think its a good idea to add in retrorangepi

Link:
https://github.com/libretro/mupen64plus-libretro-nx

i check the installation @ weekend
Reply
#2
i have compiled from SSH on new kernel, will test later:

pi@RetrOrangePi:~/mupen64plus-libretro-nx$ /opt/retropie/emulators/retroarch/bin/retroarch -v --config /opt/retropie/configs/all/retroarch.cfg -L mupen64plus_next_libretro.so ~/NTFS/roms/n64/Mario\ Kart\ 64\ \(U\)\ \[\!\].z64
[INFO] RetroArch 1.7.6 (Git 55b449d743)
[INFO] Redirecting save file to "/home/pi/NTFS/roms/n64/Mario Kart 64 (U) [!].srm".
[INFO] Redirecting savestate to "/home/pi/NTFS/roms/n64/Mario Kart 64 (U) [!].state".
[INFO] === Build =======================================
Capabilities: NEON VFPv3 VFPv4
Built: Feb 11 2019
[INFO] Version: 1.7.6
[INFO] Git: 55b449d743
[INFO] =================================================
[INFO] Loading dynamic libretro core from: "/home/pi/mupen64plus-libretro-nx/mupen64plus_next_libretro.so"
INFO] Environ SET_HW_RENDER.
[INFO] Requesting OpenGLES2 context.
[libretro INFO] mupen64plus: Using full mem base
[INFO] Environ SYSTEM_DIRECTORY: "/home/pi/RetroPie/BIOS".
[libretro INFO] mupen64plus: Goodname: Mario Kart 64 (U) [!]
[libretro INFO] mupen64plus: Name: MARIOKART64
[libretro INFO] mupen64plus: MD5: 3A67D9986F54EB282924FCA4CD5F6DFF
[libretro INFO] mupen64plus: CRC: 3E5055B6 2E92DA52
[libretro INFO] mupen64plus: Imagetype: .z64 (native)
[libretro INFO] mupen64plus: Rom size: 12582912 bytes (or 12 Mb or 96 Megabits)
[libretro INFO] mupen64plus: ClockRate = F
[libretro INFO] mupen64plus: Version: 1446
[libretro INFO] mupen64plus: Manufacturer: Nintendo
[libretro INFO] mupen64plus: Cartridge_ID: 544B
[libretro INFO] mupen64plus: Country: USA
[libretro INFO] mupen64plus: PC = 80000400
[libretro INFO] mupen64plus: Save type: 0
[INFO] Skipping SRAM load..
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 44100.00 Hz.
[INFO] [Video]: Video @ 960x720
[INFO] [Video]: Using HW render, OpenGL driver forced.
[INFO] [GL]: Found GL context: kms
[INFO] [GL]: Detecting screen resolution 1920x1080.
[INFO] [EGL] Found EGL_EXT_platform_base, trying eglGetPlatformDisplayEXT
[INFO] [EGL]: EGL version: 1.4
[INFO] [EGL]: Current context: 0x40000001.
[INFO] [KMS]: New FB: 1920x1080 (stride: 7680).
[INFO] [GL]: Vendor: ARM, Renderer: Mali-400 MP.
[INFO] [GL]: Version: OpenGL ES 2.0.
[INFO] [GL]: Using resolution 1920x1080
[libretro INFO] mupen64plus: Initializing 4 RDRAM modules for a total of 8 MB
[libretro INFO] mupen64plus: Starting R4300 emulator: Dynamic Recompiler
[libretro INFO] mupen64plus: Init new dynarec
[libretro INFO] mupen64plus: ARM CPU Features:, Half, Thumb, FastMult, VFP, ESDP, NEON, VFPv3, TLS, VFPv4, IDIV
a, IDIVt
[INFO] [KMS]: New FB: 1920x1080 (stride: 7680).
Reply
#3
looks good nice alex
Reply
#4
any news? is it working?
Reply
#5
i have test it @ weekend

have problems to compile it have errors...

what have you set to compile alex?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)