Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with 4.2
#1
Hello everyone,

last year I bought myself a Orange Pi Zero rev 1.5 because I like it's specs and want to build a retro handheldconsole out of it. For this project I bought the SBC, an arduino for the buttons and all the other things I need(like buttons, battery + charging circuit and so on). 
To get the SPI LCD working I use SPI_LCD and BB_CP by bitbank2 which can be found on github. 
The problem I get is that the 4.2 Retropi destribution won't work on my OPi. It starts up, reboots but I can't get an IP. If I use the 4.1 build though it's working.
The SDCard I use is a pretty new SanDisk Ultra 32GB.
Thanks in advance for your answers.
Reply
#2
(04-14-2019, 06:18 PM)DrReVaN Wrote: Hello everyone,

last year I bought myself a Orange Pi Zero rev 1.5 because I like it's specs and want to build a retro handheldconsole out of it. For this project I bought the SBC, an arduino for the buttons and all the other things I need(like buttons, battery + charging circuit and so on). 
To get the SPI LCD working I use SPI_LCD and BB_CP by bitbank2 which can be found on github. 
The problem I get is that the 4.2 Retropi destribution won't work on my OPi. It starts up, reboots but I can't get an IP. If I use the 4.1 build though it's working.
The SDCard I use is a pretty new SanDisk Ultra 32GB.
Thanks in advance for your answers.

Can you connect a keyboard?

Send us:

ifconfig -a

grep eth /var/log/messages
grep wlan /var/log/messages

Regards
Reply
#3
(04-15-2019, 05:08 PM)naxeras Wrote:
(04-14-2019, 06:18 PM)DrReVaN Wrote: Hello everyone,

last year I bought myself a Orange Pi Zero rev 1.5 because I like it's specs and want to build a retro handheldconsole out of it. For this project I bought the SBC, an arduino for the buttons and all the other things I need(like buttons, battery + charging circuit and so on). 
To get the SPI LCD working I use SPI_LCD and BB_CP by bitbank2 which can be found on github. 
The problem I get is that the 4.2 Retropi destribution won't work on my OPi. It starts up, reboots but I can't get an IP. If I use the 4.1 build though it's working.
The SDCard I use is a pretty new SanDisk Ultra 32GB.
Thanks in advance for your answers.

Can you connect a keyboard?

Send us:

ifconfig -a

grep eth /var/log/messages
grep wlan /var/log/messages

Regards

Thanks for the answer!
I managed to get a screen working via tv out and connected through WLAN. gonna take a look why eth won't work. everything else works now.
Reply
#4
ifconfig -a :
Code:
eth0      Link encap:Ethernet  HWaddr 72:03:c2:78:51:2a
         inet6 addr: fe80::7003:c2ff:fe78:512a/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:102 errors:0 dropped:0 overruns:0 frame:0
         TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:9758 (9.5 KiB)  TX bytes:366 (366.0 B)
         Interrupt:114

lo        Link encap:Local Loopback
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:8 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:1104 (1.0 KiB)  TX bytes:1104 (1.0 KiB)

wlan4     Link encap:Ethernet  HWaddr dc:44:6d:58:ab:93
         inet addr:192.168.0.158  Bcast:192.168.0.255  Mask:255.255.255.0
         inet6 addr: fe80::de44:6dff:fe58:ab93/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:19021 errors:0 dropped:0 overruns:0 frame:0
         TX packets:13146 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:26677391 (25.4 MiB)  TX bytes:1206527 (1.1 MiB)

 grep eth /var/log/messages : 
Code:
Apr 18 18:00:39 RetrOrangePi kernel: [   12.605619] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Apr 18 18:17:14 RetrOrangePi kernel: [   14.350491] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Apr 18 18:35:17 RetrOrangePi kernel: [   14.376863] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Apr 18 19:07:15 RetrOrangePi kernel: [   15.024939] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Apr 20 00:34:07 RetrOrangePi kernel: [   14.861510] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Apr 20 00:39:31 RetrOrangePi kernel: [   15.016400] gmac0 gmac0: eth0: eth0: PHY ID 00441400 at 0 IRQ poll (gmac0-0:00)
Reply
#5
try:

what about "sudo dhclient eth0"
Reply
#6
(04-20-2019, 01:06 PM)alexkidd Wrote: try:

what about "sudo dhclient eth0"

What should happen with that command?
Reply
#7
you should get an ip from router, if it's running a DHCP server
Reply
#8
Thanks that worked Smile
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  kodi android remote problem feel2death 0 117 05-01-2019, 03:40 PM
Last Post: feel2death
  Problem with Retrorangepi 4.2 slim plus Video Splash naxeras 5 444 04-15-2019, 07:34 PM
Last Post: naxeras
  Music Problem saroninux 2 280 04-08-2019, 05:38 PM
Last Post: saroninux
Question PROBLEM HDMI AUDIO ROPI 4.2 FULL ups94 5 1,285 12-09-2018, 07:33 AM
Last Post: dee098
  mupen64plus-glide64 rom problem naik 2 875 11-26-2018, 08:03 PM
Last Post: naik
  Problem after update??? RinDim 2 958 11-13-2018, 01:53 PM
Last Post: RinDim
Exclamation [solved]Problem with the video in gamelist view style retux 4 1,310 10-28-2018, 02:00 PM
Last Post: retux
  Problem with xbox360 wired controller r3fear 7 1,861 10-11-2018, 04:21 PM
Last Post: r3fear
  Kodi problem ekonik3 4 1,470 10-08-2018, 04:31 PM
Last Post: alexkidd
  Kodi - android control problem Teleseil 1 819 09-05-2018, 12:29 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)