Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't Install custombluez and customhidsony...
#1
Hi thanks for reading my msg, sorry if my english is not too good i'm not a english native person and iam new in this downloaded configured roms, solved some problems but now im stuck


I've downloaded Retrorange 4.2 full for an orange pi lite

Everything is fine not without its troubles i downloaded some lib to get video preview on a theme, i've sucessfullly paired oficial sony ps3 controller everything is fine but I need to pair a
gasia controller (ps3 generic clone)

I can't install custombluez or customhid sony

If i want to install custombluez gives this error:

"Could not successfully build custombluez - Updated version of BlueZ Bluetooth stack

Install alongside 'sixaxis' driver if you need to pair third-party (Gasia/Shanwan) DualShock 3 controllers.
Needed only if your distribution's BlueZ version is <5.48. (/home/pi/RetroPie-Setup/tmp/build/custombluez/bluetooth_5.50-1~rpi1_all.deb not found).

Log ended at: Sun Apr 28 13:09:56 CEST 2019
Total running time: 0 hours, 0 mins, 51 secs"

Full log is in this link: https://pastebin.com/NukV2fV1


Or customhidsony install try gives this error....

Getting sources for 'customhidsony' : Custom hid-sony driver backported from kernel 4.15
= = = = = = = = = = = = = = = = = = = = =

/opt/retropie/supplementary/customhidsony /home/pi/RetroPie-Setup/tmp/build/customhidsony /home/pi
/home/pi/RetroPie-Setup/tmp/build/customhidsony /home/pi
/home/pi

= = = = = = = = = = = = = = = = = = = = =
Building 'customhidsony' : Custom hid-sony driver backported from kernel 4.15
= = = = = = = = = = = = = = = = = = = = =


------------------------------
Deleting module version: 0.1.2
completely from the DKMS tree.
------------------------------
Done.

Creating symlink /var/lib/dkms/hid-sony/0.1.2/source ->
                 /usr/src/hid-sony-0.1.2

DKMS: add completed.
Error! Your kernel headers for kernel 3.4.113-sun8i cannot be found.
Please install the linux-headers-3.4.113-sun8i package,
or use the --kernelsourcedir option to tell DKMS where it's located
/opt/retropie/supplementary/customhidsony /home/pi

= = = = = = = = = = = = = = = = = = = = =
Configuring 'customhidsony' : Custom hid-sony driver backported from kernel 4.15
= = = = = = = = = = = = = = = = = = = = =

/home/pi

Log ended at: Sun Apr 28 13:34:03 CEST 2019
Total running time: 0 hours, 0 mins, 43 secs

Full Log of customhidsony here https://pastebin.com/6CwT8HV9

What can i do to fix this?

Thanks a lot

Aditiional info

This info gave me lsb_release -a

No LSB modules are available.
Distribuitor ID: Debian
Description: Debian GNU/Linux 8.11 (jessie)
Release: 8.11
Codename: jessie

Sorry i'm really new in this stuff, i searched for the command to get what distribution i have, i knew it was jessie but not sure that if was complete info, so i've searched for the command

See you, anything else that should i give you to help me?
0
Reply
#2
tried to upgrade to strech using this guide... https://www.datenreise.de/en/raspberry-p...o-stretch/

im stuck in this step Step 6: Update to „Stretch“

Now we are ready to start the upgrade:

$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade (this command failed with error now im on stretch but couldnt finish this command in this line) this error gave me...

"the following packages have unmet dependencies:
init-system-helpers : Breaks: sysvinit-utils ( 2.88dsf-59.3 ) but 2,88dsf-59 is to be installed
E: error, pkproblemresolver::resolve generated breaks this may be cause by held packages

if i need i could restore backup before updating to stretch, thanks again
Reply
#3
Trying to update to stretch may break dependencies, I’ll try to upload the missing kernel headers so installation works.
Reply
#4
(05-01-2019, 01:22 AM)alexkidd Wrote: Trying to update to stretch may break dependencies, I’ll try to upload the missing kernel headers so installation works.

Thanx man, hope soon could be installing custombluez, and customhidsony
Reply
#5
Same error here, in a OPi H3. I was looking for a way to manually install bluetooth_5.50-1~rpi1_all.deb, but couldn't find this package.
Reply
#6
That is a raspberry only package, you won’t be able to install it in anOrange Pi
I’m on a short trip, next week we’ll solve this thread
Reply
#7
it is really sad too think this would not be solved, and it is important to have an option to use generic ps3 controllers they are really cheap and common, hope this have a solution soon or in next revision
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Can't install Amiberry from sources giankyfava 25 822 08-16-2019, 12:22 PM
Last Post: alexkidd
  orange pi win plus how to install retro djmcg 12 2,159 08-11-2019, 04:08 PM
Last Post: alexkidd
Bug joystick and keyboard are not detected in fresh install on ROPi 4.2 efeferrari 3 670 07-03-2019, 02:33 AM
Last Post: efeferrari
  Can't install any drivers shawnsdada 5 759 03-31-2019, 03:52 PM
Last Post: alexkidd
  PSP emulator lost its key setting mapping table and re-install with getting error Himyorange 2 973 12-12-2018, 02:57 PM
Last Post: Himyorange
  error of install 4.2 full indevor 6 1,744 11-26-2018, 11:50 AM
Last Post: indevor
  Could not successfully install Daphne rtokuda 5 1,673 11-05-2018, 03:45 PM
Last Post: Roy
  Unable to install ps3 controller driver genzi0401 8 5,673 08-23-2018, 06:59 PM
Last Post: genzi0401

Forum Jump:


Users browsing this thread: 1 Guest(s)