Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't install Amiberry from sources
#1
Hi,
I can't manage to install Amiberry. I updated retropie scripts but then, when I try to install amiberry from sources (main packages), I get several error for source not found ( 151.101.240.204 port 80) so I can't solve some dependencies.  Sad  Maybe this source is not available anymore? Is there another way to solve the problem? Thanks.
Reply
#2
this may help:
https://github.com/retr0rangepi/RetrOran...-480643850
Reply
#3
Source problem solved, thanks. But now I have a compile problem...

From compiler's log:

{standard input}: Assembler messages:
{standard input}:21887: Warning: end of file not at end of a line; newline inserted
{standard input}:22954: Error: unknown pseudo-op: `.l'
{standard input}:22923: Error: branch out of range
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
<builtin>: recipe for target 'src/cpuemu_11.o' failed
make: *** [src/cpuemu_11.o] Error 4
make: *** Waiting for unfinished jobs....
/home/pi/RetroPie-Setup
Could not successfully build amiberry - Amiga emulator with JIT support (forked from uae4arm) (/home/pi/RetroPie-Setup/tmp/build/amiberry/amiberry-orangepi-pc not found).

Do you think it's a compiler bug? May I try to update gcc? Thanks in advance.
Reply
#4
g++: internal compiler error is generally lack of RAM. Add swap memory by editing /home/pi/RetroPie-Setup/scriptmodules/emulators/amiberry.sh and adding the following line right after function build_amiberry:
rpSwap on 1536
Reply
#5
You were right! Thanks a lot.
Reply
#6
Hi again...
Amiberry now works but it can't save settings (like path cpu etc) and I can't save another emu template to start lha roms with. I also gave 777 permission octet to amiga roms folder but with no success. Is there another path where Amiberry saves config templates? Thanks again
Reply
#7
/opt/retropie/configs/amiga/amiberry
Reply
#8
(07-14-2019, 01:01 PM)alexkidd Wrote: /opt/retropie/configs/amiga/amiberry

Ok I created a new config file .uae in that path and now I see all lha roms in emulation station, but when I try to start one of them emulation stops at amiga dos shell (I tried kickstart 1.3, 3.1 and aros). Moreover all roms try to start with profile 'amiberry', not with rp-a500 or rp-a1200 and my profile (named Amiga.uae) it's not even shown.
Maybe I didn't understand how lha files work in amiberry.
Reply
#9
Amiberry inherits uae4arm configs with autodetection of model and rom type. Check lines 19 and 45 from
https://github.com/retr0rangepi/RetroPie...uae4arm.sh

To run a custom uae with LHA, you'll probably need to add a new entry to /opt/retropie/configs/amiga/emulators.cfg , mixing some of the parameters

About Amiga.uae not showing up, open /etc/emulationstation/es_systems.cfg and add .uae and .UAE if they arent in the extensions line for amiga
Reply
#10
After several trials with no success in starting lha roms I decided to remove both uae4arm and amiberry and reinstall them both using default configs. Paths seem correct to me (I setup them like in this screenshot:
https://4.bp.blogspot.com/-_YsuNNeSWrk/W...iberry.png
) and I see all lha roms in emulationstation but I don't know why won't load. I'm stuck at dos shell. Any ideas? I'm driving mad...  Cry
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Which version to install - Orange Pi Plus 2 woonaval 5 836 08-27-2019, 05:35 PM
Last Post: alexkidd
  orange pi win plus how to install retro djmcg 12 3,765 08-11-2019, 04:08 PM
Last Post: alexkidd
Bug joystick and keyboard are not detected in fresh install on ROPi 4.2 efeferrari 3 1,129 07-03-2019, 02:33 AM
Last Post: efeferrari
  Can't Install custombluez and customhidsony... verawarez 6 1,556 05-31-2019, 09:16 PM
Last Post: verawarez
  Amiberry - Black screen after logo (no logs?) luckithroe 1 581 05-27-2019, 11:45 PM
Last Post: Roy
  Amiberry controls on RetroStone help luckithroe 3 899 04-19-2019, 01:59 AM
Last Post: luckithroe
  Can't install any drivers shawnsdada 5 1,310 03-31-2019, 03:52 PM
Last Post: alexkidd
  PSP emulator lost its key setting mapping table and re-install with getting error Himyorange 2 1,300 12-12-2018, 02:57 PM
Last Post: Himyorange
  error of install 4.2 full indevor 6 2,278 11-26-2018, 11:50 AM
Last Post: indevor
  amiberry xtremox 6 2,542 11-14-2018, 06:32 AM
Last Post: Asti

Forum Jump:


Users browsing this thread: 1 Guest(s)