Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[OPi Plus 2E] Install RetrOrangePi on eMMC
#11
ZeroHager, did you fix your problem ?
Reply
#12
(10-12-2019, 02:25 PM)Remylenain Wrote: ZeroHager, did you fix your problem ?

Hi @Remylenain,

Sorry for the delay, didn't have much time this past days, thanks for the new info, I will try again this days or maybe in the weekend, I will let you know if I solve the problem.

Thanks again Wink
Reply
#13
No problem, I hope this will work Wink
Reply
#14
Hi.

My orangepi plus 2e doesn't boot too.

I've the same problem: oragepi boots without sd card but with sd inserted no.

My sd card is formated in fat32

What file must I change to boot right?

EDIT: I've tried my old rc.local file (it works ok in retrorangepi 4.2) and boot fails too:

if [ -b "/dev/sda1"]; then
sudo mount /dev/mmcblk1p1 /home/pi/RetroPie -o rw,user,exec,umask=0000,uid=pi,gid=pi
elif [ -b "/dev/mmcblk1p1"]; then
sudo mount /dev/mmcblk0p1 /home/pi/RetroPie/roms -o rw,user,exec,umask=0000,uid=pi,gid=pi
fi

EDIT 2: All It's too stranger:

I've running armdesktop from retrorangepi menu.
I've inserted sd card and it's mount to /media/pi/ORANGEPI (mi sd card is labeled as "ORANGEPI")

Then I'm modify the rc.local again (I've eliminated my old 4.2 version lines) and I've write:

sudo mount /media/pi/ORANGEPI /home/pi/RetroPie/roms -o rw,user,exec,umask=0000,uid=pi,gid=pi

and retroragepi continues without booting.

It's likes retrorangepi tries to boot directly from SD and not from EMMC and then mount the SD.


SOLVED:

The SD was used to copy retrorangepi 4.3 image. After that, I format SD to fat32 from Windows but some partition
must still in it. Format the sd card with SD Card Formatted solved the problem.

rc.local file now have this lines:

if [ -b "/dev/sda1"]; then
sudo mount /dev/mmcblk1p1 /home/pi/RetroPie
elif [ -b "/dev/mmcblk1p1"]; then
sudo mount -t vfat /dev/mmcblk0p1 /home/pi/RetroPie/roms
fi
Reply
#15
Hi again,

zarkon, thanks for the new info, I will try it in this days because still not working for me, hope this fix it one and for all.
Reply
#16
Hi @Remylenain,

Finally did it,

Formated the SD to fat32.

This command didn't work at all

cp -R /home/pi/RetroPie/* /dev/mmcblk0p1/

so I used this

cp -R /home/pi/RetroPie/* /media/pi/SD_card_name

Modified rc.local with this before exit 0

sudo mount -t vfat /dev/mmcblk0p1 /home/pi/RetroPie

Thanks.
Reply
#17
Dont know if this helps on your system but on my OrangePi PC Plus... 
Burn image to your SD card

Backup contents of sd card, file structure etc. then clear the /home/pi/RetroPie/ folder so its empty
Everything you want and then install to EMMC
after that is done and Pi is powered off, format your card in its normal file format.. probably going to be ExFAT

then in the autostart.sh file in the /opt/retropie/configs/all/autostart.sh ( I think its there ) just add the following
sudo mount /dev/mmcblk0p1 /home/pi/RetroPie

on your pc make sure your formatted sd card has the right folders and roms etc..
This will work and you will have your sd card working fine. Make sure you have the relevant folders needed for it, like roms etc...
In RETROARCH, change the config save locatoins to the home/Pi/ folder, then everything is now saved onto the Pi and it now ONLY uses the SD card for reading media.
Hope this helps.. of i might have just caused a lot more issues for people Smile
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  OrangePi PC Plus - Setup Install on EMMC roms on SD yolkfolk 3 224 04-05-2020, 02:09 PM
Last Post: yolkfolk
  how to get linux 5.2.14 kernel source about RetrOrangePi 4.3 FULL lyric1984 8 1,357 02-28-2020, 08:43 AM
Last Post: Hotab777
  Need help installing Retrorangepi 4.3 into microSD (Orange Pi PC) ministryofnoobs 4 992 12-29-2019, 04:51 PM
Last Post: alexkidd
  RetrOrangePI Segfault after system update ebonflame 2 726 11-21-2019, 06:30 AM
Last Post: ebonflame
  RetrOrangePi on NanoPi Duo2 - CVBS enable RossiRPI 3 975 11-13-2019, 05:46 PM
Last Post: alexkidd
  RetroRangePi doesn't save configuration zarkon 0 469 10-23-2019, 05:24 PM
Last Post: zarkon

Forum Jump:


Users browsing this thread: 1 Guest(s)