Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
4.3 Full for Orange Pi One
#11
(10-04-2019, 01:04 PM)alexkidd Wrote: if sound isnt working, try to edit /etc/asound.conf with sudo nano and change card to 0 and hw:1,0 to hw:0,0

sound works now .. 

samba dont work
joypad dont work in kodi
OTG usb dead ?!?
Reply
#12
@lastclass which is your board?

Samba is working fine on images uploaded a couple of days ago
Joypad still not supported in kodi
USB OTG needs extra settings . Looks like serial is default instead in Armbian boot, I still have to figure out which file to tweak.
Reply
#13
(10-05-2019, 09:37 PM)alexkidd Wrote: @lastclass which is your board?

Samba is working fine on images uploaded a couple of days ago
Joypad still not supported in kodi
USB OTG needs extra settings . Looks like serial is default instead in Armbian boot, I still have to figure out which file to tweak.

i have orange one and orange pc 2
downloaded 5/10-2019

and power button only works for shutdown .. cant change power button
Reply
#14
(10-06-2019, 08:31 AM)lastclass Wrote:
(10-05-2019, 09:37 PM)alexkidd Wrote: @lastclass which is your board?

Samba is working fine on images uploaded a couple of days ago
Joypad still not supported in kodi
USB OTG needs extra settings . Looks like serial is default instead in Armbian boot, I still have to figure out which file to tweak.

i have orange one and orange pc 2
downloaded 5/10-2019

and power button only works for shutdown .. cant change power button

got samba to work ... 

power button selector dont work .. only with power down
Reply
#15
yes, confirmed,
looks like there were changes in mainline kernel and acpi support
Reply
#16
I found another bug... sometimes emulation station stop working randomly exiting to shell (segmentation fault). And it seems to me slower than 4.2 is it possible?
I'll try to modify asound.conf asap.

(09-28-2019, 07:41 PM)alexkidd Wrote: Please report if One image works as I have noticed issues with 512MB ram board images

It works but I had to activate swap (especially for scraping) and, as you already know, sound doesn't work and samba must be installed to get it work. Any possibility to get otg works again ?(it's quite important to me)

(10-05-2019, 09:37 PM)alexkidd Wrote: @lastclass which is your board?

Samba is working fine on images uploaded a couple of days ago
Joypad still not supported in kodi
USB OTG needs extra settings . Looks like serial is default instead in Armbian boot, I still have to figure out which file to tweak.

Maybe this can help?

https://forum.armbian.com/topic/10822-or...t-working/

or maybe this?

http://www.orangepi.org/orangepibbsen/fo...d&tid=3399
Reply
#17
(10-05-2019, 08:27 PM)lastclass Wrote:
(10-04-2019, 01:04 PM)alexkidd Wrote: if sound isnt working, try to edit /etc/asound.conf with sudo nano and change card to 0 and hw:1,0 to hw:0,0

sound works now .. 

samba dont work
joypad dont work in kodi
OTG usb dead ?!?

Ok, sound problem solved for me too. Thanks.
Reply
#18
Ok, I solved OTG problem (turning it into a regular usb)... this is what I did:

in /boot/dtb

I changed this into the file sun8i-h3-orangepi-one.dtb:

dr_mode = "peripheral";

to

dr_mode = "host";

And it works!

Here the entire procedure:

https://forum.armbian.com/topic/4814-ora...e-usb-otg/
Reply
#19
Cool, thanks, will try to make it default OR add a script
Reply
#20
Hi,

on my Orange PI one all stuff I tried out works well.

I do not have speakers so I can not verify that sound is working.
Sometimes i can see some ALSA messages during a emulator is starting,
but I’m not sure what the problem is.
 Or even if there is a problem.

I can also verify that the following bluetooth hardware works well.


* PS4 wireless controller (first revision)
* Bluetooth 4.0 Adapter TP-Link ub400 Nano USB
* Hama generic usb hub (no external power supply)
* Bluetooth wireless keyboard BK3001BA (china Import)

Just two points:

* The Amiga amiberry sems  to be working, except of the cpu speed settings as mentioned here (https://github.com/midwan/amiberry/issues/107)
* The nds emulator drastic quits directly after it was started without an error message.

Please let me know in case you want more detail information.

Best regards
Kai
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Orange pi PC2 davide84e31 25 2,091 Less than 1 minute ago
Last Post: alexkidd
  Orange Pi PC Retroarch - Arcade (Insert Coin function) TnDan 0 51 11-10-2019, 08:22 PM
Last Post: TnDan
Bug Orange Pi PC - reporting bugs found caioandrade 10 982 11-10-2019, 03:01 PM
Last Post: TnDan
  Orange Pi Pc 2 Overheating Broos-E 7 269 11-04-2019, 03:59 PM
Last Post: thedotsteev
  Orange Pi Lite (Slim Version) diegohv 12 708 10-27-2019, 05:41 PM
Last Post: prixes
  No sound - Orange PI PC Plus fredjedimaster 2 185 10-18-2019, 06:54 PM
Last Post: fredjedimaster
  Orange pi ZERO H2 (512 mb) Goodvin-punk 0 138 10-18-2019, 08:41 AM
Last Post: Goodvin-punk
  Fix por usb otg on Orange Pi Plus 2e? saitoh00 2 182 10-15-2019, 09:30 PM
Last Post: saitoh00
Exclamation Orange Pi PC - dangerous problem read caioandrade 1 368 10-03-2019, 02:59 AM
Last Post: alexkidd
  How to transfer roms? ORANGE PI WIN PLUS geezerbutler 8 829 09-28-2019, 01:30 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)