Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
4.3 Full for Orange Pi One
#41
OrangePi PC version checked. The 4.2 orange pi PC version worked on all areas for me, so i figured i'd start with the same for 4.3
- File used for test: RetrOrangePi_v4.3_Armbian_5.97_Orangepipc_Ubuntu_bionic_dev_5.2.14_desktop
- Tested on Pandora X board (h3/1gb/?)
- Cpu speeds was super low, fixed by copying the gpio regulator parts from opi-one and removing the I2C VDD one.
- My base was sun8i-h3-orangepi-pc.dtb, see code below:

Code:
vdd-cpux-regulator {
        compatible = "regulator-gpio";
        regulator-name = "vdd-cpux";
        regulator-type = "voltage";
        regulator-boot-on;
        regulator-always-on;
        regulator-min-microvolt = <0x0010c8e0>;
        regulator-max-microvolt = <0x00155cc0>;
        regulator-ramp-delay = <0x00000032>;
        gpios = <0x0000002d 0x00000000 0x00000006 0x00000000>;
        enable-active-high;
        gpios-states = <0x00000001>;
        states = <0x0010c8e0 0x00000000 0x00155cc0 0x00000001>;
        phandle = <0x0000002d>;
    };

- Sound on HDMI does not work for me. Alsa fixes do not work for me. (Fine in 4.2)
- Upgraded the GB2000s GPIO joystick driver to mainline kernel and fixed it up, works.
- Have some kernel patches for 3.4.113 to add CGA video mode, tested & working, but need to upgrade/port into mainline.

First this first: Any ideas about sound? On 4.2 i only see this relevant info in dmesg:

Code:
[    5.529965] ALSA device list:                                                                                        
[    5.534468]   #0: audiocodec                                                                                        
[    5.538818]   #1: sndhdmi

Mainline is missing any and all Alsa messages or any sound related messages in dmesg. Sad
#42
what is the ' aplay -l ' output? The settings in /etc/asound.conf should match it . If you dont get anything, DTB tweak may go further
#43
Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: allwinnerhdmi [allwinner,hdmi], device 0: 1c22800.i2s-i2s-hifi i2s-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

From dmesg i see big errors:
Code:
[    7.728369] sun4i-codec 1c22c00.codec: ASoC: codec-analog@1f015c0 not registered
[    7.728387] sun4i-codec 1c22c00.codec: Failed to register our card
[    7.731908] sun4i-codec 1c22c00.codec: ASoC: codec-analog@1f015c0 not registered
[    7.731926] sun4i-codec 1c22c00.codec: Failed to register our card
[    7.742009] sun4i-codec 1c22c00.codec: ASoC: Failed to create component debugfs directory
[    7.744570] sun4i-codec 1c22c00.codec: Codec <-> 1c22c00.codec mapping ok

I've card 1 set, but no go. 

It worked on 3.4.113 with no changes whatsoever. #1 was sndhdmi there and that just worked.


Attached Files
.txt   dmesg_4.19.57.txt (Size: 27.32 KB / Downloads: 3)
#44
New kernel, new issues.

Both audio cards were detected fine, sun4i-codec errors are harmless. The culprit is probably this:

[ 2.454417] sun4i-drm display-engine: HDMI-A-1: EDID is invalid:
[ 2.454430] [00] BAD 00 ff ff ff ff ff ff 00 04 c9 01 00 01 00 00 01
[ 2.454433] [00] BAD 01 11 01 03 80 00 12 60 0a 04 c8 80 54 42 90 23
[ 2.454437] [00] BAD 10 48 44 00 08 00 81 80 01 40 81 00 01 01 01 00
[ 2.454440] [00] BAD 01 01 01 01 01 01 00 18 00 00 41 00 24 00 18 08
[ 2.454443] [00] BAD 04 00 00 80 00 00 00 18 00 18 00 10 51 10 0c 00
[ 2.454447] [00] BAD 48 28 45 00 40 04 01 00 00 1e 00 00 00 b0 00 00
[ 2.454450] [00] BAD 0b 00 40 20 14 00 02 20 20 00 00 00 00 00 00 f8
[ 2.454453] [00] BAD 00 00 18 00 40 01 00 00 00 00 00 00 00 00 01 08

Edit /boot/armbianEnv.txt and remove the extraargs part as 720p is being forced, so KMS can autodetect the optimal resolution.

Unexpected behaviour may occur since the image doesnt match your board exactly.
#45
Tried it, but EDID invalid message remains after reboot and/or full power down. Kernel defaults into 1024x768@60 but my tv says stereo is available.
Tried 1920x1080 but it blinks on and off on my screen. 640x480 works. None of these have working sound. Back to 3.4.113 for me and everything is fine :/
TV is a very standard Sony KDL series LED tv. (KDL 40R450C)
#46
As we dont have the issue in other boards nor the hardware to test, it's very hard to troubleshoot. Sorry.
#47
I have a new issue with the beta version on the download page (an issue that I didn't have on the beta here on forum).
wifi don't autoconnect on boot.
everytime i have to insert wpa password, it's very very annoying.
and I've notice that all the issue, audio, the typo on drastic aren't be fixed.
#48
(12-08-2019, 10:11 PM)Asure Wrote: OrangePi PC version checked. The 4.2 orange pi PC version worked on all areas for me, so i figured i'd start with the same for 4.3
- File used for test: RetrOrangePi_v4.3_Armbian_5.97_Orangepipc_Ubuntu_bionic_dev_5.2.14_desktop
- Tested on Pandora X board (h3/1gb/?)

Hi asure,
I'm trying the 4.3 on my Pandora board (h3/512mb).
I used the orangepipc image. My board  is hooked up by vga with sound through the jamma harness.
I changed the asound.conf to card 0 and hw 0 and I have sound through my jamma speaker, which also means sound should be on the 3.5mm jack too.


Any chance you could share your image or a image with a joystick driver? 
Thanks


Possibly Related Threads...
Thread Author Replies Views Last Post
  Amiberry and Game & Watch problem on Orange Pi PC Plus batimanvesgo 0 599 05-04-2020, 05:59 AM
Last Post: batimanvesgo
  Orange Pi Pc Plus - Message at the end of the Shutdown at Emulation Station Nill2016 1 429 05-01-2020, 09:35 PM
Last Post: alexkidd
  Latest orange PI PC2 what is working and what is not: Lamerjack 28 6,558 04-30-2020, 10:50 PM
Last Post: dvs
  Orange pi plus 2E startup problem emkara 2 468 04-29-2020, 06:49 PM
Last Post: emkara
Bug Orange Pi PC - reporting bugs found caioandrade 25 10,392 04-20-2020, 03:05 PM
Last Post: TnDan
  Does not run after full apt update Wizzard 17 2,005 04-16-2020, 10:32 PM
Last Post: OctavioS
  Orange PI Win PLus - restarting djmcg 27 8,911 04-16-2020, 12:04 PM
Last Post: Vitaliy
  Orange pi PC2 davide84e31 152 45,516 03-26-2020, 10:30 PM
Last Post: alexkidd
  Orange Pi Lite (Slim Version) diegohv 27 10,463 03-20-2020, 09:09 PM
Last Post: diegohv
  Retrorange for Orange Pi 3 jurjur 0 477 03-04-2020, 07:00 PM
Last Post: jurjur

Forum Jump:


Users browsing this thread: 1 Guest(s)