Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mupen64Plus-glide64 and rice not working
#1
Both emulators cant play N64 games, -rice just reset and back to menu and -glide64 works only sound, just show a black screen but can control game (its sound when use the joystick)

this is very relevant to me because i just play Super Smash Bros 64 and only is playable on this emulators (only 2 players, more than 2 makes a unplayable lag)

BTW, im using OPI PC
Reply
#2
select runcommand log from retropie section afterwards, so we can have a hint of what's missing (probably some package)
Reply
#3
Sorry for very late reply alex, very grateful about your dedication

log for Glide64:
Quote:Parameters: 
Executing: /opt/retropie/emulators/mupen64plus/bin/mupen64plus.sh mupen64plus-video-glide64mk2 "/home/pi/RetroPie/roms/n64/Super Smash Bros..z64"
 __  __                         __   _  _   ____  _             
|  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___ 
| |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|  
| |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \  
|_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/  
             |_|         https://mupen64plus.org/               
Mupen64Plus Console User-Interface Version 2.5.9

UI-Console: attached to core library 'Mupen64Plus Core' version 2.5.9
UI-Console:             Includes support for Dynamic Recompiler.
Core: Using full mem base
Core: Goodname: Super Smash Bros. (U) [!]
Core: Name: SMASH BROTHERS      
Core: MD5: F7C52568A31AADF26E14DC2B6416B2ED
Core: CRC: 916B8B5B 780B85A4
Core: Imagetype: .z64 (native)
Core: Rom size: 16777216 bytes (or 16 Mb or 128 Megabits)
Core: Version: 1449
Core: Manufacturer: Nintendo
Core: Country: USA
UI-Console Status: Cheat codes disabled.
UI-Console: using Video plugin: 'Glide64mk2 Video Plugin' v2.5.9
UI-Console: using Audio plugin: 'Mupen64Plus SDL Audio Plugin' v2.5.9
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
UI-Console: using Input plugin: 'Mupen64Plus SDL Input Plugin' v2.5.9
UI-Console: using RSP plugin: 'Hacktarux/Azimer High-Level Emulation RSP Plugin' v2.5.9
Video: opening /opt/retropie/configs/n64/Glide64mk2.ini

Core: input plugin did not specify a render callback; there will be no on screen display by the input plugin.
Input: 2 SDL joysticks were found.
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: N64 Controller #1: Using auto-config with SDL joystick 0 ('Twin USB Joystick')
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: N64 Controller #2: Using auto-config with SDL joystick 1 ('Twin USB Joystick')
Input: 2 controller(s) found, 2 plugged in and usable in the emulator
Input: Rumble activated on N64 joystick #1
Input: Rumble activated on N64 joystick #2
Input Warning: Couldn't open rumble support for joystick #3
Input Warning: Couldn't open rumble support for joystick #4
Input: Mupen64Plus SDL Input Plugin version 2.5.9 initialized.
RSP: RSP Fallback disabled !
Core Status: Selected state slot: 1
Core: Using video capture backend: dummy
Core: Game controller 0 (Standard controller) has a Memory pak plugged in
Core: Game controller 1 (Standard controller) has a Memory pak plugged in
Core: Game controller 2 (Standard controller) has a Memory pak plugged in
Core: Game controller 3 (Standard controller) has a Memory pak plugged in
Core: Using CIC type X103
Video Warning: Could not find [SMASH BROTHERS] section in INI file!
Video: Using TEXUMA extension.

&ConfigOpenSection is 0x8cf8ec14
Core Error: SDL video subsystem init failed: No available video device
(II) Setting video mode 1280x720...
(EE) Error setting videomode 1280x720
Video Error: Error setting display mode
Audio: Using resampler src
Audio: Initializing SDL audio subsystem...
Input: Rumble activated on N64 joystick #1
Input: Rumble activated on N64 joystick #2
Input Warning: Couldn't open rumble support for joystick #3
Input Warning: Couldn't open rumble support for joystick #4
Core: Initializing 4 RDRAM modules for a total of 8 MB
Core: Starting R4300 emulator: Dynamic Recompiler
Core: Init new dynarec
Core: ARM CPU Features:, Half, Thumb, FastMult, VFP, ESDP, NEON, VFPv3, TLS, VFPv4, IDIVa, IDIVt
Audio: Initializing SDL audio subsystem...
Core Status: Stopping emulation.
Core: R4300 emulator finished.
Core Status: Rom closed.



I saw the error for RICE and its about missing textures, will try to fix myself, but with glide is another problem, only shows black screen and play sounds (with joysticks working)
Reply
#4
&ConfigOpenSection is 0x8cf8ec14
Core Error: SDL video subsystem init failed: No available video device
(II) Setting video mode 1280x720...
(EE) Error setting videomode 1280x720

you have to edit /opt/retropie/configs/n64/mupen64plus.cfg and fix resolution with a compliant one
same for the /boot/armbianEnv.txt
better choose one you know works better
Reply
#5
video-rice command log:
Quote:Parameters: 
Executing: /opt/retropie/emulators/mupen64plus/bin/mupen64plus.sh mupen64plus-video-rice "/home/pi/RetroPie/roms/n64/Super Smash Bros..z64"
 __  __                         __   _  _   ____  _             
|  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___ 
| |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|  
| |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \  
|_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/  
             |_|         https://mupen64plus.org/               
Mupen64Plus Console User-Interface Version 2.5.9

UI-Console: attached to core library 'Mupen64Plus Core' version 2.5.9
UI-Console:             Includes support for Dynamic Recompiler.
Core: Using full mem base
Core: Goodname: Super Smash Bros. (U) [!]
Core: Name: SMASH BROTHERS      
Core: MD5: F7C52568A31AADF26E14DC2B6416B2ED
Core: CRC: 916B8B5B 780B85A4
Core: Imagetype: .z64 (native)
Core: Rom size: 16777216 bytes (or 16 Mb or 128 Megabits)
Core: Version: 1449
Core: Manufacturer: Nintendo
Core: Country: USA
UI-Console Status: Cheat codes disabled.
UI-Console: using Video plugin: 'Mupen64Plus OpenGL Video Plugin by Rice' v2.5.9
UI-Console: using Audio plugin: 'Mupen64Plus SDL Audio Plugin' v2.5.9
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
UI-Console: using Input plugin: 'Mupen64Plus SDL Input Plugin' v2.5.9
UI-Console: using RSP plugin: 'Hacktarux/Azimer High-Level Emulation RSP Plugin' v2.5.9
Core: input plugin did not specify a render callback; there will be no on screen display by the input plugin.
Input: 2 SDL joysticks were found.
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: N64 Controller #1: Using auto-config with SDL joystick 0 ('Twin USB Joystick')
Input: Using auto-config file at: '/opt/retropie/configs/n64/InputAutoCfg.ini'
Input: N64 Controller #2: Using auto-config with SDL joystick 1 ('Twin USB Joystick')
Input: 2 controller(s) found, 2 plugged in and usable in the emulator
Input: Rumble activated on N64 joystick #1
Input: Rumble activated on N64 joystick #2
Input Warning: Couldn't open rumble support for joystick #3
Input Warning: Couldn't open rumble support for joystick #4
Input: Mupen64Plus SDL Input Plugin version 2.5.9 initialized.
RSP: RSP Fallback disabled !
Core Status: Selected state slot: 1
Core: Using video capture backend: dummy
Core: Game controller 0 (Standard controller) has a Memory pak plugged in
Core: Game controller 1 (Standard controller) has a Memory pak plugged in
Core: Game controller 2 (Standard controller) has a Memory pak plugged in
Core: Game controller 3 (Standard controller) has a Memory pak plugged in
Core: Using CIC type X103
Video: Disabled SSE processing.
Video: Found ROM 'SMASH BROTHERS', CRC 5b8b6b91a4850b78-45
Video: Texture loading option is enabled. Finding all hires textures
Video Warning: Couldn't open hi-res texture directory: /home/pi/.local/share/mupen64plus/hires_texture/SMASH BROTHERS/
Video: Initializing OpenGL Device Context.
Core Error: SDL video subsystem init failed: No available video device
Core Status: Rom closed.

(11-13-2019, 02:34 PM)alexkidd Wrote: &ConfigOpenSection is 0x8cf8ec14
Core Error: SDL video subsystem init failed: No available video device
(II) Setting video mode 1280x720...
(EE) Error setting videomode 1280x720

you have to edit /opt/retropie/configs/n64/mupen64plus.cfg and fix resolution with a compliant one
same for the /boot/armbianEnv.txt
better choose one you know works better

dont know what resolution works better, but my TV is 1366x768 and dont works with that res, will try lower? in mupen64plus i've changed the general video section, but in armbianEnv dont know what resolution put in it
Reply
#6
this should fix the SDL bug:

sudo cp -av /usr/local/lib/libSDL2* /usr/lib/arm-linux-gnueabihf
Reply
#7
reinstalled the system after your response and works without problem, but slower than before (4.2 slim) in both emulators
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  OrangePi Zero Plus 2 - USB not working indevor 13 174 11-27-2019, 11:06 PM
Last Post: alexkidd
  Opi PC2 - Kodi Not Working redilyn 11 550 11-19-2019, 03:08 PM
Last Post: redilyn
  Bluetooth dongle not working on OPi PC DeJaVu 0 169 10-18-2019, 01:33 PM
Last Post: DeJaVu

Forum Jump:


Users browsing this thread: 1 Guest(s)