Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
linux-headers-5.2.14-sunxi
#1
Hi. I wanted to install exfat-linux to use with my exFAT flashdrive, but got this message during installation:

Code:
Building for 5.2.14-sunxi
Module build for kernel 5.2.14-sunxi was skipped since the
kernel headers for this kernel does not seem to be installed.

Tried to install manually:

Code:
root@RetrOrangePi: sudo apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-5.2.14-sunxi
E: Couldn't find any package by glob 'linux-headers-5.2.14-sunxi'
E: Couldn't find any package by regex 'linux-headers-5.2.14-sunxi'

I googled that armbian should be built with option
INSTALL_HEADERS="yes" in config-default.conf but if it's not where can i get linux-headers-5.2.14-sunxi?


i'm using OrangePi PC build.
Reply
#2
wget http://retrorangepi.download/linux-heade..._armhf.deb
sudo dpkg -i linux-headers-dev-sunxi_5.97_armhf.deb

edit: exfat support is enabled on kernel already. You probably need to install exfat filesystem packages only .
Reply
#3
Thank you. Sadly i am getting the same message

Code:
root@RetrOrangePi:~# sudo apt install exfat-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  exfat-dkms
0 upgraded, 1 newly installed, 0 to remove and 37 not upgraded.
Need to get 69.5 kB of archives.
After this operation, 387 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/arter97/exfat-linux/ubuntu eoan/main armhf exfat-dkms all 2.2.0-2arter97-0~201910091437~ubuntu19.10.1 [69.5 kB]
Fetched 69.5 kB in 11s (6108 B/s)
Selecting previously unselected package exfat-dkms.
(Reading database ... 116885 files and directories currently installed.)
Preparing to unpack .../exfat-dkms_2.2.0-2arter97-0~201910091437~ubuntu19.10.1_all.deb ...
Unpacking exfat-dkms (2.2.0-2arter97-0~201910091437~ubuntu19.10.1) ...
Setting up exfat-dkms (2.2.0-2arter97-0~201910091437~ubuntu19.10.1) ...
Loading new exfat-2.2.0-2arter97-0~201910091437~ubuntu19.10.1 DKMS files...
Building for 5.2.14-sunxi
Module build for kernel 5.2.14-sunxi was skipped since the
kernel headers for this kernel does not seem to be installed

I googled how to point DKMS to kernel headers, made symlink

Code:
ln -s /usr/src/linux-headers-$(uname -r)  /lib/modules/$(uname -r)/build

That kinda worked, but still

Code:
Error! Bad return status for module build on kernel: 5.2.14-sunxi (armv7l)
Consult /var/lib/dkms/exfat/2.2.0-2arter97-0~201910091437~ubuntu19.10.1/build/make.log for more information.

Log:

Code:
DKMS make.log for exfat-2.2.0-2arter97-0~201910091437~ubuntu19.10.1 for kernel 5.2.14-sunxi (armv7l)
Mon Oct 14 12:52:20 UTC 2019
make: Entering directory '/usr/src/linux-headers-5.2.14-sunxi'
Makefile:649: arch//Makefile: No such file or directory
make: *** No rule to make target 'arch//Makefile'.  Stop.
make: Leaving directory '/usr/src/linux-headers-5.2.14-sunxi'

I don't understand what else he wants here.

But building from source succeeded after this error

Code:
root@RetrOrangePi:~# cd ~/exfat-linux
root@RetrOrangePi:~/exfat-linux# make; checkinstall
make -C /lib/modules/5.2.14-sunxi/build M=/root/exfat-linux modules
make[1]: Entering directory '/lib/modules/5.2.14-sunxi/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/lib/modules/5.2.14-sunxi/build'
Makefile:23: recipe for target 'all' failed
make: *** [all] Error 2

got this

Code:
root@RetrOrangePi:~/exfat-linux# make; checkinstall
make -C /lib/modules/5.2.14-sunxi/build M=/root/exfat-linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.2.14-sunxi'
  CC [M]  /root/exfat-linux/super.o
  CC [M]  /root/exfat-linux/core.o
  CC [M]  /root/exfat-linux/core_exfat.o
  CC [M]  /root/exfat-linux/blkdev.o
  CC [M]  /root/exfat-linux/fatent.o
  CC [M]  /root/exfat-linux/cache.o
  CC [M]  /root/exfat-linux/nls.o
  CC [M]  /root/exfat-linux/misc.o
  CC [M]  /root/exfat-linux/extent.o
  CC [M]  /root/exfat-linux/xattr.o
  LD [M]  /root/exfat-linux/exfat.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /root/exfat-linux/exfat.mod.o
  LD [M]  /root/exfat-linux/exfat.ko
make[1]: Leaving directory '/usr/src/linux-headers-5.2.14-sunxi'

Finally

Code:
root@RetrOrangePi:~/exfat-linux# sudo modprobe exfat

And it works

Code:
...
/dev/sda1       118G  606M  117G   1% /mnt/Flash
...


(10-14-2019, 10:24 AM)alexkidd Wrote: edit: exfat support is enabled on kernel already. You probably need to install exfat filesystem packages only .

I was asked to uninstall package exfat-fuse during the first try installation, i agreed after seeing the approximate speeds comparison. I thought that the new driver would be better, since I planned to use the disk for different needs
Reply
#4
(10-14-2019, 01:37 PM)Lichtenshtein Wrote:
Code:
root@RetrOrangePi:~/exfat-linux# sudo modprobe exfat
Double check you're loading the new exfat module 'sudo insmod exfat.ko'
Reply
#5
(10-14-2019, 02:52 PM)alexkidd Wrote:
(10-14-2019, 01:37 PM)Lichtenshtein Wrote:
Code:
root@RetrOrangePi:~/exfat-linux# sudo modprobe exfat
Double check you're loading the new exfat module 'sudo insmod exfat.ko'

Hmm. How can I verify if I am using the new one?

Code:
root@RetrOrangePi:~/exfat-linux# sudo insmod exfat.ko
insmod: ERROR: could not insert module exfat.ko: File exists
root@RetrOrangePi:~/exfat-linux# sudo rmmod exfat.ko
rmmod: ERROR: Module exfat is in use
root@RetrOrangePi:~/exfat-linux# umount /dev/sda1
root@RetrOrangePi:~/exfat-linux# sudo rmmod exfat.ko
root@RetrOrangePi:~/exfat-linux# sudo insmod exfat.ko
root@RetrOrangePi:~/exfat-linux# sudo modprobe exfat
Reply
#6
try inserting module after a fresh reboot, if File exists , default module is being loaded automatically

you can either run a script to rmmod it and insert the new one or blacklist default (on /etc/modprobe.d/blacklist.conf) and insert the new one OR replace an existing module (i'm not sure if exfat is a module or builtin)

modinfo can help identifying the correct module
Reply
#7
(10-14-2019, 04:35 PM)alexkidd Wrote: try inserting module after a fresh reboot, if File exists , default module is being loaded automatically

you can either run a script to rmmod it and insert the new one or blacklist default (on /etc/modprobe.d/blacklist.conf) and insert the new one OR replace an existing module (i'm not sure if exfat is a module or builtin)

modinfo can help identifying the correct module

Thank you! Yes, system uses the right one!


Code:
root@RetrOrangePi:~# modinfo exfat
filename:       /lib/modules/5.2.14-sunxi/kernel/fs/exfat/exfat.ko
author:         Samsung Electronics Co., Ltd.
description:    FAT/exFAT filesystem support
license:        GPL
alias:          fs-exfat
depends:
name:           exfat
vermagic:       5.2.14-sunxi SMP mod_unload ARMv7 thumb2 p2v8
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)