Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OrangePi Zero Plus 2 - USB not working
#1
Hey. In this version 4.3 some kind of error USB ports do not work - 3 ports init.
   

If you look and compare with the boot screen of the previous version (4.2):
Do not pay attention to the error in the last line of the USB, it has been fixed
   

And as a result, my gamepad or keyboard does not work, and I can’t get beyond this screen:
   
Reply
#2
Do you acknowledge the problem?
are there any solutions?
what can i try?
Reply
#3
i'm strugging to make it work too.
mainline kernel is very challenging.

Please try a new image : http://retrorangepi.download/RetrOrangeP...top.img.7z

mainline works with kernel overlays: i tried adding usbhost0 and usbhost1 to /boot/armbianEnv.txt but i cannot test at the moment
Reply
#4
Yes! ports are working but rc_tool settings (video \ audio output) are not available
Reply
#5
composite video is not supported on mainline

resolution can also be tweaked in /boot/armbianEnv.txt

edit: did you have to add usbhost0 and usbhost1 ?
Reply
#6
ohhh .. this is very sad! I have a portable system, kernel 4.19.57 is it possible to fix usb in it?
----
Last login: Wed Nov 27 14:44:24 2019 from 192.168.88.254

root@RetrOrangePi:~# lsusb
Bus 006 Device 002: ID 09da:054f A4Tech Co., Ltd.
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 2341:8036 Arduino SA Leonardo (CDC ACM, HID)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@RetrOrangePi:~#
wi-fi work
---
but i can't run images requires srm files, ps1 and megadrive test
Parameters:
Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/megadrive/retroarch.cfg "/home/pi/RetroPie/roms/megadrive/Liquid Space Dodger Version 3.bin" --appendconfig /dev/shm/retroarch.cfg
Failed to open /home/pi/RetroPie/roms/megadrive/Liquid Space Dodger Version 3.srm: No such file or directory
/opt/retropie/supplementary/runcommand/runcommand.sh: line 1006: 3010 Segmentation fault /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-picodrive/picodrive_libretro.so --config /opt/retropie/configs/megadrive/retroarch.cfg "/home/pi/RetroPie/roms/megadrive/Liquid Space Dodger Version 3.bin" --appendconfig /dev/shm/retroarch.cfg

and


Parameters:
Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Silent Hill [RUS] [SLES-01514].cue" --appendconfig /dev/shm/retroarch.cfg
Memcard 2: disabled
Starting PCSX-ReARMed
Running PCSX Version 1.9 (Jul 8 2019).
Init new dynarec
testing if we can run recompiled code..
test passed.
Mapped (RAM/scrp/ROM/LUTs/TC):
80000000/1f800000/1fc00000/08000000/b1e0c000
found BIOS file: SCPH1001.BIN
RGB565 supported, using it
plugin: plugins/builtin_gpu
plugin: plugins/builtin_spu
plugin: plugins/builtin_pad
plugin: plugins/builtin_pad
Plugins loaded.
Loaded CD Image: /home/pi/RetroPie/roms/psx/Silent Hill [RUS] [SLES-01514].cue[+cue].
Track 01 (DATA) - Start 00:02:00, Length 59:59:06
selected sound output driver: libretro
CD-ROM Label: SLES01514
CD-ROM ID: SLES01514
CD-ROM EXE Name: SLES_015.14;1
Failed to open /home/pi/RetroPie/roms/psx/Silent Hill [RUS] [SLES-01514].srm: No such file or directory
/opt/retropie/supplementary/runcommand/runcommand.sh: line 1006: 3166 Segmentation fault /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Silent Hill [RUS] [SLES-01514].cue" --appendconfig /dev/shm/retroarch.cfg
Reply
#7
(11-27-2019, 02:46 PM)indevor Wrote: ohhh .. this is very sad! I have a portable system, kernel 4.19.57 is it possible to fix usb in it?

4.19 is also mainline kernel. You would have to edit DTB file. Procedure is described in : http://orangepi.club/showthread.php?tid=...40#pid8240 and 
https://forum.armbian.com/topic/4814-ora...ment=44756

----

but i can't run images requires srm files, ps1 and megadrive test

srm files is not the issue here. It's segmentation fault, probably caused by video resolution (720p is forced). Change video_fullscreen, fullscreen_x and y in /opt/retropie/configs/all/retroarch.cfg to your settings and it should work.
Reply
#8
How can I edit an img image ?. If I need to make changes on the installed system, then I will not be able to connect to the console, since usb-keyboard does not work
Reply
#9
If you're a Windows user, need 3rd party app with EXT4 filesystem support. Edit /boot/armbianEnv.txt with NotePad++ and add:
overlays=usbhost0 usbhost1 usbhost2 usbhost3
sometimes the app can damage the partition, unmount it safely

I strongly suggest you to upgrade to the latest image/kernel, as we're able to give support more constantly.
Reply
#10
I used the kali virtual machine and did the file editing: /boot/armbianEnv.txt
add: overlays=usbhost0 usbhost1 usbhost2 usbhost3

installing pack: sudo apt-get update
sudo apt-get install device-tree-compiler

and the following commands:

sudo cp sun8i-h3-orangepi-zeroplus2.dtb sun8i-h3-orangepi-zeroplus2.dtb.old
sudo dtc -I dtb -O dts -o sun8i-h3-orangepi-zeroplus2.dtb sun8i-h3-orangepi-zeroplus2.dtb
sudo sed -i -e 's/dr_mode = "otg";/dr_mode = "host";/g' sun8i-h3-orangepi-zeroplus2.dtb
sudo dtc -I dts -O dtb -o sun8i-h3-orangepi-zeroplus2.dtb sun8i-h3-orangepi-zeroplus2.dtb

it did not work! = (
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Mupen64Plus-glide64 and rice not working naik 6 438 11-21-2019, 02:32 AM
Last Post: naik
  Opi PC2 - Kodi Not Working redilyn 11 559 11-19-2019, 03:08 PM
Last Post: redilyn
  Bluetooth dongle not working on OPi PC DeJaVu 0 169 10-18-2019, 01:33 PM
Last Post: DeJaVu
  Orangepi zero plus 2 Allwinner H5 rzwildcard 2 357 10-13-2019, 06:53 PM
Last Post: rzwildcard
  New 4.3 OrangePI PC Image Doesn't boot shawnsdada 32 3,039 10-07-2019, 10:22 AM
Last Post: alexkidd
  Cannot transfer roms to OrangePi Pi PC+ tyrell 7 806 09-26-2019, 09:29 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)