Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Orange Pi PC - random audio error
#1
Bug 
I don't know if anyone has already reported it, here at orange pi pc at the first boot after installing the system it works perfectly, after turning on the second time or restarting the system turns on with random resolution of 1080P or 640x480 and without audio outside the set resolution that is  720P by default, and I have to restart several times to connect normal with audio and 720P, is there any correction for that? Thanks.
Reply
#2
the same problem is happening to me, the audio comes out at the first startup, after it restarts, no more audio comes out, neither in the menu nor in games.

(01-24-2020, 01:47 PM)caioandrade Wrote: I don't know if anyone has already reported it, here at orange pi pc at the first boot after installing the system it works perfectly, after turning on the second time or restarting the system turns on with random resolution of 1080P or 640x480 and without audio outside the set resolution that is  720P by default, and I have to restart several times to connect normal with audio and 720P, is there any correction for that? Thanks.

the same problem is happening to me, the audio comes out at the first startup, after restarting, no more audio comes out, neither in the menu nor in games.
Reply
#3
(01-24-2020, 01:47 PM)caioandrade Wrote: I don't know if anyone has already reported it, here at orange pi pc at the first boot after installing the system it works perfectly, after turning on the second time or restarting the system turns on with random resolution of 1080P or 640x480 and without audio outside the set resolution that is  720P by default, and I have to restart several times to connect normal with audio and 720P, is there any correction for that? Thanks.

the same mistake happens to me
Reply
#4
sudo nano /boot/armbianEnv.txt

edit extraargs line with the desired resolution or remove it , so the optimal resolution is selected automatically (generally 1080p)
Reply
#5
(01-24-2020, 04:38 PM)alexkidd Wrote: sudo nano /boot/armbianEnv.txt

edit extraargs line with the desired resolution or remove it , so the optimal resolution is selected automatically (generally 1080p)

have to set the monitor's maximum resolution? doing this will the audio always work?
Reply
#6
should not be necessary
remove the line and test it (i dont have opi pc to test)
Reply
#7
(01-24-2020, 04:43 PM)alexkidd Wrote: should not be necessary
remove the line and test it (i dont have opi pc to test)

I'll do the test and post the result here. thanks.
Reply
#8
(01-24-2020, 04:43 PM)alexkidd Wrote: should not be necessary
remove the line and test it (i dont have opi pc to test)


editing or deleting the extraargs line, the audio does not work. I tested both options and nothing, this on the orangepi pc.
Reply
#9
(01-24-2020, 04:38 PM)alexkidd Wrote: sudo nano /boot/armbianEnv.txt

edit extraargs line with the desired resolution or remove it , so the optimal resolution is selected automatically (generally 1080p)

mano tentei isso que você falou eu não sei o que pode ser pode ser bug do kernel mesmo, agora ele ficou diferente depois de remover e deixa so essa opção que você falou ele liga aleatoriamente em 1024x768 e sem som sem rodar nenhum emulador da um erro de SDL alguma coisa ai reinicio umas 2 vezes ate ele abrir em 1920x1080p ai sim ele vem com som e tudo rodando, e me parece que muda de TV para TV, se eu por na tv do quarto de 46 polegadas da sony ele liga em 640x480 so depois de algumas reiniciadas ele abre em 1920x1080p não da para entender muito louco, deve ser kernel mesmo, por enquanto vou continuar na 4.2 obrigado pela ajuda.
Reply
#10
Unfortunately it seems to be a kernel feature (KMS), configuration must be set accordingly. It may help running retroarch from command line as it shows all supported resolutions:

/opt/retropie/emulators/retroarch/bin/retroarch -v
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Orange pi PC2 davide84e31 139 20,264 Yesterday, 01:30 PM
Last Post: Tiagounderground
  Latest orange PI PC2 what is working and what is not: Lamerjack 17 1,180 02-21-2020, 11:25 AM
Last Post: Lamerjack
  Orange PI Win PLus - restarting djmcg 24 3,580 02-20-2020, 05:12 PM
Last Post: Lamerjack
  4.3 Full for Orange Pi One giankyfava 46 10,632 02-18-2020, 09:25 AM
Last Post: psygnosis
Bug Orange Pi PC - reporting bugs found caioandrade 22 5,273 02-18-2020, 05:04 AM
Last Post: PREngineer
  Orange Pi Pc+ GemRB / Stratagus Hotab777 5 251 02-15-2020, 04:40 PM
Last Post: Hotab777
  Orange Pi Lite (Slim Version) diegohv 26 5,222 02-14-2020, 07:07 PM
Last Post: ceccobeppe
  Orange Pi Pc+ DosBox troubles Hotab777 4 469 01-18-2020, 10:13 AM
Last Post: Hotab777
  will work on orange pi plus 2? Folko 1 282 01-13-2020, 09:29 PM
Last Post: alexkidd
Question Orange Pi Prime KhanhDTP 4 476 01-09-2020, 02:12 AM
Last Post: KhanhDTP

Forum Jump:


Users browsing this thread: 1 Guest(s)