Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating Amiberry
#1
Hey all,

I've downloaded the latest image for my OrangePi PC and I've noticed Amiberry is around a year old. So, I thought I'd try to update it. 

Went into the RetroPie menu and launched the config package
Updated the Retrorangepi setup script
Navigated to the additional packages menu / Amiberry
Selected update from Source
The update fails due to missing files:libpng-dev libmpeg2-4-dev zlib1g-dev libsdl2-image-dev libsdl-ttf-dev

So, I quit the utility, and installed said files manually (took some faffing around)
Relaunched the updater and it fails again with this error: Makefile:206: *** Unknown platform:H3-mali-sdl2.

I've tried to compile this manually by cloning the git repo and after much faffing around, installing various libs, it finally compiled. But upon launching it, I get an error stating no video device was found

What am I doing wrong?
Reply
#2
Some tweaks are still needed, as the compiler tries to install libsdl2-dev from the ubuntu repo and it drags a lot of other dependencies that conflicts with our custom SDL2 (with KMS backend) and Mali OpenGL ES.

I was able to compile Amiberry v3.1 myself, but i felt a performance drop. Please check for yourself: http://retrorangepi.download/amiberry .
Replace the one at /opt/retropie/emulators/amiberry/
Reply
#3
Thanks a lot, that worked.
Was the performance drop you noticed compared to v.2.2.5? I haven't done any methodical testing with the older version yet as I got stuck with Shadow of the Beast 3 (ShadowOfTheBeast3_v1.6_0016.lha), the first game I tested.

Once you're past the opening cinematic and let the game run its demo with music, the audio is really clipped on my OrangePI PC. It runs far better on my RPI 3B, although you hear the occasional clip.

According to htop, the CPU and RAM aren't anywhere being maxed out, so I wonder what's going on.
Reply
#4
yes, compared to v2.25
built successfully from a newer commit (circa sep 2019) and performance seems to be very good
please try: http://retrorangepi.download/amiberry_sep19 (rename to amiberry after downloading)
Reply
#5
Thanks.
I seem to be getting the same performance with it, but I've only tested a very limited set of games.
Shadow of the Beast 3 still has the same audio clipping.

Looking closer at htop, I may have been wrong on CPU utilisation. Not sure I'm reading this right, but it seems one core is maxed out?

https://i.imgur.com/zwr7Le9.png
Reply
#6
Well, after some more faffing around, I installed the SDL2 version of Amiberry on Raspberry Pi 3B and the peformance is as disastrous as on the OrangePI PC. I'm still using SotB 3 as a benchmark and the audio clips like crazy on the demo screen.

The dispmanx version on the RPI works fine.
Reply
#7
I will gather some more info to talk to Dimitris (midwan) , amiberry developer
Reply
#8
(02-27-2020, 06:03 PM)alexkidd Wrote: Some tweaks are still needed, as the compiler tries to install libsdl2-dev from the ubuntu repo and it drags a lot of other dependencies that conflicts with our custom SDL2 (with KMS backend) and Mali OpenGL ES.

I was able to compile Amiberry v3.1 myself, but i felt a performance drop. Please check for yourself: http://retrorangepi.download/amiberry .
Replace the one at /opt/retropie/emulators/amiberry/

Hi. Glad i found this post as I too am trying to get amiberry installed and working on my Orangepi Pc plus.
where do i put the file that is downloaded as you say to replace a file but there isnt the directory there in the first place.

is it possible to create a step by step guide to get this working please.

My old Orangepi Lite ran this great. would be nice to have it working on this.

Thanks in advance.
Reply
#9
I made a video of Shadow of the Beast 3 on my Retrostone 2. It uses the version Alex is talking about.
https://www.dropbox.com/s/ee26r48p3ihhy8...3.mp4?dl=0
Audio seems to be fine ingame when using Blitter on Immediate and With Fast Copper on.
Reply
#10
How do you change the themes?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Amiberry Update. Lamerjack 5 42 Yesterday, 03:11 PM
Last Post: Lamerjack
  Amiberry Configs. Lamerjack 8 351 03-28-2020, 02:28 PM
Last Post: alexkidd
  Amiberry issue yolkfolk 2 137 03-20-2020, 03:25 AM
Last Post: yolkfolk
  Amiberry and whdload. Lamerjack 3 642 12-22-2019, 11:55 PM
Last Post: alexkidd
  Amiberry CPU turbo/fastest mode does not work properly klaute 2 878 11-03-2019, 09:53 PM
Last Post: alexkidd

Forum Jump:


Users browsing this thread: 1 Guest(s)