Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Does not run after full apt update
#1
Hi, I am just starting with Retrorange and I like it that it is basically Armbian which I could use also for another things (printserver, mpd)

I noticed that the Retrorange GUI fails to run after I update all packages using apt. I see some SDL error or something. Can I fix it somehow? I would like to have fully updated system.

I made apt dist-upgrade, which went fine, but there were some 16 not upgraded packages, so I upgraded them one by one and then Retrorangepi does not start after reboot.
When I upgraded just without the latest 16 packages, it runs fine though. So those packages are held on purpose, because they are some special versions?
#2
(04-09-2020, 07:32 AM)Wizzard Wrote: Hi, I am just starting with Retrorange and I like it that it is basically Armbian which I could use also for another things (printserver, mpd)

I noticed that the Retrorange GUI fails to run after I update all packages using apt. I see some SDL error or something. Can I fix it somehow? I would like to have fully updated system.

I made apt dist-upgrade, which went fine, but there were some 16 not upgraded packages, so I upgraded them one by one and then Retrorangepi does not start after reboot.
When I upgraded just without the latest 16 packages, it runs fine though. So those packages are held on purpose, because they are some special versions?

Never update!
Anyway, yesterday there was an update of retropie setup.
You can try this:
Cd Retropie-Setup
sudo ./retropie_setup
do the script update.
and a new menu option "depends" will appear.
Try to recompile sdl and mesa....
Anyway probably you will have to reflash.
First rule of Orangepi Club "never update"
Second rule of Orangepi Club "NEVER update"
#3
Ok, I thought so, anyway, I like my system updated, so at least I will know that it is not recommended Smile
Thank you very much!
#4
This is the fix to kept back packages. If you want to unhold them, test and report any bug
https://github.com/retr0rangepi/RetrOrangePi/issues/68

edit: to fix SDL2 error, try this:
sudo cp -av /usr/local/lib/libSDL2* /usr/lib/arm-linux-gnueabihf/
Ctrl+D
#5
Thank you very much, I tried that and rebooted, but did not help.

Error creating SDL window.
Could not initialize EGL
Renderer failed to initialize.
Window failed to initialize.
#6
cd /usr/lib/arm-linux-gnueabihf
ls -l libEGL* libGLES* libgbm* libwayland-egl*

Post a screenshot
#7
Ok, before I tried that with unhloding all the packages.

Now I unheld only these packages:

sudo apt-mark unhold libsdl2-dev libgl1* libegl* libgles* libgbm* libwayland-egl*

and the rest 2 I let held.

Now I will try to unhold the latest 2 and will post the results.

edit:

after updating all and rebooting it does not start again. After SDL fix:

   
#8
Run the SDL2 fix too
#9
I inserted the screen to previous post.
#10
found the issue

GBM and Wayland EGL libraries must be symbolic links to the Mali library

run these:

cd /usr/lib/arm-linux-gnueabihf
sudo ln -sf libMali.so libwayland-egl.so.1.0.0
sudo ln -sf libMali.so libgbm.so.1.0.0
Ctrl D


Possibly Related Threads...
Thread Author Replies Views Last Post
  Retropie Setup update. Lamerjack 1 384 04-09-2020, 10:14 AM
Last Post: alexkidd
  Amiberry Update. Lamerjack 5 570 04-07-2020, 03:11 PM
Last Post: Lamerjack
  4.3 Full for Orange Pi One giankyfava 47 18,011 03-01-2020, 04:35 AM
Last Post: akira84
  how to get linux 5.2.14 kernel source about RetrOrangePi 4.3 FULL lyric1984 8 1,912 02-28-2020, 08:43 AM
Last Post: Hotab777
  RetrOrangePI Segfault after system update ebonflame 2 978 11-21-2019, 06:30 AM
Last Post: ebonflame

Forum Jump:


Users browsing this thread: 1 Guest(s)